Bug 526967

Summary: KMS: slow 3d
Product: [Fedora] Fedora Reporter: Alexey Kuznetsov <axet>
Component: xorg-x11-drv-atiAssignee: Jerome Glisse <jglisse>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: awilliam, beland, brianmury, canthony, dannybaumann, DoDoEntertainment, extigyro, jglisse, ma, omeddragon, savelov, xgl-maint
Target Milestone: ---Keywords: CommonBugs, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: card_R500/mM https://fedoraproject.org/wiki/Common_F12_bugs#ati-kms-slow
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-04 02:34:59 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 507684    
Attachments:
Description Flags
nomodeset - Xorg.0.log
none
nomodeset - messages
none
KMS - Xorg.0.log
none
KMS - messages
none
KMS - dmesg
none
nomodeset - dmesg
none
nomodeset - tuxracer (slow+broken sky)
none
KMS - tuxracert (fast and normal sky) none

Description Alexey Kuznetsov 2009-10-02 14:45:15 EDT
As normal boot my 3d applications work at half speed. When i add nomodeset param to kerenl everyting start to go at normal speed.

Only one abnormal application here is tuxracer. When i do normal boot (without nomodeset) tuxracer work at 40fps, but OpenArena work at 30. When i do nomodeset boot tuxracer work at 10fps with gliches on screen, OpenArena work at 100-150 fps.

Same for glxgears. Normal boot: 600fps, Nomodeset boot: 2500fps

I use F12-rawhide with last updates.
Comment 1 Matěj Cepl 2009-10-05 20:44:44 EDT
As for measuring 3D speed with glxgears see http://qa-rockstar.livejournal.com/7869.html. Otherwise you are right, and please attach the usual combo -- /var/log/Xorg.0.log, /var/log/messages and output of dmesg to this bug as separate uncompressed attachments.
Comment 2 Alexey Kuznetsov 2009-10-06 04:50:05 EDT
Thanks for the link. But in my case i have 104fps for teapot mesa test with 'nomodeset' kernel parameter, and 74 fps with normal KMS boot.
Comment 3 Alexey Kuznetsov 2009-10-06 04:50:39 EDT
Created attachment 363798 [details]
nomodeset - Xorg.0.log
Comment 4 Alexey Kuznetsov 2009-10-06 04:52:44 EDT
Created attachment 363799 [details]
nomodeset - messages
Comment 5 Alexey Kuznetsov 2009-10-06 04:56:06 EDT
Created attachment 363800 [details]
KMS - Xorg.0.log
Comment 6 Alexey Kuznetsov 2009-10-06 04:57:43 EDT
Created attachment 363801 [details]
KMS - messages
Comment 7 Alexey Kuznetsov 2009-10-06 04:58:29 EDT
Created attachment 363802 [details]
KMS - dmesg
Comment 8 Alexey Kuznetsov 2009-10-06 05:02:24 EDT
Created attachment 363803 [details]
nomodeset - dmesg
Comment 9 Alexey Kuznetsov 2009-10-06 12:48:55 EDT
Created attachment 363856 [details]
nomodeset - tuxracer (slow+broken sky)
Comment 10 Alexey Kuznetsov 2009-10-06 13:04:09 EDT
Created attachment 363858 [details]
KMS - tuxracert (fast and normal sky)
Comment 11 Alexey Kuznetsov 2009-10-06 13:35:33 EDT
openarena work appositely (kms - make it slower, nomodeset - faster)
Comment 12 Alexey Kuznetsov 2009-10-06 13:36:36 EDT
openarena/mesa teapot/quakelive - (kms - make it slower, nomodeset - faster)  

also openarena cant control screen brightness.
Comment 13 Jerome Glisse 2009-10-06 14:59:36 EDT
KMS is still slower than UMS+DRI1 for various reasons we are working on them, things should be better in Fedora12 and they will get even more better in Fedora13. I think it should be changed to not a bug (don't have right to do that yet).
Comment 14 Alexey Kuznetsov 2009-10-06 15:40:11 EDT
i told about f12.

my rawhide version, still unable to run games i think that is problem.

for kms mode i can play for:
- tuxracer (40fps)
can't:
- any other opensource games run terribly slow
- wine games (guildwars) works terribly slow

for nomodeset i can play:
- quakelive

can't:
- tuxracer run at 10 fps
- openarena cant control screen brightness
- wine games (guildwars) works terribly slow (10fps, against 70fps under win, or 30fps under f10)

- no suspend mode (stuck at resume).


so.. i hope to see f12 one (probably nomodeset) full featured mode. can you suggest what is better to do? create new bug reports or keep all info here?
Comment 15 Matěj Cepl 2009-11-05 12:17:23 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 16 Alexey Kuznetsov 2009-11-05 12:55:18 EST
i confirm this issues for f12 with last updates
Comment 17 Jerome Glisse 2009-11-09 05:04:27 EST
KMS is slower than UMS, a lot of things aren't done yet when it comes to 3D and KMS. We won't be able to improve much the situation for fedora 12 but i hope that we will have enough improvement to make the situation a lot better in fedora 13.
Comment 18 Bug Zapper 2009-11-16 08:12:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Jerome Glisse 2009-11-20 12:52:00 EST
*** Bug 539525 has been marked as a duplicate of this bug. ***
Comment 20 Nenad Mikša 2009-11-20 13:03:09 EST
It's not only 3D. The problem is also with 2D acceleration, at least in OpenOffice Impress - it's impossible to perform a decent presentation with lots of animations on laptop+projector configuration with presenter view. If I use screen mirroring, animations are a bit faster, but I still have to wait more than a minute for some animations to perform.
Comment 21 Miro Hadzhiev 2009-11-25 05:08:20 EST
Not only Impress but also Flash-based clips in Firefox/Konqueror are behaving very poorly and there are a lot of skipped frames and flickering.

Video card: Mobility X1600 (rv515)

I turned off the KMS (using "nomodeset") and the performance is just the same... no real effect (maybe only the flickering is a bit less when KMS is off).

One more thing, when you watch a video clip for longer than 1/2 minutes and the picture of the video is dynamic (the scenes are often changed and so the colours, too), the fan (I think on my Graphic PU, not on the CPU) starts to "rock'an'roll".
Comment 22 Miro Hadzhiev 2009-11-25 05:38:09 EST
Even sometimes the X Server is terminated when the window of KWrite is maximized. (and maybe it's the same with other programs, I have not tested it enough but when xorg.0.log file is open with KWrite and the windows is double-clicked in order to be maximized - X Server closes).
Comment 23 Craig Anthony 2009-11-29 03:48:03 EST
After installing F12+latest updates on my ThinkPad T60p [8744-5BU] with Radeon Mobility X1400, OpenOffice.org Impress was basically unusable due to slow performance.  When attempting to do a slideshow, Xorg is pegged at 100% CPU and everything else in X hangs for many seconds.  This problem did not reproduce after adding the "nomodeset" kernel option.  Seems to be a major performance regression for 2D as well, disabling Compiz had no effect either.
Comment 24 Nenad Mikša 2009-11-29 07:17:29 EST
I tried the solution from AdamW from Phoronix forums (http://www.phoronix.com/forums/showthread.php?t=20467&page=2#16) and I can now do a slideshow with KMS with less troubles, and even 3D performance was enhanced, but still not as it is without KMS...
Comment 25 osman 2010-02-11 13:31:06 EST
quake live I need a solution how make work everything I really need a some thing that are missing in the game is that my esc and hub dont work at all
Comment 26 Christopher Beland 2010-02-12 17:02:05 EST
Nominated for F13Target because this is listed on Common Bugs.
Comment 27 Danny Baumann 2010-04-25 08:02:45 EDT
Similar problem here (F13, X800XL [R430] AGP). With KMS, e.g. compiz is unusably slow (Alt+Tab with 1 window open takes > 2 seconds). With UMS or with KMS + indirect rendering, compiz gets into a usable state.
Comment 28 Bug Zapper 2010-11-04 05:41:29 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 29 Bug Zapper 2010-12-04 02:34:59 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.