Bug 539525 - Terrible performance with KMS
Terrible performance with KMS
Status: CLOSED DUPLICATE of bug 526967
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-20 08:29 EST by Nenad Mikša
Modified: 2009-11-20 12:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-20 12:52:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nenad Mikša 2009-11-20 08:29:10 EST
Description of problem:
While using KMS, the rendering speed of xorg-x11-drv-ati driver is terrible. Glxgears shows only 700 FPS, and OpenOffice Impress animations are very slow or even freeze the system.
On the other hand, if booting with the nomodeset option, rendering speed increases a lot: glxgears shows 1700 FPS, and OpenOffice Impress works normally.

The graphics card is ATi Mobility Radeon X1600.


Version-Release number of selected component (if applicable): xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.i686


How reproducible:
Acquire ATi Radeon X1xxx card, boot with KMS enabled and measure rendering speed. Then boot with KMS disabled and remeasure rendering speed.

Steps to Reproduce:
see How reproducible.
  
Actual results:
Rendering speed is slow.

Expected results:
Rendering speed should be at least as fast as without using KMS.


Additional info:

I supposed that KMS is designed to increase the graphics performance, not to decrease it. Am I wrong?
Comment 1 Jérôme Glisse 2009-11-20 12:52:00 EST

*** This bug has been marked as a duplicate of bug 526967 ***

Note You need to log in before you can comment on or make changes to this bug.