This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 527315

Summary: Custom Dictionary does not work in Enchant
Product: [Fedora] Fedora Reporter: Dmytro Taranovsky <dmytro>
Component: enchantAssignee: Marc Maurer <uwog>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: bojan, cwickert, kmilos, uwog
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: enchant-1.6.0-1.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-20 22:23:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 507684    

Description Dmytro Taranovsky 2009-10-05 18:48:26 EDT
Steps to reproduce:
In an application such as gedit, evolution, or abiword (they use Enchant),  add a word to the spell-check dictionary.  Close the application and reopen it, and that word will continue to be marked as a spelling error.

My analysis has shown that the word gets added to the custom dictionary, but that when the application starts again, it calls
open("/home/dmytro/.config/enchant/en_US.dic", O_WRONLY|O_CREAT|O_TRUNC, 0666)
and thus erasing all words from the dictionary.
Comment 1 Miloš Komarčević 2009-11-11 17:34:20 EST
I can confirm this as well with latest Rawhide. It's very annoying, lost my dictionary I was building up until F11.
Comment 2 Miloš Komarčević 2009-11-12 13:36:21 EST
Had a look through AbiSource repos and BZ and found the patch that fixes this:

http://www.abisource.com/viewvc?view=rev&revision=28175
http://bugzilla.abisource.com/show_bug.cgi?id=12350

Could we have this backported and packaged for F12 updates asap please?
Comment 3 Bug Zapper 2009-11-16 08:17:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bojan Smojver 2009-12-02 18:51:26 EST
I see this with Evo 2.28.
Comment 5 Miloš Komarčević 2009-12-18 10:24:40 EST
Wow, more than two months. And here I was thinking data loss was an issue Fedora QA takes seriously... Anybody reading these at all?

Meanwhile, bug #544473 does manage to attract maintainer's attention?! What gives?
Comment 6 Dmytro Taranovsky 2010-03-27 14:19:32 EDT
This bug is also present in the Fedora 13 development branch -- I tested with the desktop nightly compose from 20100326.  Adding to Fedora 13 target to increase visibility.
Comment 7 Fedora Update System 2010-04-01 18:09:54 EDT
enchant-1.6.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/enchant-1.6.0-1.fc12
Comment 8 Marc Maurer 2010-04-01 18:12:15 EDT
Fixed by releasing enchant 1.6.0 and pushing the updated version to F12-updates-testing, F13-updates-testing, and rawhide. Please test and approve if it works for you.
Comment 9 Dmytro Taranovsky 2010-04-02 00:26:24 EDT
I installed the fc13 build (from koji) and it fixes the bug for me (I did not not test the fc12 build, but I expect that it would work as well).
Comment 10 Fedora Update System 2010-04-03 00:43:27 EDT
enchant-1.6.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update enchant'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/enchant-1.6.0-1.fc12
Comment 11 Fedora Update System 2010-04-20 22:23:17 EDT
enchant-1.6.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Kevin Kofler 2010-04-21 19:06:01 EDT
*** Bug 584524 has been marked as a duplicate of this bug. ***