Bug 530045

Summary: Dep versions in spec file
Product: [Fedora] Fedora Reporter: Ed Avis <ed>
Component: perl-Module-InstallAssignee: Steven Pritchard <steve>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 12CC: perl-devel, steve
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-06 11:38:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ed Avis 2009-10-21 10:24:06 UTC
The spec file doesn't give versions for some requirements, this tightens it up:

--- perl-Module-Install.spec~   2009-07-27 16:39:39.000000000 +0100
+++ perl-Module-Install.spec    2009-10-21 11:19:31.000000000 +0100
@@ -15,10 +15,10 @@

 BuildRequires:  perl(Archive::Tar)
 BuildRequires:  perl(CPAN)
-BuildRequires:  perl(Devel::PPPort)
-BuildRequires:  perl(ExtUtils::Install)
+BuildRequires:  perl(Devel::PPPort) >= 3.16
+BuildRequires:  perl(ExtUtils::Install) >= 1.52
 BuildRequires:  perl(ExtUtils::MakeMaker)
-BuildRequires:  perl(ExtUtils::ParseXS)
+BuildRequires:  perl(ExtUtils::ParseXS) >= 2.19
 BuildRequires:  perl(File::Remove) >= 1.42
 BuildRequires:  perl(File::Spec)
 BuildRequires:  perl(JSON)

Comment 1 Ed Avis 2009-10-21 10:27:24 UTC
Note that according to its Makefile.PL, Module::Install requires Devel::PPPort
version 3.16.  But perl 5.10, currently the version in rawhide, only provides
3.13.  I don't know what you will decide to do about this.

Comment 2 Bug Zapper 2009-11-16 13:56:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Marcela Mašláňová 2010-08-06 11:38:42 UTC
BuildRequires:  perl(Devel::PPPort)
This was already fixed.