Bug 530555

Summary: Too small default /boot
Product: [Fedora] Fedora Reporter: Alexander Boström <abo>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: anaconda-maint-list, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-13.8-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-04 15:25:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alexander Boström 2009-10-23 12:51:00 UTC
Description of problem:
The default /boot is too small to allow preupgrade to work.

Version-Release number of selected component (if applicable):
F12 Beta, Anaconda 12.37

How reproducible:
Always

Steps to Reproduce:
1. Choose automatic partitioning
  
Actual results:
A /boot of around 200MB is created.

Expected results:
A /boot of around 250MB is created.

Additional info:
For example, on my F11 machine, with a ~200MB (190MB) /boot, I'm unable to preupgrade to F12 Beta because the three kernels+initrd I have in /boot, plus preupgrade data plus what Anaconda wants to install won't fit (bug 530541). To make preupgrade from F12 to later releases possible it seems more room is needed.

The dracut initramfs files in F12 seems to be larger than the initrds in F11, though perhaps that's the kernel debug data which won't be in the F12 release?

So https://bugzilla.redhat.com/show_bug.cgi?id=510970#c7 seems wrong.

Comment 1 Alexander Boström 2009-10-23 12:57:06 UTC
Ok, so I have some kdump images as well and a couple of small memtest images too.

# du -sh /boot/*
93K     /boot/config-2.6.29.6-217.2.16.fc11.x86_64
95K     /boot/config-2.6.30.5-43.fc11.x86_64
95K     /boot/config-2.6.30.8-64.fc11.x86_64
228K    /boot/efi
118K    /boot/elf-memtest86+-2.11
354K    /boot/grub
3.6M    /boot/initrd-2.6.29.6-217.2.16.fc11.x86_64.img
3.7M    /boot/initrd-2.6.30.5-43.fc11.x86_64.img
1.9M    /boot/initrd-2.6.30.5-43.fc11.x86_64kdump.img
3.7M    /boot/initrd-2.6.30.8-64.fc11.x86_64.img
2.2M    /boot/initrd-2.6.30.8-64.fc11.x86_64kdump.img
13K     /boot/lost+found
116K    /boot/memtest86+-2.11
1.6M    /boot/System.map-2.6.29.6-217.2.16.fc11.x86_64
1.7M    /boot/System.map-2.6.30.5-43.fc11.x86_64
1.7M    /boot/System.map-2.6.30.8-64.fc11.x86_64
141M    /boot/upgrade
3.0M    /boot/vmlinuz-2.6.29.6-217.2.16.fc11.x86_64
3.3M    /boot/vmlinuz-2.6.30.5-43.fc11.x86_64
3.3M    /boot/vmlinuz-2.6.30.8-64.fc11.x86_64
# df -h /boot
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1             190M  177M  3.7M  98% /boot

Comment 2 Chris Lumens 2009-11-04 15:25:18 UTC
I've bumped it up to 250 MB in anaconda-13.8, but the ever changing /boot size game isn't one we want to play too many times.  I advise you to try to keep the number of installed kernels to a minimum.  Incidentally, that should cause any operation involving rpm to run faster too as you'll have far fewer files with similar names on the system.