Bug 510970 - Default/necessary size of /boot
Default/necessary size of /boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 515379 529551 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 19:02 EDT by Scott Wilburn
Modified: 2010-02-13 01:19 EST (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-07 10:07:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
ddumas: fedora_requires_release_note?


Attachments (Terms of Use)
Anaconda dump (153.13 KB, text/plain)
2009-07-12 19:03 EDT, Scott Wilburn
no flags Details

  None (edit)
Description Scott Wilburn 2009-07-12 19:02:15 EDT
Description of problem:

Unable to install F11 from CDs due to anaconda crash. Anaconda aborts during transfer of install image to disk saying probably out of disk space.

Version-Release number of selected component (if applicable):


How reproducible:

Every time

Steps to Reproduce:
1. Boot from F11 install CD disc 1
2. Select defaults (except custom disk layout)
3. 
  
Actual results:

Installer quits as described

Expected results:

Successful installation

Additional info:

Using 16 GB SSD with three partitions:

sda1  /boot  100 MB
sda2  swap     1 GB
sda3  /       14 GB

Log file attached
Comment 1 Scott Wilburn 2009-07-12 19:03:02 EDT
Created attachment 351411 [details]
Anaconda dump
Comment 2 Scott Wilburn 2009-07-17 00:23:48 EDT
This is not a bug. It might should be an RFE instead. The problem was 100 MB is too small for /boot during the install process. Increasing to 500 MB fixed it. Two notes:

1. The install guide recommends 100 MB for /boot. This worked up to F10, but not for F11. The documentation should be changed.

2. Ideally, anacondo would warn at the time of partitioning if /boot is too small for the install to succeed.
Comment 3 Denise Dumas 2009-07-23 16:39:36 EDT
Release note at least for F12 Beta - also Install Guide fix!
Comment 4 Rahul Sundaram 2009-07-23 16:52:03 EDT
Added to

https://fedoraproject.org/wiki/Fedora_12_Alpha_release_notes
Comment 5 Chris Lumens 2009-07-23 23:56:16 EDT
Fixed the obvious typo causing the traceback.  We still need to address the underlying cause, I suppose.
Comment 6 John J. McDonough 2009-08-03 15:06:00 EDT
So, 100 Mb is too small, and 500 Mb is plenty, what is the right number for the Install Guide?
Comment 7 Chris Lumens 2009-08-03 15:11:42 EDT
anaconda currently defaults to 250 MB for /boot.
Comment 8 Ruediger Landmann 2009-08-03 18:48:24 EDT
I've increased the suggested minimum in the Installation Guide to 250 MB; this will become visible the next time that we republish the guide.
Comment 9 Andy Lindeberg 2009-08-04 11:03:47 EDT
*** Bug 515379 has been marked as a duplicate of this bug. ***
Comment 10 Robert Scheck 2009-08-10 12:30:00 EDT
The only bug in this bug report is, that /boot has to be 250 or 500 MB, that
is (sorry for the clear wording) totally crap for a couple of installed Linux 
kernels having ~ 50 MB in the end in total.

Please fix Anaconda or whatelse, that ~ 100 MB for /boot are much enough...
Comment 11 Robert Scheck 2009-08-10 12:39:31 EDT
Just to add something forgotten here:

/dev/cciss/c0d0p1      97M   20M   73M  21% /boot

Even ~ 50 MB for /boot should work and be much enough when looking to my own
system right now.
Comment 12 Bill Nottingham 2009-08-10 12:44:30 EDT
This is all because of dract. See bug 516230.
Comment 13 Bill Nottingham 2009-08-10 12:44:46 EDT
Excuse me; dracut and preupgrade.
Comment 14 Robert Scheck 2009-08-10 13:29:36 EDT
If I got Harald correct during LinuxTag, dracut should be more efficient
compared to current mkinitrd - otherwise there's IMHO no real benefit...
Comment 15 Paul W. Frields 2009-08-10 16:33:00 EDT
The extra size is required by preupgrade to store the install image for use after rebooting during the upgrade process.
Comment 16 Harald Hoyer 2009-08-12 04:42:00 EDT
(In reply to comment #14)
> If I got Harald correct during LinuxTag, dracut should be more efficient
> compared to current mkinitrd - otherwise there's IMHO no real benefit...  

You mean no real benefit other than:
- replacing mkinitrd/nash, which is very difficult to maintain
- modular
- easy to extend
- one image can boot everything
Comment 17 Chris Lumens 2009-08-21 11:11:04 EDT
We've already got a bug against dracut tracking the initrd file size, so there's really no point in keeping this bug open too.  We'd like to handle this by making sure the initrds are appropriately sized, not by just increasing /boot every time someone requests it.
Comment 18 Jerry Vonau 2009-08-27 21:37:33 EDT
id.backend._loopbackFile: /mnt/sysimage/boot/rhinstall-install.img

Any reason for backend.py to copy install.img from the cd/dvd to "/boot" rather than using "/" for the rhinstall-install.img on the target system? That is what triggered this bug to begin with, not enough room in /boot.
Comment 19 Paul P Komkoff Jr 2009-10-20 17:47:18 EDT
Shall I take all my servers offline before yum upgrade because all of them have 100M /boot?
Comment 20 Harald Hoyer 2009-10-21 03:26:07 EDT
(In reply to comment #19)
> Shall I take all my servers offline before yum upgrade because all of them have
> 100M /boot?  

Install dracut in F-11... edit /etc/dracut.conf and enable the host-only option.
This will make the image ~5MB instead of 10MB.
Comment 21 David Lehman 2009-10-21 12:15:44 EDT
*** Bug 529551 has been marked as a duplicate of this bug. ***
Comment 22 Alexander Boström 2009-10-23 08:51:56 EDT
(In reply to comment #7)
> anaconda currently defaults to 250 MB for /boot.  

I had to check that: bug 530555
Comment 23 Harald Hoyer 2009-10-23 09:44:10 EDT
initrd's are _not_ created by dracut.
Comment 24 James Heather 2009-11-13 04:10:23 EST
I'm not entirely following this. Is the effect that anyone with F11 and a 200MB /boot partition simply won't be able to upgrade to F12?

If so, that will hit thousands of people. All of my machines have a 200MB /boot because that's what the default was when I first installed. (Some machines were fresh F11 installs; some were upgraded from earlier releases.)
Comment 25 Rob Stewart 2009-11-13 21:44:58 EST
James Heather is right, HOW is this not regarded as a bug? and a serious one at that?

I have come from Fedora 10, through to Fedora 11. The setup in Fedora 10 was as was recommended by the installer, I did not make any changes to the partition configuration at all. So I was left with a 200mb /boot partition, just like James Heather, above.

So I have just ran preupgrade and, sure enough, during the anaconda run after the reboot, I get "you need more space on the following file systems: 21mb on /mnt/sysimage/boot "


Am I missing something, or can someone tell me how this is NOT going to affect many many people like myself? For now, I have just had to boot back into my Fedora 11 PC, waiting for a response. I do not expect to have a do a full re-install.

Note: The auto-setup for my Fedora 10 was a 200mb /boot partition. Now this is not enough for preuprade upgrade from Fedora 11 to Fedora 12. Is this not a massive fail ?
Comment 26 Rob Stewart 2009-11-13 21:48:43 EST
(In reply to comment #7)
> anaconda currently defaults to 250 MB for /boot.  

That has not always been the case. There will be many people out there, like myself and James Heather who used the partitioner at Fedora install, which left a 200mb partition for /boot. This is now causing me a problem, as it will come next week when other users try to run the preupgrade.
Comment 27 Rob Stewart 2009-11-13 22:26:18 EST
update:

Note that this problem was openly acknowledged here:
http://meetbot.fedoraproject.org/fedora-meeting/2009-11-13/fesco.2009-11-13-17.00.log.html

But an update to preupgrade is pending in the updates repository for version 1.1.3 which come up with the more useful message: "Low disk space detect in /boot" ... "we recommend that you free up xMB by deleting old kernels or the upgrade may not run".


It's not ideal (prevention better than the cure), but this warning at least prevents users from slipping into the Anaconda installer to find it fails.
Comment 28 James Heather 2009-11-16 05:27:54 EST
> Note that this problem was openly acknowledged here:
> http://meetbot.fedoraproject.org/fedora-meeting/2009-11-13/fesco.2009-11-13-17.00.log.html

Looks as though you can still upgrade if you have a wired ethernet connection. (I wonder whether anaconda could include wifi support--that would make things rather easier.)

But none of this is mentioned on the 'Common F12 bugs' page! The entry there is very sparse, and not even consistent. The title is

  /boot must be a minimum of 300MB

and the description reads

  If you use a separate /boot partition, it is highly recommended that it be at least 300MB in size.

There's quite a difference between 'must' and 'highly recommended'! This badly needs updating before tomorrow. Does it have to be 300MB, or doesn't it? If not, what is the thinking behind the recommendation? Does it apply to DVD upgrades, or just preupgrade?
Comment 29 Charles-Henri d'Adhémar 2009-11-16 11:33:05 EST
Hi all !

What do you mean James by "Looks as though you can still upgrade if you have a wired ethernet connection." ?

Is it linked to wwoods statement in the related fesco meeting :
"17:23:38 <wwoods> dgilmore: happily your case will hit the existing disk-space check and offer to download install.img over the internet" ?

Will anaconda detect the missing stage and offer to download it to another place than the already full filled /boot partition (/tmp or somewhere else). Will anaconda be able to download the stage to a LVM partition (everything but /boot is inside a LVM on my system) ?

Thank you very much for your help on this subject : I think that all the users having a too small /boot partition will be very happy to know about a workaround different from resizing the partition.

Thanks again,
Cheers,
Chicha
Comment 30 James Heather 2009-11-16 14:15:07 EST
> What do you mean James by "Looks as though you can still upgrade if you have a
> wired ethernet connection." ?
> 
> Is it linked to wwoods statement in the related fesco meeting :
> "17:23:38 <wwoods> dgilmore: happily your case will hit the existing disk-space
> check and offer to download install.img over the internet" ?

Yes, that's how I read it. I don't have any info beyond what's logged in that FESCo meeting.

> Will anaconda detect the missing stage and offer to download it to another
> place than the already full filled /boot partition (/tmp or somewhere else).
> Will anaconda be able to download the stage to a LVM partition (everything but
> /boot is inside a LVM on my system) ?

Same here. I am very much assuming that it's being downloaded to RAM.

The 'Common F12 bugs' page seems to have been updated now. The inconsistent entry is still there and unmodified, but there's another entry further up, which describes the issues in a little more detail. But bizarrely it doesn't mention the possibility of downloading the relevant files over the net.

So I hope we don't find tomorrow that that's gone out the window!

James
Comment 31 Jerry Vonau 2009-11-16 19:37:59 EST
I have a patched anaconda to workaround the not enough space in /boot issue, looking for feedback. If you would like to try my workaround place the updates.img into /boot/upgrade for preupgrade or pull it down with updates= from http://members.shaw.ca/jvonau/pub/F12/ 

Jerry
Comment 32 Vadim Raskhozhev 2009-11-18 08:50:07 EST
(In reply to comment #31)
> I have a patched anaconda to workaround the not enough space in /boot issue,
> looking for feedback. If you would like to try my workaround place the
> updates.img into /boot/upgrade for preupgrade or pull it down with updates=
> from http://members.shaw.ca/jvonau/pub/F12/ 

Didn't sort out how to use updates.img but was able to apply "preupfix2.diff" patch (http://members.shaw.ca/jvonau/pub/F12/preupfix2.diff) and successfully upgrade my system with /boot of 200 Mb with only the last F11 kernel and preupgrade stuff on it. Jerry, thanks for your patch, it worked for me
Comment 33 Jerry Vonau 2009-11-21 05:36:27 EST
 (In reply to comment #18)
> id.backend._loopbackFile: /mnt/sysimage/boot/rhinstall-install.img
> 
> Any reason for backend.py to copy install.img from the cd/dvd to "/boot" rather
> than using "/" for the rhinstall-install.img on the target system? That is what
> triggered this bug to begin with, not enough room in /boot.  

This has nothing to do with preupgrade, that is a different issue. This bug should be reopened, the original issue: "Unable to install F11 from CDs due to anaconda crash. Anaconda aborts during transfer of install image to disk saying probably out of disk space." has everything to do with having to transfer the install.img from the cdrom to the hard-drive in order to unmount the first cdrom. The question is why it is using /boot to hold the image.

https://www.redhat.com/archives/anaconda-devel-list/2009-November/msg00373.html 

"You are on to something here, the old code is using the first
element of anaconda.id.storage.fsFreeSpace, which is sorted by size, but
that is the element with the smallest size! I think this is a bug and the
code should use the last element"

Please reopen.
Comment 34 Hans de Goede 2009-11-21 05:51:48 EST
(In reply to comment #33)
>  
> https://www.redhat.com/archives/anaconda-devel-list/2009-November/msg00373.html 
> 
> "You are on to something here, the old code is using the first
> element of anaconda.id.storage.fsFreeSpace, which is sorted by size, but
> that is the element with the smallest size! I think this is a bug and the
> code should use the last element"
> 
> Please reopen.  

As author of the quoted text, let me correct this, please do not re-open this bug, file a new bug instead.
Comment 35 udo 2009-11-30 12:00:01 EST
a) the problem situation is poorly handled: error message and shutdown need improvement
b) choice of filesystem to put these upgrade images on is suboptimal.
Comment 37 Hans de Goede 2009-12-07 10:07:57 EST
(In reply to comment #36)
> https://bugzilla.redhat.com/show_bug.cgi?id=544774  

<sigh>

Re-opening 2 bugs for issue is *really* bad style, esp. as I've written in comment #34 of this bug:

"let me correct this, please do not re-open this bug, file a new bug instead."

Note though that the filing of a new bug is no longer necessary. As I already fixed the original issue of this bug (poor choice to store install.img with multiple CD install), see:

http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=632fa16c6c8bb21252fc7792afc2e80734100efe
Comment 38 Christopher Beland 2010-02-12 15:31:18 EST
Trying to update the Common Bugs page with the resolution.  It looks like this issue is "fixed" for Fedora 13, but what does that imply the minimum /boot size should be?  Is whatever is documented in the Installation Guide and whatever the installer now defaults to sufficient?
Comment 39 James Heather 2010-02-12 17:07:19 EST
I should say that what the installer *now* defaults to isn't the end of the story--that would only help people who make fresh installs of F12 to make future upgrades. It won't help people whose /boot was created long ago by a previous Fedora version.

The default from time immemorial has been 200MB, so the issue is only properly fixed for F13 if 200MB is sufficient. Otherwise, those of us with machines dating back to F11 or earlier will still have trouble upgrading, and it'll still need to appear in some form on the F13 Common Bugs page.
Comment 40 udo 2010-02-13 01:19:49 EST
/boot should not be abused -ever- for installation/upgrade purposes.
If /boot can hold one kernel it should be sufficient for starting the system.
Demanding bigger sizes is not justified.

Note You need to log in before you can comment on or make changes to this bug.