This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 531924

Summary: reboot hangs waiting for return on livecd
Product: [Fedora] Fedora Reporter: jmccann
Component: livecd-toolsAssignee: Warren Togami <wtogami>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: awilliam, cschalle, davidz, dcantrell, fedora, jlaska, katzj, krh, rstrode, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-03 00:45:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473303    
Attachments:
Description Flags
VT1
none
VT3 none

Description jmccann 2009-10-29 17:09:34 EDT
When I try to reboot the livecd from today it hangs.  When I switch VTs I notice a message asking me to remove the cd and press enter to continue.
Comment 1 James Laska 2009-10-29 17:20:58 EDT
jmccann, I saw this earlier today as well.  Can you take screenshots of the different tty's?  I believe tty3 or tty4 has an eject error on it?
Comment 2 jmccann 2009-10-29 17:50:28 EDT
Created attachment 366720 [details]
VT1
Comment 3 jmccann 2009-10-29 17:56:42 EDT
Created attachment 366721 [details]
VT3
Comment 4 Jesse Keating 2009-10-29 18:08:14 EDT
That string comes from the livecd ks itself.  Warren has the info.
Comment 5 Adam Williamson 2009-10-30 15:18:03 EDT
Discussed at today's blocker bug meeting, though we haven't made a discussion yet. Jesse summarizes the choices:

"so our options are A) try to fix plymouth so that we get our message, B) remove the messing with halt and regress 474817, C) do nothing and hope that the 30s timeout isn't too egregious"

Ray believes this change in initscripts may fix it:

ah ha
/etc/event.d/plymouth-shutdown doesn't have --attach-to-session
which means /dev/console messages aren't getting redirected
that may be why the message isn't showing up

Jesse is testing this theory at present. We'll continue to evaluate this one via this bug report.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Matthias Clasen 2009-10-30 18:39:24 EDT
Moving to plymouth according to that theory.
Comment 7 Ray Strode [halfline] 2009-10-30 20:42:24 EDT
Note, plymouth-shutdown is in initscripts not plymouth (although maybe it should be in plymouth).

Anyway, this bug is sort of in my lap either way so assigning it to plymouth is fine.
Comment 8 Adam Williamson 2009-10-31 01:22:35 EDT
well, the question is still whether we should attempt a fix for this bug in plymouth, try and work around it elsewhere, or leave it alone and document it...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Ray Strode [halfline] 2009-11-02 15:12:35 EST
I think that we should probably revert the fix that was added in bug 474817 for a few reasons:

1) even if we fixed which vt the message was shown on, we'd only show the message for non-graphical users.  Graphical users would just get stuck wondering what's going on (or we would end up tearing down the graphical display and show text mode).

2) Warren says that he's run into issues where the eject happens too early sometimes and the system blows up (I don't know if he filed a bug for this or not)

3) the problem that's solved, only affects a subset of users with cd drives that can pull the cd back in, but the problem that's caused by the fix affects every user

4) we're getting down to the wire now.

For F13 i think we probably want better plymouth integration instead of 

echo blah > /dev/console

So the graphical case is right, and come up with a better implementation so that 2 doesn't happen.

(also for F13, we should fix plymouth so that /dev/console messages go to the right vt)

So after talking to Warren, I'm moving this to LiveCD.
Comment 10 Warren Togami 2009-11-02 15:22:37 EST
> 3) the problem that's solved, only affects a subset of users with cd drives
> that can pull the cd back in, but the problem that's caused by the fix affects
> every user

This is a race condition where the device backing the root filesystem is disappearing and it subsequently tries to read from the block device to run the next command or read something necessary to proceed with shutdown.

I will figure out exactly which change this was and back it out.
Comment 11 Jesse Keating 2009-11-03 00:45:12 EST
The change was backed out in the config, closing this bug.