Bug 474817 - Usability improvements in Live CD installer
Usability improvements in Live CD installer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 09:20 EST by Ed Avis
Modified: 2013-01-09 23:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 13:32:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2008-12-05 09:20:24 EST
These are some observations from seeing someone new to Linux try to install Fedora using the i386 Live CD.

- Once the installer has copied the image to the system it reboots the machine.  However the CD is still in the drive!  It gets ejected on shutdown, but on most PCs the drawer will immediately close again so you have to be very quick to take the CD out.  And users may not even notice that the disc has been momentarily ejected and then sucked back in.  So the machine boots back to the live image again.

Suggestion: make removing the install CD from the drive (or unplugging the USB key) an explicit step in the install.  I appreciate this could be difficult to implement because the live filesystem must be unmounted first.

- It is not obvious what the difference is between running from CD and running the installed system from local disk.  They both look very similar.  In particular it might look like you have just installed your new Fedora system but all that happened was a reboot and the live CD loaded again!

Suggestion: It would help to have some kind of splash screen for the live CD that explains it is running from CD, or at the very least a different desktop background.

Additionally, it would help if the live CD had a simple menu on boot with two choices: run from CD, and install to disk.  If you choose the second option then you go straight into the installer without loading the GNOME desktop first.  This would also make the process faster.

- When you do remember to remove the CD and it boots the system from the hard disk for the first time, the installation continues, but it's not completely obvious that this is just the 'second stage' and the last step before the system is usable.  It feels as though you are back at the installer again, which has already happened several times before when you left the CD in the drive...

Suggestion: perhaps the initial user setup and selection of timezone etc. could happen during the main install process, so when this process finishes the system is completely ready to use.  Alternatively, a more obvious splash screen or banner for 'finishing the installation' might make it clearer what is happening.
Comment 1 Jeremy Katz 2008-12-08 13:32:56 EST
(In reply to comment #0)
> These are some observations from seeing someone new to Linux try to install
> Fedora using the i386 Live CD.

Note that in the future, filing as a set of separate bugs makes it a lot easier to work with as each individual issue can be reassigned or worked independently.

> - Once the installer has copied the image to the system it reboots the machine.
>  However the CD is still in the drive!  It gets ejected on shutdown, but on
> most PCs the drawer will immediately close again so you have to be very quick
> to take the CD out.  And users may not even notice that the disc has been
> momentarily ejected and then sucked back in.  So the machine boots back to the
> live image again.
> 
> Suggestion: make removing the install CD from the drive (or unplugging the USB
> key) an explicit step in the install.  I appreciate this could be difficult to
> implement because the live filesystem must be unmounted first.

We can't eject during the actual install as that's where the system is running off of.  Adding a delay with a timeout after we eject, though, is pretty reasonable and doable.  Fixed in git for F11.

> - It is not obvious what the difference is between running from CD and running
> the installed system from local disk.  They both look very similar.  In
> particular it might look like you have just installed your new Fedora system
> but all that happened was a reboot and the live CD loaded again!
> 
> Suggestion: It would help to have some kind of splash screen for the live CD
> that explains it is running from CD, or at the very least a different desktop
> background.

The similar look and feel is intended.  The speed should be a good indicator you're no longer running off of the CD :-)   

More seriously, things like logging in as the live user and the different bootloader bits are the main win.

> Additionally, it would help if the live CD had a simple menu on boot with two
> choices: run from CD, and install to disk.  If you choose the second option
> then you go straight into the installer without loading the GNOME desktop
> first.  This would also make the process faster.

There is support for this (add 'liveinst' to your kernel command line), but it's not something that we want to expose more.  It's better for most people to be in the full desktop environment as they can ensure their hardware functions and do things like use firefox to read release notes while the install is going on.

> - When you do remember to remove the CD and it boots the system from the hard
> disk for the first time, the installation continues, but it's not completely
> obvious that this is just the 'second stage' and the last step before the
> system is usable.  It feels as though you are back at the installer again,
> which has already happened several times before when you left the CD in the
> drive...
> 
> Suggestion: perhaps the initial user setup and selection of timezone etc. could
> happen during the main install process, so when this process finishes the
> system is completely ready to use.  Alternatively, a more obvious splash screen
> or banner for 'finishing the installation' might make it clearer what is
> happening.

This seems reasonable; filed bug 475270 so that it can be tracked appropriately against firstboot.

Note You need to log in before you can comment on or make changes to this bug.