Bug 532071

Summary: manpath patch misses last item in path?
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: kdebase-runtimeAssignee: Ngo Than <than>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: jfontain, jgrulich, jreznik, kevin, rdieter, smparrish, than
Target Milestone: ---Keywords: FutureFeature, Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 4.3.3-7.fc12 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-26 12:29:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Rex Dieter 2009-10-30 14:19:12 UTC
$ rpm -q kdebase-runtime
kdebase-runtime-4.3.2-4.fc12.x86_64

$ manpath
/usr/kerberos/man:/usr/local/share/man:/usr/share/man/en:/usr/share/man

man:/

seems to miss everything in the last item in the path, /usr/share/man

Comment 1 Rex Dieter 2009-11-14 13:31:46 UTC
Any update here?

Since this makes a majority of manpages unusable, I'm of a mind to drop manpath support until this is fixed.

Comment 2 Fedora Update System 2009-11-16 07:26:15 UTC
kdebase-workspace-4.3.3-7.fc10, kdelibs-4.3.3-4.fc10, kdebase-runtime-4.3.3-5.fc10, kdeaccessibility-4.3.3-1.fc10, kdeadmin-4.3.3-1.fc10, kdeartwork-4.3.3-1.fc10, kdebindings-4.3.3-3.fc10, kdebase-4.3.3-3.fc10, kdeedu-4.3.3-1.fc10, kdegames-4.3.3-2.fc10, kdegraphics-4.3.3-1.fc10, kdelibs-experimental-4.3.3-1.fc10, kdemultimedia-4.3.3-1.fc10, kdenetwork-4.3.3-4.fc10, kdepim-4.3.3-1.fc10, kdepim-runtime-4.3.3-1.fc10, kdepimlibs-4.3.3-1.fc10, kdeplasma-addons-4.3.3-1.fc10, kdesdk-4.3.3-1.fc10, kdetoys-4.3.3-1.fc10, kdeutils-4.3.3-1.fc10, konq-plugins-4.3.3-2.fc10, oxygen-icon-theme-4.3.3-1.fc10, sip-4.9.1-1.fc10, PyQt4-4.6.1-1.fc10, qscintilla-2.4-7.fc10, webkitkde-0.0.2-0.1.20091109svn.fc10, kde-l10n-4.3.3-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-workspace kdelibs kdebase-runtime kdeaccessibility kdeadmin kdeartwork kdebindings kdebase kdeedu kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils konq-plugins oxygen-icon-theme sip PyQt4 qscintilla webkitkde kde-l10n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-11500

Comment 3 Fedora Update System 2009-11-16 07:26:56 UTC
kdebase-workspace-4.3.3-7.fc12, kdelibs-4.3.3-4.fc12, kdebase-runtime-4.3.3-5.fc12, kde-l10n-4.3.3-1.fc12, kdeaccessibility-4.3.3-2.fc12, kdeadmin-4.3.3-1.fc12, kdeartwork-4.3.3-1.fc12, kdebindings-4.3.3-3.fc12, kdebase-4.3.3-3.fc12, kdeedu-4.3.3-2.fc12, kdegames-4.3.3-2.fc12, kdegraphics-4.3.3-1.fc12, kdelibs-experimental-4.3.3-1.fc12, kdemultimedia-4.3.3-2.fc12, kdenetwork-4.3.3-5.fc12, kdepim-4.3.3-1.fc12, kdepim-runtime-4.3.3-1.fc12, kdepimlibs-4.3.3-1.fc12, kdeplasma-addons-4.3.3-1.fc12, kdesdk-4.3.3-1.fc12, kdetoys-4.3.3-1.fc12, kdeutils-4.3.3-1.fc12, konq-plugins-4.3.3-2.fc12, oxygen-icon-theme-4.3.3-1.fc12, sip-4.9.1-1.fc12, PyQt4-4.6.1-1.fc12, qscintilla-2.4-7.fc12, webkitkde-0.0.2-0.1.20091109svn.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-workspace kdelibs kdebase-runtime kde-l10n kdeaccessibility kdeadmin kdeartwork kdebindings kdebase kdeedu kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils konq-plugins oxygen-icon-theme sip PyQt4 qscintilla webkitkde'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11503

Comment 4 Fedora Update System 2009-11-16 07:37:58 UTC
kdebase-workspace-4.3.3-7.fc11, kdelibs-4.3.3-4.fc11, kdebase-runtime-4.3.3-5.fc11, kdeaccessibility-4.3.3-1.fc11, kdeadmin-4.3.3-1.fc11, kdeartwork-4.3.3-1.fc11, kdebindings-4.3.3-3.fc11, kdebase-4.3.3-3.fc11, kdeedu-4.3.3-1.fc11, kdegames-4.3.3-2.fc11, kdegraphics-4.3.3-1.fc11, kdelibs-experimental-4.3.3-1.fc11, kdemultimedia-4.3.3-1.fc11, kdenetwork-4.3.3-4.fc11, kdepim-4.3.3-1.fc11, kdepim-runtime-4.3.3-1.fc11, kdepimlibs-4.3.3-1.fc11, kdeplasma-addons-4.3.3-1.fc11, kdesdk-4.3.3-1.fc11, kdetoys-4.3.3-1.fc11, kdeutils-4.3.3-1.fc11, konq-plugins-4.3.3-2.fc11, oxygen-icon-theme-4.3.3-1.fc11, sip-4.9.1-1.fc11, PyQt4-4.6.1-1.fc11, qscintilla-2.4-7.fc11, webkitkde-0.0.2-0.1.20091109svn.fc11, kde-l10n-4.3.3-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-workspace kdelibs kdebase-runtime kdeaccessibility kdeadmin kdeartwork kdebindings kdebase kdeedu kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils konq-plugins oxygen-icon-theme sip PyQt4 qscintilla webkitkde kde-l10n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11627

Comment 5 Bug Zapper 2009-11-16 14:41:51 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Fedora Update System 2009-11-24 07:45:36 UTC
kdebase-workspace-4.3.3-7.fc11, kdelibs-4.3.3-4.fc11, kdebase-runtime-4.3.3-5.fc11, kdeaccessibility-4.3.3-1.fc11, kdeadmin-4.3.3-1.fc11, kdeartwork-4.3.3-1.fc11, kdebase-4.3.3-3.fc11, kdeedu-4.3.3-1.fc11, kdegames-4.3.3-2.fc11, kdegraphics-4.3.3-1.fc11, kdelibs-experimental-4.3.3-1.fc11, kdemultimedia-4.3.3-1.fc11, kdenetwork-4.3.3-4.fc11, kdepim-4.3.3-1.fc11, kdepim-runtime-4.3.3-1.fc11, kdepimlibs-4.3.3-1.fc11, kdeplasma-addons-4.3.3-1.fc11, kdesdk-4.3.3-1.fc11, kdetoys-4.3.3-1.fc11, kdeutils-4.3.3-1.fc11, konq-plugins-4.3.3-2.fc11, oxygen-icon-theme-4.3.3-1.fc11, qscintilla-2.4-7.fc11, webkitkde-0.0.2-0.1.20091109svn.fc11, kde-l10n-4.3.3-1.fc11, PyKDE-3.16.6-1.fc11, sip-4.9.2-1.fc11, PyQt4-4.6.2-1.fc11, qzion-0.4.0-5.fc11, qedje-0.4.0-4.fc11, PyQwt-5.2.0-2.fc11, PyQt-3.18.1-5.fc11, kdebindings-4.3.3-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-workspace kdelibs kdebase-runtime kdeaccessibility kdeadmin kdeartwork kdebase kdeedu kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils konq-plugins oxygen-icon-theme qscintilla webkitkde kde-l10n PyKDE sip PyQt4 qzion qedje PyQwt PyQt kdebindings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11627

Comment 7 Fedora Update System 2009-11-24 07:52:42 UTC
kdebase-workspace-4.3.3-7.fc10, kdelibs-4.3.3-4.fc10, kdebase-runtime-4.3.3-5.fc10, kdeaccessibility-4.3.3-1.fc10, kdeadmin-4.3.3-1.fc10, kdeartwork-4.3.3-1.fc10, kdebase-4.3.3-3.fc10, kdeedu-4.3.3-1.fc10, kdegames-4.3.3-2.fc10, kdegraphics-4.3.3-1.fc10, kdelibs-experimental-4.3.3-1.fc10, kdemultimedia-4.3.3-1.fc10, kdenetwork-4.3.3-4.fc10, kdepim-4.3.3-1.fc10, kdepim-runtime-4.3.3-1.fc10, kdepimlibs-4.3.3-1.fc10, kdeplasma-addons-4.3.3-1.fc10, kdesdk-4.3.3-1.fc10, kdetoys-4.3.3-1.fc10, kdeutils-4.3.3-1.fc10, konq-plugins-4.3.3-2.fc10, oxygen-icon-theme-4.3.3-1.fc10, qscintilla-2.4-7.fc10, webkitkde-0.0.2-0.1.20091109svn.fc10, kde-l10n-4.3.3-1.fc10, PyKDE-3.16.6-1.fc10, sip-4.9.2-1.fc10, PyQt4-4.6.2-1.fc10, qzion-0.4.0-5.fc10, qedje-0.4.0-4.fc10, PyQwt-5.2.0-2.fc10, PyQt-3.18.1-5.fc10, kdebindings-4.3.3-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-workspace kdelibs kdebase-runtime kdeaccessibility kdeadmin kdeartwork kdebase kdeedu kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils konq-plugins oxygen-icon-theme qscintilla webkitkde kde-l10n PyKDE sip PyQt4 qzion qedje PyQwt PyQt kdebindings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-11500

Comment 8 Fedora Update System 2009-11-24 07:59:47 UTC
kdebase-workspace-4.3.3-7.fc12, kdelibs-4.3.3-4.fc12, kdebase-runtime-4.3.3-5.fc12, kde-l10n-4.3.3-1.fc12, kdeaccessibility-4.3.3-2.fc12, kdeadmin-4.3.3-1.fc12, kdeartwork-4.3.3-1.fc12, kdebase-4.3.3-3.fc12, kdeedu-4.3.3-2.fc12, kdegames-4.3.3-2.fc12, kdegraphics-4.3.3-1.fc12, kdelibs-experimental-4.3.3-1.fc12, kdemultimedia-4.3.3-2.fc12, kdenetwork-4.3.3-5.fc12, kdepim-4.3.3-1.fc12, kdepim-runtime-4.3.3-1.fc12, kdepimlibs-4.3.3-1.fc12, kdeplasma-addons-4.3.3-1.fc12, kdesdk-4.3.3-1.fc12, kdetoys-4.3.3-1.fc12, kdeutils-4.3.3-1.fc12, konq-plugins-4.3.3-2.fc12, oxygen-icon-theme-4.3.3-1.fc12, qscintilla-2.4-7.fc12, webkitkde-0.0.2-0.1.20091109svn.fc12, qzion-0.4.0-5.fc12, qedje-0.4.0-4.fc12, PyQwt-5.2.0-3.fc12, PyQt-3.18.1-5.fc12, kdebindings-4.3.3-4.fc12, PyKDE-3.16.6-1.fc12, sip-4.9.2-1.fc12, PyQt4-4.6.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-workspace kdelibs kdebase-runtime kde-l10n kdeaccessibility kdeadmin kdeartwork kdebase kdeedu kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils konq-plugins oxygen-icon-theme qscintilla webkitkde qzion qedje PyQwt PyQt kdebindings PyKDE sip PyQt4'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11503

Comment 9 Kevin Kofler 2009-11-24 16:44:44 UTC
*** Bug 540987 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2009-11-25 14:55:56 UTC
kdebase-workspace-4.3.3-7.fc10, kdelibs-4.3.3-4.fc10, kdebase-runtime-4.3.3-5.fc10, kdeaccessibility-4.3.3-1.fc10, kdeadmin-4.3.3-1.fc10, kdeartwork-4.3.3-1.fc10, kdebase-4.3.3-3.fc10, kdeedu-4.3.3-1.fc10, kdegames-4.3.3-2.fc10, kdegraphics-4.3.3-1.fc10, kdelibs-experimental-4.3.3-1.fc10, kdemultimedia-4.3.3-1.fc10, kdenetwork-4.3.3-4.fc10, kdepim-4.3.3-1.fc10, kdepim-runtime-4.3.3-1.fc10, kdepimlibs-4.3.3-1.fc10, kdeplasma-addons-4.3.3-1.fc10, kdesdk-4.3.3-1.fc10, kdetoys-4.3.3-1.fc10, kdeutils-4.3.3-1.fc10, konq-plugins-4.3.3-2.fc10, oxygen-icon-theme-4.3.3-1.fc10, qscintilla-2.4-7.fc10, webkitkde-0.0.2-0.1.20091109svn.fc10, kde-l10n-4.3.3-1.fc10, sip-4.9.3-1.fc10, PyKDE-3.16.6-1.fc10, PyQt4-4.6.2-1.fc10, qzion-0.4.0-5.fc10, qedje-0.4.0-4.fc10, PyQwt-5.2.0-2.fc10, PyQt-3.18.1-5.fc10, kdebindings-4.3.3-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Rex Dieter 2009-11-25 15:03:53 UTC
Re-opening, so we can track this patch coming back fixed someday.

Comment 12 Fedora Update System 2009-11-25 15:06:33 UTC
kdebase-workspace-4.3.3-7.fc11, kdelibs-4.3.3-4.fc11, kdebase-runtime-4.3.3-5.fc11, kdeaccessibility-4.3.3-1.fc11, kdeadmin-4.3.3-1.fc11, kdeartwork-4.3.3-1.fc11, kdebase-4.3.3-3.fc11, kdeedu-4.3.3-1.fc11, kdegames-4.3.3-2.fc11, kdegraphics-4.3.3-1.fc11, kdelibs-experimental-4.3.3-1.fc11, kdemultimedia-4.3.3-1.fc11, kdenetwork-4.3.3-4.fc11, kdepim-4.3.3-1.fc11, kdepim-runtime-4.3.3-1.fc11, kdepimlibs-4.3.3-1.fc11, kdeplasma-addons-4.3.3-1.fc11, kdesdk-4.3.3-1.fc11, kdetoys-4.3.3-1.fc11, kdeutils-4.3.3-1.fc11, konq-plugins-4.3.3-2.fc11, oxygen-icon-theme-4.3.3-1.fc11, qscintilla-2.4-7.fc11, webkitkde-0.0.2-0.1.20091109svn.fc11, sip-4.9.3-1.fc11, kde-l10n-4.3.3-1.fc11, PyKDE-3.16.6-1.fc11, PyQt4-4.6.2-1.fc11, qzion-0.4.0-5.fc11, qedje-0.4.0-4.fc11, PyQwt-5.2.0-2.fc11, PyQt-3.18.1-5.fc11, kdebindings-4.3.3-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2009-11-25 15:14:36 UTC
kdebase-workspace-4.3.3-7.fc12, kdelibs-4.3.3-4.fc12, kdebase-runtime-4.3.3-5.fc12, kde-l10n-4.3.3-1.fc12, kdeaccessibility-4.3.3-2.fc12, kdeadmin-4.3.3-1.fc12, kdeartwork-4.3.3-1.fc12, kdebase-4.3.3-3.fc12, kdeedu-4.3.3-2.fc12, kdegames-4.3.3-2.fc12, kdegraphics-4.3.3-1.fc12, kdelibs-experimental-4.3.3-1.fc12, kdemultimedia-4.3.3-2.fc12, kdenetwork-4.3.3-5.fc12, kdepim-4.3.3-1.fc12, kdepim-runtime-4.3.3-1.fc12, kdepimlibs-4.3.3-1.fc12, kdeplasma-addons-4.3.3-1.fc12, kdesdk-4.3.3-1.fc12, kdetoys-4.3.3-1.fc12, kdeutils-4.3.3-1.fc12, konq-plugins-4.3.3-2.fc12, oxygen-icon-theme-4.3.3-1.fc12, qscintilla-2.4-7.fc12, webkitkde-0.0.2-0.1.20091109svn.fc12, sip-4.9.3-1.fc12, qzion-0.4.0-5.fc12, qedje-0.4.0-4.fc12, PyQwt-5.2.0-3.fc12, PyQt-3.18.1-5.fc12, kdebindings-4.3.3-4.fc12, PyKDE-3.16.6-1.fc12, PyQt4-4.6.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Jean-Luc Fontaine 2009-11-27 16:32:51 UTC
fixed in today's update on fc12, thanks.

Comment 15 Rex Dieter 2009-11-27 17:07:05 UTC
Re-opening (again) per comment #11

Comment 16 Rex Dieter 2010-06-22 15:27:22 UTC
Than, here anything from the fellow who produced this patch?

Comment 17 Ngo Than 2010-06-22 15:32:54 UTC
please keep it open, i will fix it later. Thanks

Comment 18 Rex Dieter 2012-01-27 14:27:51 UTC
ping, it's been... over a year, and still nothing.  do you still really want to keep this open?  :)

Comment 19 Ngo Than 2016-09-26 12:29:56 UTC
the patch is not needed anymore. dropped.