Bug 532212

Summary: Gdm selects USA keyboard layout by default
Product: [Fedora] Fedora Reporter: seventhguardian
Component: gdmAssignee: jmccann
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: awilliam, cschalle, igor, jmccann, luke, mclasen, rstrode
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 530452 Environment:
Last Closed: 2010-05-01 16:06:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
The output from lshal
none
Contents of my /ets/sysconfig/keyboard
none
My Xorg.0.log none

Description seventhguardian 2009-10-31 10:01:54 EDT
I've experienced bug 530452 on two systems (one is a i686 and the other is a x86_64, not sure if relevant). The fix solved the problem for the i686 system, but not for the x86_64 one.

The problem is still present with:
gdm-2.28.1-12.fc12.x86_64


Additional info:
The problematic x86_64 system has a long term rawhide installation. The fixed i686 system was a freshly installed fedora 12 beta.
Comment 1 seventhguardian 2009-10-31 10:03:26 EDT
Created attachment 366928 [details]
The output from lshal
Comment 2 seventhguardian 2009-10-31 10:04:06 EDT
Created attachment 366929 [details]
Contents of my /ets/sysconfig/keyboard
Comment 3 seventhguardian 2009-10-31 10:09:27 EDT
Created attachment 366930 [details]
My Xorg.0.log

Here's my Xorg.0.log.

I've noticed that the layout used by gdm is the correct one (Portuguese), but the session layout (on the dropdown box) is defaulted to USA.
Comment 4 Matthias Clasen 2009-11-01 00:12:39 EDT
I just tried this with German, and it works as intended:

1. make german the system keyboard layout, using s-c-keyboard
2. reboot
3. notice that gdm uses german keyboard layout
4. select a user
5. notice that german is the default keyboard layout

This works unless you have something else selected in your $HOME/.dmrc
Comment 5 seventhguardian 2009-11-01 05:03:07 EST
Here are the contents of my .dmrc:

<snip>
[Desktop]
Language=pt_PT.UTF-8
Layout=us
</snip>

So the layout is wrongly selected to be "us". I suspect that if I change it manually, it will be used.

Any idea why the .dmrc file is unchanged even if I go to System->Configuration->Keyboard?

$ ls .dmrc -l
-rw-r--r--. 1 renato renato 42 Nov  1 09:53 .dmrc

You may notice that the file is touched, but it is unchanged. Maybe a broken applet?
Comment 6 seventhguardian 2009-11-01 05:06:10 EST
I've changed it by hand to "pt", and logged off. Gdm still selects "us", and opening the file after login shows it is set once again to "us"...
Comment 7 Ray Strode [halfline] 2009-11-01 18:40:43 EST
if you

rm -f /var/cache/gdm/your-username/.dmrc
rm -f ~/.dmrc

and start fresh, does it work from then on?
Comment 8 seventhguardian 2009-11-01 19:01:09 EST
It does! Great!

I'm not sure how to settle this, is it a bug or a just a quirk?
Comment 9 Adam Williamson 2009-11-02 02:01:11 EST
Ray, if I'm reading this correctly it's a transient issue which hit Renato because he'd used the broken version, and it shouldn't hit any new installs or upgrades using the final release images - does that sound correct? If so, I think we can drop it from the blocker list.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Ray Strode [halfline] 2009-11-02 07:39:49 EST
Right, it's a bit of a trap because the layout chooser isn't really designed right.  We aren't going to fix that for GA though.
Comment 11 Bug Zapper 2009-11-16 09:45:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 seventhguardian 2010-05-01 16:06:31 EDT
I'm closing this bug, as it shouldn't be a problem anymore. WONTFIX seemed the best resolution for a quirk, apart from WORKSFORME.. :)