Bug 530452 - Gnome sets the keyboard layout to USA after every log in
Gnome sets the keyboard layout to USA after every log in
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
: 528433 530509 530551 530941 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-22 16:44 EDT by Peeter Puusemp
Modified: 2015-01-14 18:23 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 532212 (view as bug list)
Environment:
Last Closed: 2009-10-29 20:42:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
~/.dmrc file (21 bytes, text/plain)
2009-10-23 00:43 EDT, Peeter Puusemp
no flags Details
Contents of my /ets/sysconfig/keyboard (87 bytes, text/plain)
2009-10-23 18:14 EDT, seventhguardian
no flags Details
The output from lshal (118.52 KB, text/plain)
2009-10-23 18:15 EDT, seventhguardian
no flags Details
lshal output (109.00 KB, text/plain)
2009-10-26 11:24 EDT, Peeter Puusemp
no flags Details

  None (edit)
Description Peeter Puusemp 2009-10-22 16:44:36 EDT
Description of problem:
Every time I log back in the keyboard layout is set to USA even if I have deleted it from the list. The keyboard layout I want to use: Estonia.

PS. I don't remember if the layout Estonia was in the list after I installed Fedora 12 Beta, but I somewhat remember adding it myself. During the installation I chose Estonian layout.

Version-Release number of selected component (if applicable):
I have fully updated system.

How reproducible:
Log out and log back in.

Steps to Reproduce:
1. Install Fedora 12 Beta.
2. Add the keyboard layout of Estonia in gnome-keyboard-properties and delete the USA one.
3. Log out and log back in.
  
Actual results:
The keyboard layout is always set to USA after the log in.

Expected results:
Gnome remembers the keyboard layout set before.

Additional info:
Comment 1 Adam Williamson 2009-10-22 19:01:24 EDT
Also reported on fedora-test-list:

https://www.redhat.com/archives/fedora-test-list/2009-October/msg00486.html

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Ray Strode [halfline] 2009-10-22 20:20:36 EDT
Can you attach your ~/.dmrc file and the output of

gconftool-2 -R /desktop/gnome/peripherals/keyboard

?
Comment 3 Adam Williamson 2009-10-22 21:51:33 EDT
Nominating this as blocker, we will confirm/deny tomorrow.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Peeter Puusemp 2009-10-23 00:43:48 EDT
Created attachment 365812 [details]
~/.dmrc file

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard
 bell_custom_file = (väärtus määramata)
 rate = 30
 bell_pitch = 400
 remember_numlock_state = true
 bell_duration = 100
 click = true
 click_volume = 0
 repeat = true
 bell_mode = on
 delay = 500
 /desktop/gnome/peripherals/keyboard/indicator:
  secondary = 0
  showFlags = false
  enabledPlugins = []
 /desktop/gnome/peripherals/keyboard/preview:
  x = 240
  y = 150
  height = 900
  width = 1440
 /desktop/gnome/peripherals/keyboard/kbd:
  layouts = [ee,us]
  options = [grp	grp:shift_caps_toggle]
  model = logiultrax
 /desktop/gnome/peripherals/keyboard/general:
  defaultGroup = -1
  update_handlers = []
  handleIndicators = false
  disable_sysconfig_changed_warning = false
  groupPerWindow = false
  known_file_list = []
  layoutNamesAsGroupNames = true
  loadExtraItems = false
Comment 5 birger 2009-10-23 03:38:44 EDT
As I see it something really broke down with keyboard layouts back when evdev appeared. My expectation is that when I select a keyboard layout during install that layout stays the default for that system.

Now, when I select norwegian keyboard layout during install of 12 beta, the system still defaults to USA at the login screen. This is very bad, as it could make it impossible for users to type their password correctly unless they see the 'USA' label at the bottom of the screen. The login screen also falls back to USA at each login. It doesn't remember the users choice at last login, nor does it see that the user has set a different keyboard layout for gnome.

If I select Norway as my layout during login I expect to get that layout not only while typing my password, but for that session. 12 beta falls back to USA after login.

If I use System->Preferences->Keyboard to set my keyboard layout I get the layout I want, and it sticks across logins. But if I log out, I still get USA layout at the login screen.

Keyboard layout should be selected on a per-system basis. For most users it would be plain wrong to override the keyboard selection in their gnome setup, as it can vary between systems. They should use the system default. The login screen should use the user selected layout if the user really needs to override, and fall back to the system-wide default otherwise. And of course the system wide default should be set when I select keyboard layout during install.
Comment 6 Ray Strode [halfline] 2009-10-23 12:22:24 EDT
When you click a username at login time (before typing your username), it says "English" for Language on the bottom panel, right?

What happens if you click the language selector and change it, then log in?

Is the session right?  Are subsequent logins right?
Comment 7 Ray Strode [halfline] 2009-10-23 12:36:13 EDT
*** Bug 530509 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2009-10-23 12:36:53 EDT
*** Bug 530551 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Qarras 2009-10-23 13:36:04 EDT
> And of course the system wide default should be set when I select keyboard
> layout during install.

FWIW, I definitely agree: it is a bit annoying that the keyboard layout is both in /etc/grub.conf and /etc/sysconfig/keyboard but yet GDM suggests using some other keyboard layout.
Comment 10 Adam Williamson 2009-10-23 14:16:03 EDT
discussed in the blocker bug meeting today. Ray is aware of this issue and actively working on it. The major bug - that GDM does not pick up the layout selected during installation and defaults to en-US no matter what - will definitely be fixed for the final release.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Ray Strode [halfline] 2009-10-23 15:51:59 EDT
two more bits of info that would be very useful to me.

the contents of /etc/sysconfig/keyboard and the output of lshal
Comment 12 Ray Strode [halfline] 2009-10-23 16:23:07 EDT
This should be fixed in -6.

Marking MODIFIED
Comment 13 birger 2009-10-23 18:05:45 EDT
> When you click a username at login time (before typing your username), it says
> "English" for Language on the bottom panel, right?
It says USA if I remember correctly

> What happens if you click the language selector and change it, then log in?
I assume it affects the password entry. After login it has no effect.

> Is the session right?  Are subsequent logins right?
Only if I set the layout using System->Preferences->Keyboard. The layout set during login has no effect for the session.

I'm sorry I can't get those bits of info you ask for, as I won't be at work until monday.
Comment 14 seventhguardian 2009-10-23 18:12:27 EDT
Here, the GDM layout is correctly set to Portuguese.

If I open the Keyboard Preferences dialog, I can see two entries (Portuguese and USA). The Portuguese entry is set as default, but the layout is still set to USA.

If I delete the USA entry, then the layout is set to Portuguese.
Comment 15 seventhguardian 2009-10-23 18:14:50 EDT
Created attachment 365900 [details]
Contents of my /ets/sysconfig/keyboard

Here's my /etc/sysconfig/keyboard file. The output from "lshal" will follow.
Comment 16 seventhguardian 2009-10-23 18:15:45 EDT
Created attachment 365901 [details]
The output from lshal

Here goes the output from lshal.
Comment 17 Daniel Qarras 2009-10-23 18:38:29 EDT
Hi,

I'm happy to confirm that gdm-2.28.1-6.fc12.i686 fixes the issue. It survived few login/logoff and reboot cycles, no USA keyboard suggested anymore.

Thanks!
Comment 18 seventhguardian 2009-10-24 05:41:13 EDT
(In reply to comment #14)
> Here, the GDM layout is correctly set to Portuguese.
No, it's not. I'm really sorry for this bogus info. The _language_ is set to Portuguese, but the layout is set to English.

Selecting the correct layout makes it work correctly. So this is a GDM bug, and I expect gdm-2.28.1-6.fc12.x86_64 to fix this for me as well.
Comment 19 seventhguardian 2009-10-24 05:42:58 EDT
Correction: English -> USA
Comment 20 Ville-Pekka Vainio 2009-10-25 05:43:50 EDT
(In reply to comment #12)
> This should be fixed in -6.
> 
> Marking MODIFIED  

I just installed gdm-2.28.1-7.fc12 from Koji and I can confirm this is fixed. Thanks!
Comment 21 info@kobaltwit.be 2009-10-25 09:11:14 EDT
*** Bug 528433 has been marked as a duplicate of this bug. ***
Comment 22 info@kobaltwit.be 2009-10-25 09:11:55 EDT
Same here.

I have installed gdm-2.28.1-7.fc12 and now the proper keyboard is selected.
Comment 23 Jóhann B. Guðmundsson 2009-10-26 09:43:59 EDT
*** Bug 530941 has been marked as a duplicate of this bug. ***
Comment 24 Peeter Puusemp 2009-10-26 11:24:37 EDT
Created attachment 366114 [details]
lshal output

(In reply to comment #12)
> This should be fixed in -6.
> 
> Marking MODIFIED

Sorry to say, but it did not fix it for me.

(In reply to comment #6)
> When you click a username at login time (before typing your username), it says
> "English" for Language on the bottom panel, right?

No, the language is Eesti like it should. The keyboard is USA and that is wrong.

> 
> What happens if you click the language selector and change it, then log in?
> 
> Is the session right?  Are subsequent logins right?  

If I select Estonian keyboard and log in then the keyboard layout is Estonian. If I log out and select the user then it says Estonian as keyboard, but after I log in it is set to USA.


(In reply to comment #11)
> two more bits of info that would be very useful to me.
> 
> the contents of /etc/sysconfig/keyboard and the output of lshal  

$ cat /etc/sysconfig/keyboard
KEYTABLE="et"
MODEL="pc105"
LAYOUT="ee"
KEYBOARDTYPE="pc"
Comment 25 Jóhann B. Guðmundsson 2009-10-26 11:38:56 EDT
I have installed gdm-2.28.1-7.fc12 and now the proper keyboard is selected so this fixes things for me...  

Not sure if this is relevant but when I do cat /etc/sysconfig/keyboard I have a + in front of the KEYTABlE as in 

$ cat /etc/sysconfig/keyboard
+KEYTABLE="is-latin1"
MODEL="pc105"
LAYOUT="is"
KEYBOARDTYPE="pc"

Noticed in comment 24 that the + is missing which begs the question is the + supposed to be there or not?
Comment 26 Peeter Puusemp 2009-10-26 11:46:51 EDT
(In reply to comment #24)
> (In reply to comment #12)
> > This should be fixed in -6.
> > 
> > Marking MODIFIED
> 
> Sorry to say, but it did not fix it for me.
> 

I apologize. Since there was a gdm update, I assumed that it was .6 or newer, but actually it was .5. I try to get the newest one from the koji.
Comment 27 Peeter Puusemp 2009-10-26 11:56:55 EDT
(In reply to comment #26)
> I apologize. Since there was a gdm update, I assumed that it was .6 or newer,
> but actually it was .5. I try to get the newest one from the koji.  

I installed the version -9 from Koji and I can confirm that the problem is solved. Thanks!
Comment 28 Arkady L. Shane 2009-10-27 09:24:02 EDT
This problem is steel present if LAYOUT in /etc/sysconfig/keyboard contains more than one meaning and us is one of them. For example, LAYOUT="us,ru".

There are many languages in system-config-keyboard keyboard_models.py file which use "us" and another one.

So it is really fixed if LAYOUT contains only one meaning, but in my case the problem is not solved.
Comment 29 Peter Robinson 2009-10-27 13:11:13 EDT
Has the fixed package been tagged into F-12? I didn't see it in todays rawhide report. There's no packages tagged f-12 (only dist-f12-updates-candidate) in koji and I don't see an open rel-eng ticket to get it tagged into the release.
Comment 30 Ray Strode [halfline] 2009-10-27 19:22:44 EDT
Yes I had it tagged sometime earlier today.
Comment 31 Adam Williamson 2009-10-27 21:47:23 EDT
Ray: is comment #28 sufficient grounds to re-open this?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 32 Ray Strode [halfline] 2009-10-28 01:13:14 EDT
Arkady,

This bug report is about the system keyboard layout getting ignored and US getting used instead.

Your issue seems different.  Can you file a detailed explanation of your problem in another report?
Comment 33 D.S. Ljungmark 2009-10-28 09:26:50 EDT
[spider@Weaver]~% cat /etc/sysconfig/keyboard
KEYBOARDTYPE="pc"
KEYTABLE="sv-latin1"
LAYOUT="se"
MODEL="pc105"
OPTIONS=""
VARIANT=""

[spider@Weaver]~% gconftool-2 -R /desktop/gnome/peripherals/keyboard 
 bell_custom_file = (no value set)
 rate = 30
 bell_pitch = 400
 remember_numlock_state = true
 bell_duration = 100
 click = true
 click_volume = 0
 repeat = true
 bell_mode = on
 delay = 500
 /desktop/gnome/peripherals/keyboard/indicator:
  secondary = 0
  showFlags = false
  enabledPlugins = []
 /desktop/gnome/peripherals/keyboard/preview:
  x = 128
  y = 96
  height = 576
  width = 768
 /desktop/gnome/peripherals/keyboard/host-weaver@46@takeit@46@se:
  /desktop/gnome/peripherals/keyboard/host-weaver@46@takeit@46@se/0:
   numlock_on = false
 /desktop/gnome/peripherals/keyboard/host-Weaver:
  /desktop/gnome/peripherals/keyboard/host-Weaver/0:
   numlock_on = false
 /desktop/gnome/peripherals/keyboard/general:
  defaultGroup = 0
  update_handlers = []
  handleIndicators = false
  disable_sysconfig_changed_warning = false
  groupPerWindow = false
  known_file_list = []
  layoutNamesAsGroupNames = true
  loadExtraItems = false
 /desktop/gnome/peripherals/keyboard/kbd:
  layouts = [se,us]
  options = [grp	grp:shift_caps_toggle]
  model = 


[spider@Weaver]~% cat .dmrc 

[Desktop]
Language=en_US.utf8
Layout=us




Same issue here, still bugging as of 2009-10-28
Comment 34 D.S. Ljungmark 2009-10-28 09:49:31 EDT
Installed -12 and tested:  First test gave me american input again (grrr), once again restoring my real keyboard layout, both in the somewhat hard to discover input field for the password and once inside, and it seems to retain it.


However, I'm not 100% that things work okay if the default keyboard layout from when you feed the password in is different from the default in the desktop.
Comment 35 seventhguardian 2009-10-29 15:09:00 EDT
I've tested version -6 from koji in another system, and it fixed the problem.

But on this system I've only used rawhide rpms, and the gdm-2.28.1-12.fc12.x86_64 doesn't solve it. I still need to either select the Portuguese layout on gdm, or then fix it after login. Reopening.
Comment 36 Ray Strode [halfline] 2009-10-29 20:42:12 EDT
Hey Renato,

Would you mind opening a new bug for the issue mentioned in comment 35?  Since the original problem was fixed for most users, it's likely that the issue you're seeing is separate.
Comment 37 seventhguardian 2009-10-31 09:18:59 EDT
(In reply to comment #36)
> Hey Renato,
> 
> Would you mind opening a new bug for the issue mentioned in comment 35?  Since
> the original problem was fixed for most users, it's likely that the issue
> you're seeing is separate.  

Sure.
Comment 38 Igor Pires Soares 2009-11-01 15:17:53 EST
Renato, if you filed another bug for this please let me know the bug number.

The behavior is still broken when using kickstart files too.
Comment 39 seventhguardian 2009-11-01 15:48:57 EST
(In reply to comment #38)
> Renato, if you filed another bug for this please let me know the bug number.
> 
> The behavior is still broken when using kickstart files too.  

Here it is:
https://bugzilla.redhat.com/show_bug.cgi?id=532212
Comment 40 birger 2009-11-08 13:53:44 EST
I just installed from the F12rc DVD.

Selected Norwegian layout during install, and after install I had Norwegian as default during login and in my environment after login. This was with a fresh local user created during firstboot.

This particular bug seems to be fixed for fresh installs.
Comment 41 Jihed Amine 2009-11-11 14:51:02 EST
Using a fresh install of Fedora 12 beta upgraded to rawhide, I still have this bug. System uses french canadian layout, gnome too uses french canadian layout but gdm creates the usa layout in its list and defaults to it.
Comment 42 Adam Williamson 2009-11-11 15:21:01 EST
yes, because you installed from beta. You need to install from something newer to avoid the bug. I believe workarounds for your case are listed above, though.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 43 Peter Robinson 2009-11-12 06:21:27 EST
Interestingly this is mostly fixed for me. Its fixed in all apps except occasionally the terminal reverts to US keyboard, while everything else still is in UK format.
Comment 44 Adam Williamson 2009-11-13 00:08:56 EST
peter: that would be a totally different issue, then.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 45 Jerther 2010-01-02 12:48:21 EST
I'm using GDM 2.28.1-25 and Fedora 12

I want the keyboard layout to be set to Canada.

At the login screen, the layout is set to USA. If I log in, it is still set to USA, and I have to go change it to Canada. If I log out, the keyboard layout is still set to USA at the login screen, and the cycle goes on.

At the login screen, if I change the keyboard layout to Canada, the DISPLAY freezes except for the cursor. Nothing seems to react to clicks but if I click on the login button, it does log in, and it seems to have accepted the Canada layout since it is still correctly set.

From there, if I log out, at the login screen the keyboard layout is back to USA.

So, as a workaround, every time I login I have the choice to either freeze GDM or change the layout once logged.

cat /etc/sysconfig/keyboard

KEYBOARDTYPE="pc"
KEYTABLE="cf"
LAYOUT="ca(fr)"
MODEL="pc105"
OPTIONS=""
VARIANT=""

cat .dmrc

[Desktop]
Language=en_US.UTF-8
Layout=us


hmmm, could this be related to the .dmrc? I have no idea how it got set to that.

Note You need to log in before you can comment on or make changes to this bug.