Bug 534055

Summary: The default disk layout is not sufficient for preupgrade
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: jlaska, lili, mishu, vanmeeuwen+fedora, wwoods
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-10 19:01:48 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
error message
logs none

Description Kamil Páral 2009-11-10 06:44:09 EST
Created attachment 368370 [details]
error message

Description of problem:
The default disk layout is 200MB for /boot and rest for LVM containing / and swap. I have installed F11 with accepting all the defaults. When I tried to preupgrade, I received a message there is not enough space on the /boot partition (see error.png). The disk layout should be proposed in such a way that preupgrade works with default values.

I was preupgrading from Fedora 11 to Rawhide (soon to be released as F12).

Version-Release number of selected component (if applicable):
anaconda 12.46

How reproducible:
tried once
Actual results:
not possible to do preupgrade with default F11 install

Expected results:
possible to do preupgrade with default F11 install
Comment 1 Kamil Páral 2009-11-10 06:44:29 EST
Created attachment 368371 [details]
Comment 2 Kamil Páral 2009-11-10 06:55:39 EST
Adding CC to jlaska, because I believe he hit this issue too.
Comment 3 Liam Li 2009-11-10 07:19:02 EST
preupgrade from f10 to rawhide has the same issue. please see below about the pic and logs.
Comment 4 Liam Li 2009-11-10 07:21:06 EST
Created attachment 368378 [details]

this is the error message preupgrade from f10 to rawhide
Comment 5 Liam Li 2009-11-10 07:24:41 EST
Created attachment 368379 [details]

logs of preupgrade, the out message is insufficient disk space,but actually my system has a 160G disk and only installed a f10
Comment 6 Radek Vykydal 2009-11-10 08:22:08 EST
*** Bug 533748 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2009-11-10 09:14:58 EST
I have increased the /boot size in rawhide to 250 MB which should once again hold us for a little while.  However, keep in mind that anaconda in the past doesn't know how much preupgrade in the future is going to require, so there's always the possibility of hitting this issue from time to time.  I suggest that if you have a bunch of kernel packages installed, you try removing one or two you no longer need to make some room.
Comment 8 James Laska 2009-11-10 09:25:59 EST
Chris, I'd like to leave this open if possible for now.  I don't think there's anything we can do for F-11 anaconda at this point.  But if this is an issue we are now seeing during all preupgrade testing, we may need to come up with a strategy to mitigate this issue for F-11 -> F-12 preupgraders.

As you note above, it very well may just be the number of kernels installed.  I'm going to assign this to F-11/preupgrade for now.
Comment 9 James Laska 2009-11-10 10:17:20 EST
After an autopart+default F-11 install then upgrade to latest F-11 updates, /boot contains 163M of free space.  This includes 2 kernels (F-11-GOLD and latest kernel in updates).

# df -Thl | grep boot
/dev/vda1     ext3    194M   22M  163M  12% /boot

# The F-12-RC4 kernel, ramdisk and install.img are about ~144M.  
  117M install.img
   22M images/pxeboot/initrd.img
  3.3M images/pxeboot/vmlinuz

This leaves about 20M of room for the F-12 kernel+ramdisk.  Is that enough?  I gather not.
Comment 10 Kamil Páral 2009-11-10 10:35:25 EST
Maybe we could mark this as CommonBugs and mention it on the wiki/release notes? It is possible many users will hit this.
Comment 11 James Laska 2009-11-10 10:41:01 EST
Wwoods directed me to bug#530541 which may be the same issue.

I discovered that prior to rebooting into the preupgrade-prepared anaconda
environment, I had 2 kernels installed.

This left 19M of free space in /boot.  I removed the older kernel and there is
now 27M of free space.  This was sufficient to proceed with a
preupgrade-prepared anaconda upgrade.
Comment 12 James Laska 2009-11-10 11:09:39 EST
The right mix to free up just enough space was ...

For F-11+updates/i386 install
 * Remove all but the running kernel

For F-11+updates/x86_64:
 * Remove all but running kernel
 * Free up more space: rm -rf /boot/efi
Comment 13 James Laska 2009-11-10 19:01:48 EST

*** This bug has been marked as a duplicate of bug 530541 ***