Bug 534072

Summary: Ejects then closing disc tray on eject
Product: [Fedora] Fedora Reporter: Bastien Nocera <bnocera>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: alexl, anaconda-maint-list, bnocera, davidz, tbzatek, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-10 15:43:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
anaconda's udev rules none

Description Bastien Nocera 2009-11-10 13:56:45 UTC
gvfs-1.4.1-3.fc12.x86_64
gnome-disk-utility-2.28.1-1.fc12.x86_64

Using an optical drive with a tray that can both open and close, I can't get nautilus to eject the disc and wait.

1. Insert disc in drive
2. Have it mounted
3. Right-click -> Eject
4. Ejects the disc
and within a few seconds
5. Tray rolls back in

My guess is that the drive is being probed whilst the tray is open, which it shouldn't do.

Let me know if you need debug info.

Comment 1 David Zeuthen 2009-11-10 14:47:01 UTC
Does moving /lib/udev/rules.d/70-anaconda.rules out of the way helps?

Comment 2 David Zeuthen 2009-11-10 15:14:51 UTC
(reasons I'm asking is that I've seen some bugs mentioning this being a problem - can't find it right now though)

Comment 3 Bastien Nocera 2009-11-10 15:27:16 UTC
And indeed removing those rules from anaconda makes it work as expected.

Comment 4 Bastien Nocera 2009-11-10 15:28:24 UTC
Created attachment 368414 [details]
anaconda's udev rules

My bet is on blkid before over eager.

Comment 5 David Zeuthen 2009-11-10 15:35:46 UTC
Something like

 KERNEL=="sr*", ENV{ID_CDROM_MEDIA}!="?*", GOTO="dont_scan_empty_drive"

avoids scanning empty optical drives causing the tray to be closed.

Comment 6 Chris Lumens 2009-11-10 15:43:46 UTC
This will be fixed in rawhide, though not in F12.  As a workaround, you can either remove the 70-anaconda.rules file or add what we did in 527781 to make sure it's still present but not executed.

*** This bug has been marked as a duplicate of bug 527781 ***

Comment 7 Bastien Nocera 2009-11-10 16:03:43 UTC
(In reply to comment #6)
> This will be fixed in rawhide, though not in F12.  As a workaround, you can
> either remove the 70-anaconda.rules file or add what we did in 527781 to make
> sure it's still present but not executed.

How about using David's work-around above, and adding that to an F12 update (which would fix the problem of it happening on a new Live CD install).