Bug 527781 - Cd tray is closed automatically after ejecting
Cd tray is closed automatically after ejecting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 534072 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-07 13:06 EDT by Harald Hoyer
Modified: 2010-02-01 10:51 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-01 10:51:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2009-10-07 13:06:56 EDT
Description of problem:

Install from LiveCD and you end up with

/lib/udev/rules.d/70-anaconda.rules

If you eject a CD, one of the rules of 70-anaconda.rules kicks in and calls blkid, which should not be done (see /lib/udev/rules.d/60-persistent-storage.rules). blkid causes the CD tray to close immediately.

Solutions in order of preference:

1) push all rules upstream to udev or to the tools they belong to and obsolete 70-anaconda.rules completely

2) remove 70-anaconda.rules after installation (might be a symlink)

3) enclose the rules with:
ENV{ANACONDA}!=".*", GOTO="anaconda_end"
... rules....
LABEL="anaconda_end"
and set ANACONDA from anaconda with:
# udevadm control --env=ANACONDA=1

4) remove anaconda completely after livecd installation
Comment 1 Chris Lumens 2009-10-13 09:30:54 EDT
We'll do #3 for now while we very slowly continue to do #1.
Comment 2 Chris Lumens 2009-11-10 10:43:46 EST
*** Bug 534072 has been marked as a duplicate of this bug. ***
Comment 3 Kamil Dudka 2010-01-30 05:40:54 EST
Would be possible to fix the bug in F-12 anaconda and release an update addressing it?

This embarrassing bug has been polluting Fedora since F-9 and I am still closing duplicates...
Comment 4 Kamil Dudka 2010-01-30 05:47:40 EST
more info at bug 453095
Comment 5 Chris Lumens 2010-02-01 10:51:35 EST
No, we don't really release updates for anaconda as that requires making entirely new media spins which requires additional QA work, rel-eng work, etc.  However, Fedora Unity does some of this if you want to send this bug to them.

Note You need to log in before you can comment on or make changes to this bug.