Bug 536275 (RHQ-642)

Summary: set up maven poms so we can publish jars at time of release to the jboss maven repo (use java.net wagon-svn extension)
Product: [Other] RHQ Project Reporter: Ian Springer <ian.springer>
Component: Build SystemAssignee: Ian Springer <ian.springer>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.1preCC: ccrouch
Target Milestone: ---Keywords: Task
Target Release: ---   
Hardware: All   
OS: All   
URL: http://jira.rhq-project.org/browse/RHQ-642
Whiteboard:
Fixed In Version: 1.2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Ian Springer 2008-07-03 16:17:00 EDT
We could either:

1) try to get the Wagon-SVN (https://wagon-svn.dev.java.net/) Maven extension working and publish release artifacts directly to the JBoss Maven repo SVN repo.

or:

2) publish artifacts to the a checkout of the JBoss Maven repo on the local filesystem and then checkin the updates. this procedure is described at http://www.jboss.org/community/docs/DOC-11376.

Comment 1 Joseph Marques 2009-02-03 14:55:25 EST
ian, should this be done in 1.2?
Comment 2 Ian Springer 2009-03-17 11:04:39 EDT
r3444 and r3445 update our root pom and sample settings.xml, so that the procedure described at http://www.jboss.org/community/docs/DOC-11376 can be used to publish release jars to the JBoss Maven repo.

In a nutshell, the procedure is:

One-time steps:
1) Checkout the JBoss Maven repo source from SVN:
        svn co https://svn.jboss.org/repos/repository.jboss.org/maven2/  jboss-m2-repo
2) In ~/.m2/settings.xml, set jboss.repository.root to the full path to a checkout of the JBoss Maven repo (e.g. C:/Projects/jboss-m2-repo)

Per-release steps:
1) Checkout release tag of RHQ (or Jopr), e.g.:
        svn co http://svn.rhq-project.org/repos/rhq/tags/RHQ_1_1_2_GA/  rhq-1.1.2
2) Run 'mvn release' from dir where the tag is checked out.
3) svn commit the local checkout of the JBoss Maven repo.
Comment 3 Ian Springer 2009-03-17 11:09:10 EDT
Note, we went with option 2, since it's easier to setup and what is recommended on the JBoss Maven wiki.
Comment 4 Red Hat Bugzilla 2009-11-10 16:13:52 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-642