Bug 538600

Summary: preupgrade fails to do anything fc-11 to fc12
Product: [Fedora] Fedora Reporter: Ray Todd Stevens <raytodd>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: cwickert, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-19 09:28:36 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Ray Todd Stevens 2009-11-18 16:54:06 EST
I have a system that failed to upgrade with preupgrade.  Apparently the grub.conf is unchanged.   Also it definately did not have time to download the packages.   Now the /boot is on raid1, and it detects that.   Then it says that as long as you have a wired connection and can download it this is ok.   Then it has a button to push to reboot and start the upgrade.   Push that and nothing happens.

/usr/lib/python2.6/site-packages/yum/__init__.py:203: UserWarning: Use .preconf instead of passing args to _getConfig 
  warnings.warn('Use .preconf instead of passing args to _getConfig') 
Loaded plugins: blacklist, dellsysidplugin2, refresh-packagekit, whiteout 
[root@charon grub]# preupgrade 
/usr/lib/python2.6/site-packages/yum/__init__.py:203: UserWarning: Use .preconf instead of passing args to _getConfig 
  warnings.warn('Use .preconf instead of passing args to _getConfig') 
Loaded plugins: blacklist, dellsysidplugin2, refresh-packagekit, whiteout 
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-12&arch=$basearch 
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-12&arch=i386 
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/12/Fedora/$basearch/os 
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/12/Fedora/i386/os 
preupgrade-fedora (mirrorlist) 
  url: https://mirrors.fedoraproject.org/metalink?repo=fedora-12&arch=i386 
  now: https://mirrors.fedoraproject.org/metalink?repo=fedora-12&arch=i386 
unknown metadata being downloaded: metalink 
preupgrade-updates (mirrorlist) 
  url: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f12&arch=i386 
  now: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f12&arch=i386 
Traceback (most recent call last): 
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 240, in on_assistant_apply 
    self._do_main() 
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in _do_main 
    self.main_preupgrade() 
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 436, in main_preupgrade 
    download_progressbar=self.dnlProgress) 
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 130, in setup 
    self.complete_repo_setup() 
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 328, in complete_repo_setup 
    repo._grabfunc.opts.user_agent = __user_agent__ 
AttributeError: 'NoneType' object has no attribute 'opts' 

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/md0             147786584   8380340 131899076   6% /
/dev/sda2              6048352    143236   5597876   3% /temp
tmpfs                   481412       884    480528   1% /dev/shm
Comment 1 Christoph Wickert 2009-11-19 09:28:36 EST

*** This bug has been marked as a duplicate of bug 538118 ***