Bug 538118 - preupgrade crashes when resuming after an interrupted/failed run
preupgrade crashes when resuming after an interrupted/failed run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 538123 538136 538152 538600 538688 539515 540237 540549 542152 543611 546943 547182 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 12:04 EST by Steven Garrity
Modified: 2014-01-21 18:12 EST (History)
31 users (show)

See Also:
Fixed In Version: 1.1.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-08 15:00:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error from preupgrade (3.33 KB, text/plain)
2009-11-17 12:57 EST, Steven Garrity
no flags Details

  None (edit)
Description Steven Garrity 2009-11-17 12:04:16 EST
Description of problem:
Running preupgrade on F11 (trying to upgrade to F12), getting an error.

Version-Release number of selected component (if applicable):
Preupgrade v1.1.2

How reproducible:
Always

Steps to Reproduce:
1. Run preupgrade, wait a bit

Actual results:
Getting an error ending with "AttributeError: 'NoneType' object has no attribute 'opts'"


Expected results: A great upgrade.


Additional info: Here's the full output in the terminal, including the error:

$ preupgrade
/usr/lib/python2.6/site-packages/yum/__init__.py:203: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Loaded plugins: blacklist, presto, refresh-packagekit, whiteout
Detected in-progress upgrade to Fedora 12 (Constantine)
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-12&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-12&arch=i386
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/12/Fedora/$basearch/os
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/12/Fedora/i386/os
preupgrade-adobe-linux-i386 (baseurl) 
  url: http://linuxdownload.adobe.com/linux/i386/
  now: http://linuxdownload.adobe.com/linux/i386/
preupgrade-chromium (baseurl) 
  url: http://spot.fedorapeople.org/chromium/F12/
  now: http://spot.fedorapeople.org/chromium/F12/
preupgrade-fedora (mirrorlist) 
  url: https://mirrors.fedoraproject.org/metalink?repo=fedora-12&arch=i386
  now: https://mirrors.fedoraproject.org/metalink?repo=fedora-12&arch=i386
unknown metadata being downloaded: metalink
preupgrade-google (baseurl) 
  url: http://dl.google.com/linux/rpm/stable/i386
  now: http://dl.google.com/linux/rpm/stable/i386
preupgrade-google-testing (baseurl) 
  url: http://dl.google.com/linux/rpm/testing/i386
  now: http://dl.google.com/linux/rpm/testing/i386
preupgrade-rpmfusion-free (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-12&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-12&arch=i386
preupgrade-rpmfusion-free-updates (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-12&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-12&arch=i386
preupgrade-rpmfusion-nonfree (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-12&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-12&arch=i386
preupgrade-rpmfusion-nonfree-updates (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-12&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-12&arch=i386
preupgrade-updates (mirrorlist) 
  url: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f12&arch=i386
  now: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f12&arch=i386
unknown metadata being downloaded: metalink
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 764, in <module>
    widgets = PreUpgradeGtk()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 376, in __init__
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 436, in main_preupgrade
    download_progressbar=self.dnlProgress)
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 130, in setup
    self.complete_repo_setup()
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 328, in complete_repo_setup
    repo._grabfunc.opts.user_agent = __user_agent__
Comment 1 Will Woods 2009-11-17 12:43:04 EST
You left off the last line of the traceback, which has the actual error. Luckily someone else reported it:

AttributeError: 'NoneType' object has no attribute 'opts'

Could you please provide the versions of the following packages:
rpm -q yum createrepo python-urlgrabber
Comment 2 Nicholas Miell 2009-11-17 12:46:45 EST
yum-3.2.24-2.fc11.noarch
createrepo-0.9.7-7.fc11.noarch
python-urlgrabber-3.0.0-15.fc11.noarch

I upgraded to the updates-testing version of preupgrade and I'm trying again, will report what happens.
Comment 3 Reid Rivenburgh 2009-11-17 12:50:09 EST
FYI, I'm seeing this too, with preupgrade-1.1.3-1.fc11.noarch.  I was also using the cli version and am now trying the GUI.  It seems to be progressing better, but I'm running it over a slow remote connection.
Comment 4 Reid Rivenburgh 2009-11-17 12:51:12 EST
Oh, and same package versions here as Nicholas in comment 2.
Comment 5 seth vidal 2009-11-17 12:53:11 EST
looks like the yum instance of the urlgrabber object is not setup when preupgrade tries to set the useragent. Not sure why, though, I don't recall any changes to that interface at all.
Comment 6 Will Woods 2009-11-17 12:56:43 EST
Are you resuming an interrupted preupgrade? Did you run preupgrade to get to F11?
Comment 7 Steven Garrity 2009-11-17 12:57:59 EST
Created attachment 369926 [details]
error from preupgrade

Yeah, I have the same package versions as comment #2:

yum-3.2.24-2.fc11.noarch
createrepo-0.9.7-7.fc11.noarch
python-urlgrabber-3.0.0-15.fc11.noarch

Sorry for omitting the key line from the error in my original report. For the sake of (late) completeness, here's the full output.
Comment 8 Steven Garrity 2009-11-17 13:01:43 EST
(In reply to comment #6)
> Are you resuming an interrupted preupgrade? Did you run preupgrade to get to
> F11?  

I am resuming an interrupted preupgrade, but it was interrupted by the same crash.

No, I did not run preupgrade to get from F10 to F11.
Comment 9 Will Woods 2009-11-17 13:01:53 EST
*** Bug 538123 has been marked as a duplicate of this bug. ***
Comment 10 Reid Rivenburgh 2009-11-17 13:03:39 EST
I got this error when I first tried to preupgrade F11 -> F12.  Now that I'm trying the GUI version, it does think I'm resuming.

I'm pretty sure I did do a preupgrade to go F10 -> F11 when F11 came out.
Comment 11 Will Woods 2009-11-17 13:03:54 EST
*** Bug 538136 has been marked as a duplicate of this bug. ***
Comment 12 Michael Young 2009-11-17 13:15:29 EST
If I say no to the question about resuming it runs through to the reboot message, seemingly without doing anything more.

If I do rm -rf /var/cache/yum/preupgrade* then run preupgrade and say no to resuming then it does seem, after a long delay and some network traffic, to allow me to start a fresh preupgrade (I haven't run it to completion yet).
Comment 13 Reid Rivenburgh 2009-11-17 13:32:53 EST
I did an "rm -rf /var/cache/yum/preupgrade*", and now preupgrade-cli is downloading packages.  (The error happened before that point.)  My initial run of preupgrade involved a bunch of extra repositories like livna, google, rpmfusion, and adobe, one of which may have caused a problem.  Now I'm doing a fresh start with just fedora and fedora-updates and it seems to be working.
Comment 14 Charley Wang 2009-11-17 13:52:28 EST
Sorry for the late reply, and sorry for leaving off the last line : /

Here's the rpm -q as requested:
yum-3.2.24-2.fc11.noarch
createrepo-0.9.7-7.fc11.noarch
python-urlgrabber-3.0.0-15.fc11.noarch


My /boot is indeed quite full, mostly with an image in /boot/upgrade (117M). I'll try rm -rf /var/cache/yum/preupgrade* and see if that will upgrade correctly.

The error posted above is indeed from attempting to resume preupgrade after the first reboot failed. However, I'm pretty sure I created this system from scratch, and not as an upgrade from F10.
Comment 15 Guil Barros 2009-11-17 14:03:40 EST
*** Bug 538152 has been marked as a duplicate of this bug. ***
Comment 16 Adri Verhoef 2009-11-17 16:23:51 EST
$ rpm -q yum createrepo python-urlgrabber
yum-3.2.24-2.fc11.noarch
createrepo-0.9.7-7.fc11.noarch
python-urlgrabber-3.0.0-15.fc11.noarch

I ran 'preupgrade', too, to upgrade from F11 to F12, but the first time I did that it gave up with:
Not enough space in /boot/upgrade to download install.img.

Then I moved the directory /boot/upgrade to /xxx (some other file system with enough space) and made a symbolic link:

# cd /boot; ln -s /xxx/upgrade

I started 'preupgrade' for the second time, but after several minutes it bombed out with:
AttributeError: 'NoneType' object has no attribute 'opts'

I tried 'preupgrade' again, but the same thing happened.

Then I went to bugzilla and found out about the problem.
I decided to "rm -rf /var/cache/yum/preupgrade*" and run 'preupgrade' again.
Everything seems to be going fine so far.
It's now happily downloading packages (before the "Prepare and test packages") ...
Comment 17 Charley Wang 2009-11-17 17:22:26 EST
Attempting to preupgrade again generates the out of memory error for me during reboot.

After cleaning out the old kernel versions in /boot, the error message currently claims it needs 0MB more space, though this may be because it is rounding down.
Comment 18 EMR_Fedora 2009-11-17 20:18:23 EST
Not to add to the noise, but my upgrade got interrupted and it gives the same error. Is there a way this can resume in the future because it was sitting here for a long time downloading, now I have to start over.
Comment 19 Andy Burns 2009-11-18 04:34:51 EST
(In reply to comment #6)

> Are you resuming an interrupted preupgrade? Did you run preupgrade to get to
> F11?  

This install was not a preupgrade from F10.

preupgrade  had downloaded all packages for F11-F12 then hit a problem with mirrors timing out while loading metadata, so had to resume the pre-upgrade, I then hit the error caused by interrupted preupgrade

tried the updates-testing version of preupgrade, same problem, had to 
rm -rf /var/cache/yum/preupgrade*

this allowed it to work, but now having to download 700MB again, hoping I don't run into mirror problems again this time ...
Comment 20 Richard Schwarting 2009-11-18 05:12:08 EST
I'll note as a workaround, I edited the file tripping the AttributeError to catch and ignore it[1], and I've been able to continue.  Having limited monthly bandwidth and already having used up almost a GB of it, I really didn't want to restart.

I'll note that I use RPM Fusion a little, if esoteric repos might be the culprit.

1. http://blog.kosmokaryote.org/2009/11/preupgrade-crash-when-resuming.html
Comment 21 tom-ipp 2009-11-18 06:42:54 EST
Hello,

I had the same issue with preupgrade.
The boot partition was too small.
I used yumextender to remove excessive kernels.
Then everytime I launch preupgrade, I had the error "AttributeError: 'NoneType' object has no attribute 'opts'" and an infinite reboot.
I then used "rm -rf /var/cache/yum/preupgrade*"
I can confirm that preupgrade now works.
Thanks.
tom-ipp
Comment 22 Will Woods 2009-11-18 09:48:06 EST
1) This bug has nothing to do with "out of disk on /boot" errors - for that, go to bug 530541.

2) Re Comment #18: Yes, you can normally resume interrupted upgrades, but this bug is *in* the "resume interrupted upgrade" code.
Comment 23 Andy Burns 2009-11-18 17:37:45 EST
(In reply to comment #19)

> rm -rf /var/cache/yum/preupgrade*
> 
> allowed it to work, but now having to download 700MB again, hoping I don't
> run into mirror problems again this time ...  

Upgrade did proceed after this, rebooted and downloaded the stage2 image (because my /boot only 200MB) and the anaconda phase completed fine, I did notice that I still have 800MB of RPMs left under /var/cache/yum/preupgrade* folders

Is this related to the "failure to resume" issue, or worth logging as a separate BZ?
Comment 24 Sean Buehler 2009-11-19 00:24:00 EST
in regards to #22 .. I received OutOfSpace issues for /boot and have been having the same issue.

rm -rf /var/cache/yum/preupgrade*   currently running preupgrade now and has yet to error out
Comment 25 seth vidal 2009-11-19 00:52:29 EST
*** Bug 538688 has been marked as a duplicate of this bug. ***
Comment 26 Victor Bogado 2009-11-19 05:06:08 EST
I'm trying to restart the process removing all files in the preupgrade dirs except for the "packages" dir. It seems to be working fine, requiring a minimum of re-downloads. I did a 'rm preupgrade-*/!(packages)' followed by 'rm -rf preupgrade' and restarted the process.
Comment 27 Christoph Wickert 2009-11-19 09:28:36 EST
*** Bug 538600 has been marked as a duplicate of this bug. ***
Comment 28 Ray Todd Stevens 2009-11-19 10:28:18 EST
Interesting  538600 is my bug.

The machine I had this on has a single partition with no seperate /boot.   The single partition is RAID1.

When I upgraded from fc10 to fc11 I did indeed have a failure and had to do a cdrom based across the wire upgrade.    I got this on my first attempt at a preupgrade fc11 -- fc12 upgrade.

It seems like there should be a way to clear the preupgrade system so that you start fresh.   Maybe something like yum clean all actually also cleaning the preupgrade system.   But yeah that would tie to systems together, which might be bad.   Maybe we need a preupgrade clean all command.
Comment 29 Will Woods 2009-11-19 11:35:13 EST
(In reply to comment #28)
> Maybe we need a preupgrade clean all command.

There already is one. Try preupgrade --clean.

This will delete all the downloaded metadata and packages, so you'll have to download them again. Comment #26 notes that it's not necessary to delete the packages, just the metadata. So you might try that instead.
Comment 30 Ray Todd Stevens 2009-11-19 15:29:37 EST
Actually preupgrade --clean doesn't fix the problem.  

A manual delete of the directory does, but then it seems to cause other problems.
Comment 31 Ray Todd Stevens 2009-11-19 15:40:36 EST
OK I am wondering if I am a duplicate or not.

For one thing I have tried to delete all of the old data on the first machine, and still get the same thing.   I also am now experiencing this on a second machine.   That machine was generated as a fc11 machine so never has had preupgrade run on it before.
Comment 32 Martí­n Marqués 2009-11-20 08:09:34 EST
(In reply to comment #29)
> (In reply to comment #28)
> > Maybe we need a preupgrade clean all command.
> 
> There already is one. Try preupgrade --clean.

preupgrade --clean didn't work. 

I had to rm -rf /var/cache/yum/preupgrade*.
Comment 33 Ray Todd Stevens 2009-11-20 10:41:41 EST
Here to, and it still didn't fully work, but crashed again apparently in a different place.
Comment 34 Will Woods 2009-11-20 10:53:18 EST
*** Bug 539515 has been marked as a duplicate of this bug. ***
Comment 35 Chris Rankin 2009-11-22 16:13:12 EST
*** Bug 540237 has been marked as a duplicate of this bug. ***
Comment 36 Runwalsoft 2009-11-23 07:04:09 EST
I have tried with
rm -rf /var/cache/yum/preupgrade*. 

but still effect is same. as I am getting same error which is written here.
--------
repo._grabfunc.opts.user_agent = __user_agent__
AttributeError: 'NoneType' object has no attribute 'opts'
-----
Without this we can't use fedora 12.
Comment 37 seth vidal 2009-11-23 11:38:49 EST
*** Bug 540549 has been marked as a duplicate of this bug. ***
Comment 38 Edward Rudd 2009-11-23 12:35:43 EST
I have a fix for this.. a Correct fix

Change the line 

repo._grabfunc.opts.user_agent = __user_agent

to 

repo._getgrabfunc().opts.user_agent = __user_agent

that will ensure that _grabfunc is initialized correctly.
Comment 39 seth vidal 2009-11-23 12:39:05 EST
checking it to:

repo.grabfunc.opts.user_agent = __user_agent

will work, too.

b/c grabfunc is a property call to _getgrabfunc()

so - same result.
Comment 40 Samuel Irlapati 2009-11-23 12:50:17 EST
repo._getgrabfunc().opts.user_agent = __user_agent
 did not work for me

repo.grabfunc.opts.user_agent = __user_agent
worked for me.
Comment 41 seth vidal 2009-11-23 13:08:52 EST
so
diff --git a/preupgrade/__init__.py b/preupgrade/__init__.py
index 2e82f1e..d79ec4b 100644
--- a/preupgrade/__init__.py
+++ b/preupgrade/__init__.py
@@ -325,7 +325,7 @@ class PreUpgrade(yum.YumBase):
         rf = open(repofile,"w")
         for repo in [self.instrepo] + self.repos.listEnabled():
             # adapted from YumRepository.write()
-            repo._grabfunc.opts.user_agent = __user_agent__
+            repo.grabfunc.opts.user_agent = __user_agent__
             yc = yumConfigParser()
             yc.add_section(repo.id)
             for k,v in repo.iteritems():
Comment 42 Habig, Alec 2009-11-24 14:59:13 EST
Seth's patch from Comment #41 worked for me.
Comment 43 skiffx 2009-11-24 17:31:19 EST
Looks like this helped in my case as well: 
rm -rf /var/cache/yum/preupgrade*
Comment 44 Martin Ellison 2009-11-24 21:41:30 EST
#41 worked for me too.
Comment 45 Runwalsoft 2009-11-25 23:02:49 EST
My Network connection is 256kbps so I can't download 1.6GB in one attempt so I have to break the processes multiple times and restart it again after another day.
Yesterday it was working #41 given. and downloaded around 400MBytes of files.
But today when I started to download I got following errors
==========================
/boot/upgrade/vmlinuz checksum OK
/boot/upgrade/initrd.img checksum OK
/boot/upgrade/install.img checksum OK
Checking for new repos for mirrors
 * preupgrade-updates: mirror.svk.su
*** glibc detected *** /usr/bin/python: double free or corruption (out): 0x0aa07098 ***
======= Backtrace: =========
/lib/libc.so.6[0x1802a1]
/usr/lib/libpython2.6.so.1.0[0x79d1a1b]
/usr/lib/python2.6/lib-dynload/_elementtree.so[0x7cab23]
/usr/lib/python2.6/lib-dynload/_elementtree.so[0x7ca639]
/usr/lib/python2.6/lib-dynload/_elementtree.so[0x7caae4]
/usr/lib/python2.6/lib-dynload/_elementtree.so[0x7ca639]
/usr/lib/python2.6/lib-dynload/_elementtree.so[0x7caae4]
/usr/lib/libpython2.6.so.1.0[0x79c8caa]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x55c)[0x7a3bb1c]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x443c)[0x7a39f9c]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x53ad)[0x7a3af0d]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x7b9)[0x7a3bd79]
/usr/lib/libpython2.6.so.1.0[0x79cab87]
/usr/lib/libpython2.6.so.1.0(PyObject_Call+0x5c)[0x799e72c]
/usr/lib/libpython2.6.so.1.0[0x799ee04]
/usr/lib/libpython2.6.so.1.0(PyObject_CallFunction+0x3f)[0x799f10f]
/usr/lib/libpython2.6.so.1.0[0x79b89f1]
/usr/lib/libpython2.6.so.1.0(PyObject_GenericGetAttr+0x153)[0x79e01d3]
/usr/lib/libpython2.6.so.1.0(PyObject_GetAttr+0x5f)[0x79e058f]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x276e)[0x7a382ce]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x53ad)[0x7a3af0d]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x53ad)[0x7a3af0d]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x7b9)[0x7a3bd79]
/usr/lib/libpython2.6.so.1.0(PyEval_EvalCode+0x63)[0x7a3bed3]
/usr/lib/libpython2.6.so.1.0[0x7a56eab]
/usr/lib/libpython2.6.so.1.0(PyRun_FileExFlags+0x92)[0x7a56f72]
/usr/lib/libpython2.6.so.1.0(PyRun_SimpleFileExFlags+0xda)[0x7a5851a]
/usr/lib/libpython2.6.so.1.0(PyRun_AnyFileExFlags+0x7a)[0x7a58daa]
/usr/lib/libpython2.6.so.1.0(Py_Main+0xb82)[0x7a65592]
/usr/bin/python(main+0x27)[0x80485c7]
/lib/libc.so.6(__libc_start_main+0xe6)[0x126a66]
/usr/bin/python[0x8048501]
======= Memory map: ========
00110000-0027b000 r-xp 00000000 fd:00 344213     /lib/libc-2.10.1.so
0027b000-0027d000 r--p 0016b000 fd:00 344213     /lib/libc-2.10.1.so
0027d000-0027e000 rw-p 0016d000 fd:00 344213     /lib/libc-2.10.1.so
0027e000-00281000 rw-p 00000000 00:00 0 
00281000-0028c000 r-xp 00000000 fd:00 5179047    /usr/lib/python2.6/lib-dynload/_socketmodule.so
0028c000-0028f000 rw-p 0000b000 fd:00 5179047    /usr/lib/python2.6/lib-dynload/_socketmodule.so
0028f000-00298000 r-xp 00000000 fd:00 4458161    /usr/lib/libkrb5support.so.0.1
00298000-00299000 rw-p 00008000 fd:00 4458161    /usr/lib/libkrb5support.so.0.1
00299000-0029a000 r-xp 00000000 fd:00 5179011    /usr/lib/python2.6/lib-dynload/_bisect.so
0029a000-0029b000 rw-p 00001000 fd:00 5179011    /usr/lib/python2.6/lib-dynload/_bisect.so
0029b000-002ab000 r-xp 00000000 fd:00 5179058    /usr/lib/python2.6/lib-dynload/cPickle.so
002ab000-002ac000 rw-p 00010000 fd:00 5179058    /usr/lib/python2.6/lib-dynload/cPickle.so
002ac000-002b0000 r-xp 00000000 fd:00 5179693    /usr/lib/python2.6/lib-dynload/selectmodule.so
002b0000-002b2000 rw-p 00003000 fd:00 5179693    /usr/lib/python2.6/lib-dynload/selectmodule.so
002b2000-002b8000 r-xp 00000000 fd:00 5179057    /usr/lib/python2.6/lib-dynload/bz2.so
002b8000-002ba000 rw-p 00006000 fd:00 5179057    /usr/lib/python2.6/lib-dynload/bz2.so
002ba000-002bc000 r-xp 00000000 fd:00 5179145    /usr/lib/python2.6/lib-dynload/grpmodule.so
002bc000-002bd000 rw-p 00001000 fd:00 5179145    /usr/lib/python2.6/lib-dynload/grpmodule.so
002bf000-002c1000 r-xp 00000000 fd:00 5179030    /usr/lib/python2.6/lib-dynload/_functools.so
002c1000-002c2000 rw-p 00001000 fd:00 5179030    /usr/lib/python2.6/lib-dynload/_functools.so
002c2000-002c4000 r-xp 00000000 fd:00 5179696    /usr/lib/python2.6/lib-dynload/syslog.so
002c4000-002c5000 rw-p 00001000 fd:00 5179696    /usr/lib/python2.6/lib-dynload/syslog.so
002c8000-002f2000 r-xp 00000000 fd:00 344248     /lib/libgcc_s-4.4.1-20090729.so.1
002f2000-002f3000 rw-p 00029000 fd:00 344248     /lib/libgcc_s-4.4.1-20090729.so.1
002f5000-00309000 r-xp 00000000 fd:00 344251     /lib/libresolv-2.10.1.so
00309000-0030a000 ---p 00014000 fd:00 344251     /lib/libresolv-2.10.1.so
0030a000-0030b000 r--p 00014000 fd:00 344251     /lib/libresolv-2.10.1.so
0030b000-0030c000 rw-p 00015000 fd:00 344251     /lib/libresolv-2.10.1.so
0030c000-0030e000 rw-p 00000000 00:00 0 
00310000-00325000 r-xp 00000000 fd:00 4458289    /usr/lib/libelf-0.142.so
00325000-00326000 r--p 00014000 fd:00 4458289    /usr/lib/libelf-0.142.so
00326000-00327000 rw-p 00015000 fd:00 4458289    /usr/lib/libelf-0.142.so
00327000-0036a000 r-xp 00000000 fd:00 345468     /lib/libfreebl3.so
0036a000-0036b000 rw-p 00042000 fd:00 345468     /lib/libfreebl3.so
0036b000-0036f000 rw-p 00000000 00:00 0 
0036f000-003b7000 r-xp 00000000 fd:00 4458167    /usr/lib/libssl.so.0.9.8k
003b7000-003bb000 rw-p 00047000 fd:00 4458167    /usr/lib/libssl.so.0.9.8k
003bb000-003df000 r-xp 00000000 fd:00 344245     /lib/libexpat.so.1.5.2
003df000-003e1000 rw-p 00024000 fd:00 344245     /lib/libexpat.so.1.5.2
003e1000-003ef000 r-xp 00000000 fd:00 5179049    /usr/lib/python2.6/lib-dynload/_sqlite3.so
003ef000-003f1000 rw-p 0000e000 fd:00 5179049    /usr/lib/python2.6/lib-dynload/_sqlite3.so
003f1000-003fb000 r-xp 00000000 fd:00 5179947    /usr/lib/python2.6/site-packages/_sqlitecache.so
003fb000-003fc000 rw-p 00009000 fd:00 5179947    /usr/lib/python2.6/site-packages/_sqlitecache.so
003fc000-00404000 r-xp 00000000 fd:00 5179147    /usr/lib/python2.6/lib-dynload/itertoolsmodule.so
00404000-00407000 rw-p 00008000 fd:00 5179147    /usr/lib/python2.6/lib-dynload/itertoolsmodule.so
00407000-00409000 r-xp 00000000 fd:00 5179032    /usr/lib/python2.6/lib-dynload/_heapq.so
00409000-0040b000 rw-p 00002000 fd:00 5179032    /usr/lib/python2.6/lib-dynload/_heapq.so
0040d000-0040f000 r-xp 00000000 fd:00 344253     /lib/libcom_err.so.2.1
0040f000-00410000 rw-p 00001000 fd:00 344253     /lib/libcom_err.so.2.1
00412000-00435000 r-xp 00000000 fd:00 4458162    /usr/lib/libk5crypto.so.3.1
00435000-00436000 rw-p 00023000 fd:00 4458162    /usr/lib/libk5crypto.so.3.1
00436000-0043a000 r-xp 00000000 fd:00 344258     /lib/libcap.so.2.16
0043a000-0043b000 rw-p 00003000 fd:00 344258     /lib/libcap.so.2.16
0043b000-0043f000 r-xp 00000000 fd:00 344255     /lib/libattr.so.1.1.0
0043f000-00440000 rw-p 00003000 fd:00 344255     /lib/libattr.so.1.1.0
00448000-0044d000 r-xp 00000000 fd:00 344246     /lib/libnss_dns-2.10.1.so
0044d000-0044e000 r--p 00004000 fd:00 344246     /lib/libnss_dns-2.10.1.so
0044e000-0044f000 rw-p 00005000 fd:00 344246     /lib/libnss_dns-2.10.1.so
0044f000-00465000 r-xp 00000000 fd:00 5179893    /usr/lib/python2.6/site-packages/_dbus_bindings.so
00465000-00470000 rw-p 00016000 fd:00 5179893    /usr/lib/python2.6/site-packages/_dbus_bindings.so
00470000-004af000 r-xp 00000000 fd:00 344262     /lib/libdbus-1.so.3.4.0
004af000-004b0000 r--p 0003e000 fd:00 344262     /lib/libdbus-1.so.3.4.0
004b0000-004b1000 rw-p 0003f000 fd:00 344262     /lib/libdbus-1.so.3.4.0
004b1000-004ba000 r-xp 00000000 fd:00 5202233    /usr/lib/python2.6/site-packages/_xmlplus/parsers/pyexpat.so
004ba000-004bc000 rw-p 00008000 fd:00 5202233    /usr/lib/python2.6/site-packages/_xmlplus/parsers/pyexpat.so
004ca000-004cd000 r-xp 00000000 fd:00 5179059    /usr/lib/python2.6/lib-dynload/cStringIO.so
004cd000-004ce000 rw-p 00003000 fd:00 5179059    /usr/lib/python2.6/lib-dynload/cStringIO.so
004ce000-00568000 r-xp 00000000 fd:00 4458163    /usr/lib/libkrb5.so.3.3
00568000-0056a000 rw-p 0009a000 fd:00 4458163    /usr/lib/libkrb5.so.3.3
0056a000-00581000 r-xp 00000000 fd:00 5179023    /usr/lib/python2.6/lib-dynload/_ctypes.so
00581000-00584000 rw-p 00017000 fd:00 5179023    /usr/lib/python2.6/lib-dynload/_ctypes.so
0058a000-0058e000 r-xp 00000000 fd:00 5179702    /usr/lib/python2.6/lib-dynload/zlibmodule.so
0058e000-00590000 rw-p 00003000 fd:00 5179702    /usr/lib/python2.6/lib-dynload/zlibmodule.so
005a6000-005ac000 r-xp 00000000 fd:00 5179051    /usr/lib/python2.6/lib-dynload/_ssl.so
005ac000-005ad000 rw-p 00006000 fd:00 5179051    /usr/lib/python2.6/lib-dynload/_ssl.so
005b1000-005db000 r-xp 00000000 fd:00 4458164    /usr/lib/libgssapi_krb5.so.2.2
005db000-005dc000 rw-p 0002a000 fd:00 4458164    /usr/lib/libgssapi_krb5.so.2.2
005e6000-005e8000 r-xp 00000000 fd:00 5179042    /usr/lib/python2.6/lib-dynload/_randommodule.so
005e8000-005e9000 rw-p 00002000 fd:00 5179042    /usr/lib/python2.6/lib-dynload/_randommodule.so
005ff000-00605000 r-xp 00000000 fd:00 5179687    /usr/lib/python2.6/lib-dynload/operator.so
00605000-00607000 rw-p 00005000 fd:00 5179687    /usr/lib/python2.6/lib-dynload/operator.so
00618000-00650000 r-xp 00000000 fd:00 345445     /lib/libsoftokn3.so
00650000-00651000 rw-p 00038000 fd:00 345445     /lib/libsoftokn3.so
00651000-0067f000 r-xp 00000000 fd:00 344316     /lib/libncursesw.so.5.7
0067f000-00680000 rw-p 0002e000 fd:00 344316     /lib/libncursesw.so.5.7
00686000-00688000 r-xp 00000000 fd:00 344249     /lib/libkeyutils-1.2.so
00688000-00689000 rw-p 00001000 fd:00 344249     /lib/libkeyutilAborted
==========================

Please provide me help.
Comment 46 Jeff Moe (jebba) 2009-11-26 11:38:05 EST
Patch in comment #41 worked for me.

I'll also note that the preupgrade package needs a:

Requires: anaconda

Want a separate bz for that?
Comment 47 Chris Rankin 2009-11-28 18:37:23 EST
Just to confirm: the fix in #41 works for me too.
Comment 48 Runwalsoft 2009-11-28 23:03:09 EST
I have sent this message Comment #45. But on another attempt I have seen that #41 works for me as well. Now I am sending this message from fedora 12. Thanks everyone.
Comment 49 Will Woods 2009-11-30 09:40:59 EST
*** Bug 542152 has been marked as a duplicate of this bug. ***
Comment 50 Sebastian Krämer 2009-12-01 07:46:57 EST
#41 worked here too. Thanks.
Comment 51 Don Seiler 2009-12-02 09:43:21 EST
Comment #41 for the win.  Please fix so I don't lose another half-day.  :p
Comment 52 seth vidal 2009-12-02 13:14:17 EST
*** Bug 543611 has been marked as a duplicate of this bug. ***
Comment 53 Namit Karlekar 2009-12-02 23:52:02 EST
Comment #41 did it for me !
Comment 54 Alan Eliasen 2009-12-06 02:52:36 EST
I had several preupgrades fail and then could not be resumed due to this bug.  
Manually patching according to the solution in Comment #41 worked for me.  Please push this critical bug through!  It's only a one-character fix!
Comment 55 hdfssk 2009-12-08 13:48:15 EST
I had the same experience as Comment #54.

Please, push this fix quickly! It's been known for more than two weeks now; it could hit anyone running an upgrade; it isn't listed on the common bugs page http://fedoraproject.org/wiki/Common_F12_bugs#Issues_when_upgrading_from_previous_releases .. I'm sure people are busy, but come on! One character fix. Known for more than two weeks. Please get it out there!
Comment 56 seth vidal 2009-12-12 18:10:43 EST
*** Bug 546943 has been marked as a duplicate of this bug. ***
Comment 57 seth vidal 2009-12-14 08:19:32 EST
*** Bug 547182 has been marked as a duplicate of this bug. ***
Comment 58 Will Woods 2009-12-14 14:55:44 EST
The patch from comment #41 has been accepted in preupgrade git. Preupgrade 1.1.4 has been tagged and the tarball is available here: 
https://fedorahosted.org/releases/p/r/preupgrade/preupgrade-1.1.4.tar.bz2

Seth, could you (or some other maintainer) update and build new packages?
Comment 59 Fedora Update System 2009-12-16 11:36:31 EST
preupgrade-1.1.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/preupgrade-1.1.4-1.fc11
Comment 60 Fedora Update System 2009-12-16 11:39:21 EST
preupgrade-1.1.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/preupgrade-1.1.4-1.fc12
Comment 61 Fedora Update System 2009-12-17 23:27:58 EST
preupgrade-1.1.4-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13313
Comment 62 Fedora Update System 2009-12-17 23:29:47 EST
preupgrade-1.1.4-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13322
Comment 63 Thomas Schweikle 2010-01-05 22:36:09 EST
What files does preupgrade put where and how do I remove them? preupgrade does not provide any way to reset it to virgin just a lack of documentation. It could be helpful to have at least the various places data is stored ...

There is one place: "/var/cache/yum/preupgrade" given here. But is it sure the only place??
Comment 64 Ray Todd Stevens 2010-01-05 23:01:25 EST
Sorry it is still failing.

Also preupgrade clean doesn't seem to do its job.
Comment 65 seth vidal 2010-01-06 09:52:23 EST
Thomas: preupgrade-cli --clean

will restore it to a pristine state.

Ray: can you be a bit more clear about what is failing for you? The new preupgrade mentioned in the testing repo shouldn't be failing in the same way at all.
Comment 66 Ray Todd Stevens 2010-01-06 10:28:26 EST
Interesting.   I am pretty sure I got an email that this had been pushed to the production repository.   I have not tried the testing version.  Sorry on that, didn't catch the difference.

As for the --clean,   I have tried it both as preupgrade and preupgrade-cli and neither cleans the system so that a crashed previous upgrade now works with the production version.   This includes a (AAARRRGGG) "here I need to unplug that so I  can vacuum" crash.   What you get for using a normal desk to hold a standby server while you work on it.
Comment 67 Thomas Schweikle 2010-01-06 16:48:21 EST
@vidal: preupgrade-cli --clean or preupgrade --clean did not do the job. I had to combine it with "rm -rf /var/cache/yum/preupgrade; preupgrade --clean; preupgrade-cli --clean". Afterwards I got rid of the error and the system was upgraded until ... "I don't know". Because I only had a black screen with mouse cursor on it. No reaction on moving the mouse or pressing keys. Got out of it only via hard reset.

After having bootet the system again I could find a new kernel installed and the system reporting "Fedora 12 (Constantine)" before login. The kernel including ram-disk was bootable. And then: 2361 packages installed. A little less than the double of what was installed with Fedora 12 (1391) not doing an upgrade. That is OK, because nearly all packages are installed with there F11 and F12 versions. Since they share most files installed it is quite difficult to remove the old F11 one, without damaging the F12 one. Reinstalling the F12 one is difficult too, since some are necessary for yum to work and yum does not like to reinstall already installed packages ...
Comment 68 seth vidal 2010-01-06 16:53:26 EST
yum reinstall works fine for reinstalling pkgs.
Comment 69 Ray Todd Stevens 2010-01-06 17:23:23 EST
I have seen this a couple of times with the doubling up of the installed files, and also have seen it decide to install everything, and then interestingly enough then uninstall every package.   Not sure what exactly happened.   Generally at this point I do a scratch reinstall.   But that is not this bug.
Comment 70 Mads Kiilerich 2010-01-06 19:14:39 EST
FWIW: The times I have seen doubly installed packages after upgrade it has been because the yum transaction had been interrupted before the old packages was removed. "yum-complete-transaction" has solved that. Alternatively "package-cleanup --cleandupes".
Comment 71 Thomas Schweikle 2010-01-06 20:47:41 EST
@Mads Kiilerich: "yum-complete-transaction" does not do anything --- seem all transactions are completed. "package-cleanup --cleanupdups" removes all old F11 packages. The system now looks a lot like the one reinstalled from scratch.

I could trac down what went wrong wile installing via preupgrade: quite simple the system looses mouse and keyboard wile upgrading. If the screen saver starts then it does not recognize mouse movements or keypresses. A side effect is, changing dialogs can't be clicked any more ... :(

Maybe preupgrade should detect a running screensaver, kill em and make sure they don't start again until all operations are done.
Comment 72 Ray Todd Stevens 2010-01-06 20:57:39 EST
I think I have seen this with the keyboard and mouse too.  Certainly I see it reguarly with one or the other where I get into a status where the mouse stops working or the keyboard stops working.   Have not seen both at the same time that I know of but ....
Comment 73 Martin Ellison 2010-01-06 21:30:04 EST
All these interesting options for yum, could someone ensure that they are documented in the release notes to each release? somewhere that does not require too much digging, given that when they are required it is usually some sort of emergency?
Comment 74 seth vidal 2010-01-06 22:05:53 EST
all the yum options are documented in yum's man pages and briefly documented in the yum --help output.

This is FAR afield of this bug, though.
Comment 75 Fedora Update System 2010-01-08 15:00:25 EST
preupgrade-1.1.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 76 Fedora Update System 2010-01-08 15:15:30 EST
preupgrade-1.1.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.