This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 539515

Summary: traceback triggered by repo._grabfunc = NoneType
Product: [Fedora] Fedora Reporter: Jon Burgess <jburgess777>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-20 10:53:18 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
full console output from preupgrade none

Description Jon Burgess 2009-11-20 08:09:21 EST
Created attachment 372483 [details]
full console output from preupgrade

Description of problem:
Tried running preupgrade on F11. Got part way through before the program exitted and a traceback was on the console

Version-Release number of selected component (if applicable):
preupgrade-1.1.3-1.fc11.noarch
yum-3.2.24-2.fc11.noarch

How reproducible:
Don't know. Suspect it depends on which repos are enabled

Steps to Reproduce:
1. Run preupgrade
2. select f12 for upgrade
3. click next a few times
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 773, in <module>
    widgets = PreUpgradeGtk()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 376, in __init__
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 436, in main_preupgrade
    download_progressbar=self.dnlProgress)
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 130, in setup
    self.complete_repo_setup()
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 328, in complete_repo_setup
    repo._grabfunc.opts.user_agent = __user_agent__
AttributeError: 'NoneType' object has no attribute 'opts'


Expected results:


Additional info:

Full output showing the list of repos in attachment

This is the second time I tried running preupgrade. I was initially running version 1.1.2-1.fc11 and found that it had some issues with my /boot raid1 setup (it said it had finished without actually downloading any packages). I found bug 533545 which mentions this is unsupported and suggests this new version should reject this config. I downloaded from koji and got the error above, it did not get to the point of rejecting the raid setup.
Comment 1 Will Woods 2009-11-20 10:53:18 EST

*** This bug has been marked as a duplicate of bug 538118 ***