Bug 544305

Summary: Assertion failure in _gcry_ath_mutex_lock inside lock_pool running /usr/share/virt-manager/virt-manager.py
Product: [Fedora] Fedora Reporter: Aleksander Trofimowicz <aatrof>
Component: libvirtAssignee: Cole Robinson <crobinso>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: berrange, clalance, crobinso, dmalcolm, hbrock, itamar, ivazqueznet, james.antill, jforbes, jonathansteffan, katzj, lochner, tj, veillard, virt-maint
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: abrt_hash:6d5c573d6004ca98871d56801ae618d397527efc
Fixed In Version: libvirt-0.7.1-16.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-28 13:56:24 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 514891    
Attachments:
Description Flags
File: backtrace none

Description Aleksander Trofimowicz 2009-12-04 09:46:46 EST
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. connect to remote host via TLS
2. try to open vnc console (also nested in TLS)
3. wait for a while (it not deterministic, so you may be lucky enought not to experience a crash)

Comment
-----
remote vnc sessions doesn't work. what is worse, a crash of virt-manager can lead to a crash of virtual machine on a remote host you are trying connect to. host is using qemu-kvm from git tree (head at d0be25...f72848)
using vinagre i have never noticed such problems.

Attached file: backtrace
cmdline: python /usr/share/virt-manager/virt-manager.py --no-fork
component: python
executable: /usr/bin/python
kernel: 2.6.31.6-145.fc12.x86_64
package: python-2.6.2-2.fc12
rating: 4
reason: Process was terminated by signal 6
Comment 1 Aleksander Trofimowicz 2009-12-04 09:46:49 EST
Created attachment 376096 [details]
File: backtrace
Comment 2 Dave Malcolm 2009-12-05 09:53:13 EST
Thank you for reporting this bug.

How reproducable is this problem?  If you run the program from a terminal, is an error message printed?

What version of virt-manager do you have installed?

Looking at the backtrace, it looks like an assertion failed inside frame 2 of thread #1 inside _gcry_ath_mutex_lock.

Reassigning component from "python" to "virt-manager"
Comment 3 Aleksander Trofimowicz 2009-12-08 03:13:56 EST
(In reply to comment #2)
> 
> How reproducable is this problem?  

i would say the probability is around 0.95 whenever i try to open a graphical console and stick around for a couple of seconds.

> If you run the program from a terminal, is
> an error message printed?
> 
yes it is. but there is nothing that cannot be found in the backtrace:

$ virt-manager --no-fork
/usr/share/virt-manager/virtManager/manager.py:150: GtkWarning: gtk_toolbar_set_icon_size: assertion `icon_size != GTK_ICON_SIZE_INVALID' failed
  self.window = gtk.glade.XML(config.get_glade_dir() + "/vmm-manager.glade", "vmm-manager", domain="virt-manager")
python: ath.c:193: _gcry_ath_mutex_lock: Assertion `*lock == ((ath_mutex_t) 0)' failed.
Aborted (core dumped)

> What version of virt-manager do you have installed?
>
0.8.0-7 and 0.8.0-8. both produce the same results.
Comment 4 Daniel Berrange 2009-12-17 13:21:30 EST
Needs this libvirt fix

https://www.redhat.com/archives/libvir-list/2009-December/msg00486.html

But also requires a similar patch to gtk-vnc

https://bugzilla.redhat.com/show_bug.cgi?id=537489
Comment 5 Dave Torrey 2010-01-08 14:21:40 EST
To me, this would seem to seriously affect usability, and there appears to be a fix.  Any estimates as to when a new package will be available on the libvirt side?
Comment 6 Cole Robinson 2010-05-12 10:01:05 EDT
*** Bug 591503 has been marked as a duplicate of this bug. ***
Comment 7 Cole Robinson 2010-05-12 10:01:52 EDT
Sorry about the delay on this bug, I'll build a libvirt update this week.
Comment 8 Fedora Update System 2010-05-18 12:55:34 EDT
libvirt-0.7.1-16.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libvirt-0.7.1-16.fc12
Comment 9 Fedora Update System 2010-05-19 15:13:33 EDT
libvirt-0.7.1-16.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libvirt-0.7.1-16.fc12
Comment 10 Richard A Lochner 2010-05-20 12:11:20 EDT
The -16 patch definitely solved this problem for me.  I could reproduce it consistently and I cannot any longer.
Comment 11 Fedora Update System 2010-05-28 13:55:47 EDT
libvirt-0.7.1-16.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.