Bug 537489 - Assertion failure in _gcry_ath_mutex_lock
Assertion failure in _gcry_ath_mutex_lock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
abrt_hash:7a1865d762003243e36aecc5d92...
:
: 538074 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-13 15:22 EST by Jeff Layton
Modified: 2014-06-18 03:39 EDT (History)
12 users (show)

See Also:
Fixed In Version: 0.3.10-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 591827 (view as bug list)
Environment:
Last Closed: 2010-01-07 16:47:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (24.19 KB, text/plain)
2009-11-13 15:22 EST, Jeff Layton
no flags Details

  None (edit)
Description Jeff Layton 2009-11-13 15:22:27 EST
abrt detected a crash.

Comment: Trying to open a console in virt-manager of a machine on another host.
Attached file: backtrace
cmdline: python /usr/share/virt-manager/virt-manager.py
component: python
executable: /usr/bin/python
kernel: 2.6.31.5-127.fc12.x86_64
package: python-2.6.2-2.fc12
rating: 3
reason: Process was terminated by signal 6
Comment 1 Jeff Layton 2009-11-13 15:22:29 EST
Created attachment 369479 [details]
File: backtrace
Comment 2 Dave Malcolm 2009-11-13 15:35:19 EST
Thanks for filing this bug.

From the backtrace, it looks like an assertion failed; frame 2 of thread 1 has:
  Assertion `*lock == ((ath_mutex_t) 0)' failed.
in _gcry_ath_mutex_lock, deep inside gvnc_start_tls (frame 21) within gvnc_initialize (frame 24).

So it looks like an assertion failure deep inside gvnc's TLS code, which causes the process to abort.

Reassigning component from "python" to "virt-manager" in the hope that someone with knowledge of that domain can assign it to a more appropriate component.

He or she will probably want to know which version of virt-manager, libvirt, etc you have installed.
Comment 3 Jeff Layton 2009-11-13 15:41:49 EST
Here's the versions of those two:

virt-manager-0.8.0-7.fc12.noarch
libvirt-0.7.1-15.fc12.x86_64

...let me know if you need other info.
Comment 4 Cole Robinson 2009-11-15 11:46:16 EST
Sounds like this is gtk-vnc code, reassigning there.
Comment 5 Dave Malcolm 2009-11-17 09:51:39 EST
*** Bug 538074 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Berrange 2009-12-17 13:42:02 EST
Fix built in gtk-vnc-0.3.10-2.fc12

This fixes the problem as far as GTK-VNC is concerned. It'll likely still crash though because of an identical bug in libvirt https://bugzilla.redhat.com/show_bug.cgi?id=544305
Comment 7 Fedora Update System 2009-12-17 13:43:22 EST
gtk-vnc-0.3.10-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gtk-vnc-0.3.10-2.fc12
Comment 8 Fedora Update System 2009-12-21 23:48:29 EST
gtk-vnc-0.3.10-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-vnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13469
Comment 9 Fedora Update System 2010-01-07 16:47:00 EST
gtk-vnc-0.3.10-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.