Bug 545597

Summary: Script errors starting network
Product: [Fedora] Fedora Reporter: Mads Kiilerich <mads>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: dcbw, iarlyy, notting, plautrba, rvokal
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: initscripts-9.02.2-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 557941 (view as bug list) Environment:
Last Closed: 2010-01-22 20:37:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 557941    

Description Mads Kiilerich 2009-12-08 22:01:53 UTC
Description of problem:

[root@localhost ~]# service network start
Bringing up loopback interface:                            [  OK  ]
Bringing up interface Auto_kiilerich:  Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.

Determining IP information for ... done.
cat: /sys/class/net//ifindex: No such file or directory
/etc/sysconfig/network-scripts/ifup-eth: line 302: 1000 + : syntax error: operand expected (error token is "+ ")
Missing config file ifcfg-ifcfg-Auto_kiilerich.
Command line is not complete. Try option "help"
                                                           [  OK  ]



The two failing greps are because ifup-eth calls "is_available ${REALDEVICE}" where REALDEVICE isn't set, and is_available() in 
network-functions starts with a grep which fails if $1 isn't set.

(check_link_down() is also called without parameters because DEVICE isn't set, but that cause no immediate failure.)

Finally cat fails when adding zeroconf rule, again because REALDEVICE isn't set, and that causes the bash calculation to fail.


ifcfg-Auto_kiilerich was created by NetworkManager:

ESSID="kiilerich"
MODE=Managed
KEY_MGMT=WPA-PSK
TYPE=Wireless
BOOTPROTO=dhcp
PEERDNS=yes
PEERROUTES=yes
NAME="Auto kiilerich"
UUID=1b6ba851-d2a0-402d-92ee-3bf1e0b45592
ONBOOT=yes
LAST_CONNECT=1259794157


Version-Release number of selected component (if applicable):

initscripts-9.02.1-1.i686

Comment 1 Mads Kiilerich 2009-12-08 22:15:20 UTC
Oh. Same problem is seen with the old initscripts-9.02-1.i686.

So I guess this is caused by dcbw's reinterpretation of network script semantics? (Which I was hit by in bug 502142 and the http://www.mail-archive.com/networkmanager-list@gnome.org/msg12904.html thread.)

You and initscripts consider DEVICE mandatory?

Comment 2 Bill Nottingham 2009-12-09 20:24:33 UTC
At the moment, it will fail without DEVICE. However, we should as a practical solution allow HWADDR to be sufficient.

We do need *one* of the two, though.

Comment 3 Bill Nottingham 2010-01-22 20:37:58 UTC
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=d9d2e42410e211e180a5ebbb968a1df32077f457

Will be in a future rawhide build.

Comment 4 Fedora Update System 2010-04-28 19:03:23 UTC
initscripts-9.02.2-1 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/initscripts-9.02.2-1

Comment 5 Mads Kiilerich 2010-05-06 11:21:44 UTC
Bug 589521 seems to be another variation over the same theme.

Comment 6 Fedora Update System 2010-05-22 01:47:58 UTC
initscripts-9.02.2-1 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.