Bug 589521 - error starting NM-created connection
error starting NM-created connection
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 595200 (view as bug list)
Depends On:
Blocks: 592108
  Show dependency treegraph
 
Reported: 2010-05-06 07:16 EDT by Mads Kiilerich
Modified: 2014-03-16 23:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: initscripts-9.12.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 592108 (view as bug list)
Environment:
Last Closed: 2010-07-01 14:46:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2010-05-06 07:16:10 EDT
Description of problem:

Bringing up loopback interface:                            [  OK  ]
Bringing up interface Auto_kiilerich:  
Determining IP information for ... done.
cat: /sys/class/net//ifindex: No such file or directory
/etc/sysconfig/network-scripts/ifup-eth: line 286: 1000 + : syntax error: operand expected (error token is "+ ")
Missing config file ifcfg-ifcfg-Auto_kiilerich.
                                                           [  OK  ]


Same setup and config as in bug 545597 where REALDEVICE also isn't set:

# head /etc/sysconfig/network-scripts/{ifcfg,keys}-*
==> /etc/sysconfig/network-scripts/ifcfg-Auto_kiilerich <==
ESSID="kiilerich"
MODE=Managed
KEY_MGMT=WPA-PSK
TYPE=Wireless
BOOTPROTO=dhcp
PEERDNS=yes
PEERROUTES=yes
NAME="Auto kiilerich"
UUID=1b6ba851-d2a0-402d-92ee-3bf4e0e45592
ONBOOT=yes

==> /etc/sysconfig/network-scripts/ifcfg-lo <==
DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback

==> /etc/sysconfig/network-scripts/keys-Auto_kiilerich <==
WPA_PSK="zecret"

==> /etc/sysconfig/network-scripts/keys-eth1 <==
KEY=s:1123581321

==> /etc/sysconfig/network-scripts/keys-Wireless_connection_1 <==
WPA_PSK=alsosecret!


The missing ifcfg-ifcfg-Auto_kiilerich seems like an error too ... or perhaps the same ...


Version-Release number of selected component (if applicable):

initscripts-9.11-1.fc13.i686
Comment 1 Bill Nottingham 2010-05-13 17:28:19 EDT
Fixed to have a more sane error message. Will show up in rawhide and a future F-13 update.

http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=87ef4eb
Comment 2 Bill Nottingham 2010-05-24 10:59:25 EDT
*** Bug 595200 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-06-24 15:32:30 EDT
initscripts-9.12.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/initscripts-9.12.1-1.fc13
Comment 4 Fedora Update System 2010-06-25 14:14:13 EDT
initscripts-9.12.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update initscripts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/initscripts-9.12.1-1.fc13
Comment 5 Fedora Update System 2010-07-01 14:45:29 EDT
initscripts-9.12.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.