Bug 548126

Summary: xenner 0.41: unable to start domU guest
Product: [Fedora] Fedora Reporter: Gerry Reno <greno>
Component: xennerAssignee: Gerd Hoffmann <kraxel>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 12CC: berrange, itamar, jforbes, kraxel, virt-maint
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Ubuntu 9.10
Last Closed: 2009-12-22 11:19:53 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 546334    
Attachments:
Description Flags
original pygrub.cfg
none
libvirt domain xml none

Description Gerry Reno 2009-12-16 12:38:24 EST
Description of problem:
I downloaded a domU guest and kernel (Ubuntu 9.10 32-bit) from http://www.stacklet.com/
Created a libvirt xml file, defined the domain and tried to start it.
The domain refuses to start and xenstored segfaults.

Version-Release number of selected component (if applicable):
xenner 0.41

How reproducible:


Steps to Reproduce:
$ sudo apt-get install xen xenner
$ /etc/init.d/xenner start
$ ### download a domU guest image and kernel (Ubuntu 9.10 32-bit) from
http://www.stacklet.com/
$ sudo -s
# invoke-rc.d apparmor stop
# update-rc.d -f apparmor remove  # disable apparmor
# apparmor_status
# cd /var/lib/libvirt/images
# vi ubuntu-domU.xml  #create libvirt config
# virsh define ubuntu-domU.xml
# virsh start ubuntu-domU
  
Actual results:

Here is the session and logs:

####################################################################
+ virsh start Ubuntu-domU-x86-1
Connecting to uri: qemu:///system
error: Failed to start domain Ubuntu-domU-x86-1
error: internal error unable to start guest: [xenner,1] qemu_monitor_config: unix:/var/run/libvirt/qemu/Ubuntu-domU-x86-1.monitor,server,nowait
[xenner,1] qemu_serial_config: pty
[xenner,1] qemu_disk_config_blkbackd: file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0
[xenner,1] qemu_net_config_netbackd: nic,macaddr=54:52:07:2d:e1:81,vlan=0
[xenner,1] qemu_net_config_netbackd: 0: mac="54:52:07:2d:e1:81"
[xenner,1] qemu_net_config_netbackd: tap,fd=16,vlan=0
[xenner,1] qemu_net_config_netbackd: 0: if="vnet3"
started as: "/usr/bin/xenner" "-S" "-M" "pc" "-m" "2048" "-smp" "4" "-name" "Ubuntu-domU-x86-1" "-uuid" "4027c80e-b5d5-a986-18ed-5887d623d0bb" "-domid" "9" "-nographic" "-monitor" "unix:/var/run/libvirt/qemu/Ubuntu-domU-x86-1.monitor,server,nowait" "-boot" "c" "-kernel" "/home/greno/xen/domU/x86/ubuntu-9.10-karmic/kernel/boot/vmlinuz-2.6.31.6" "-append" "xencons=xvc console=tty1 console=xvc0" "-drive" "file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0" "-net" "nic,macaddr=54:52:07:2d:e1:81,vlan=0" "-n

## /var/log/messages: xenstored segfaults when we 'virsh start...'
Dec 15 19:47:47 grp-01-23-02 kernel: [10087.283379] xenstored[23440]: segfault at 0 ip 000000000040672c sp 00007fff3576e190 error 4 in xenstored[400000+12000]


## domain log:
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin /usr/bin/xenner -S -M pc -m 2048 -smp 4 -name Ubuntu-domU-x86-1 -uuid 4027c80e-b5d5-a986-18ed-5887d623d0bb -domid 8 -nographic -monitor unix:/var/run/libvirt/qemu/Ubuntu-domU-x86-1.monitor,server,nowait -boot c -kernel /home/greno/xen/domU/x86/ubuntu-9.10-karmic/kernel/boot/vmlinuz-2.6.31.6 -append xencons=xvc console=tty1 console=xvc0 -drive file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0 -net nic,macaddr=54:52:07:2d:e1:81,vlan=0 -net tap,fd=16,vlan=0 -serial pty -parallel none -usb
[xenner,1] qemu_monitor_config: unix:/var/run/libvirt/qemu/Ubuntu-domU-x86-1.monitor,server,nowait
[xenner,1] qemu_serial_config: pty
[xenner,1] qemu_disk_config_blkbackd: file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0
[xenner,1] qemu_net_config_netbackd: nic,macaddr=54:52:07:2d:e1:81,vlan=0
[xenner,1] qemu_net_config_netbackd: 0: mac="54:52:07:2d:e1:81"
[xenner,1] qemu_net_config_netbackd: tap,fd=16,vlan=0
[xenner,1] qemu_net_config_netbackd: 0: if="vnet2"
started as: "/usr/bin/xenner" "-S" "-M" "pc" "-m" "2048" "-smp" "4" "-name" "Ubuntu-domU-x86-1" "-uuid" "4027c80e-b5d5-a986-18ed-5887d623d0bb" "-domid" "8" "-nographic" "-monitor" "unix:/var/run/libvirt/qemu/Ubuntu-domU-x86-1.monitor,server,nowait" "-boot" "c" "-kernel" "/home/greno/xen/domU/x86/ubuntu-9.10-karmic/kernel/boot/vmlinuz-2.6.31.6" "-append" "xencons=xvc console=tty1 console=xvc0" "-drive" "file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0" "-net" "nic,macaddr=54:52:07:2d:e1:81,vlan=0" "-net" "tap,fd=16,vlan=0" "-serial" "pty" "-parallel" "none" "-usb"
kvm capability clocksource: ok
kvm capability nop-iodelay: ok
kvm capability mmu-op: not supported
==================== setup ====================
xc_dom_allocate: cmdline="xencons=xvc console=tty1 console=xvc0", features="(null)"
xen_guest_parse: ----- parse kernel -----
xc_dom_kernel_file: filename="/home/greno/xen/domU/x86/ubuntu-9.10-karmic/kernel/boot/vmlinuz-2.6.31.6"
xc_dom_malloc_filemap : 1820 kB
xc_dom_parse_image: called
xc_dom_find_loader: trying ELF-generic loader ... failed
xc_dom_find_loader: trying Linux bzImage loader ... xc_dom_malloc : 3620 kB
xc_dom_do_gunzip: unzip ok, 0x1bf9e6 -> 0x3891a4
OK
elf_parse_binary: phdr: paddr=0x1000000 memsz=0x2a0000
elf_parse_binary: phdr: paddr=0x12a0000 memsz=0x1f3000
elf_parse_binary: memory: 0x1000000 -> 0x1493000
elf_xen_parse_note: GUEST_OS = "linux"
elf_xen_parse_note: GUEST_VERSION = "2.6"
elf_xen_parse_note: XEN_VERSION = "xen-3.0"
elf_xen_parse_note: VIRT_BASE = 0xc0000000
elf_xen_parse_note: ENTRY = 0xc12de000
elf_xen_parse_note: HYPERCALL_PAGE = 0xc1002000
elf_xen_parse_note: FEATURES = "!writable_page_tables|pae_pgdir_above_4gb"
elf_xen_parse_note: PAE_MODE = "yes"
elf_xen_parse_note: LOADER = "generic"
elf_xen_parse_note: unknown xen elf note (0xd)
elf_xen_parse_note: SUSPEND_CANCEL = 0x1
elf_xen_parse_note: HV_START_LOW = 0xf5800000
elf_xen_parse_note: PADDR_OFFSET = 0x0
elf_xen_addr_calc_check: addresses:
virt_base = 0xc0000000
elf_paddr_offset = 0x0
virt_offset = 0xc0000000
virt_kstart = 0xc1000000
virt_kend = 0xc1493000
virt_entry = 0xc12de000
xc_dom_parse_elf_kernel: xen-3.0-x86_32p: 0xc1000000 -> 0xc1493000
[xenner,1] domain_builder: memory: emu 4 MB, m2p 4 MB, guest 2040 MB
xen_emu_load: ----- load xen emu -----
[xenner,1] xen_load_emu_file: loading /usr/lib/xenner/emu32.elf (186892 bytes)
elf_parse_binary: phdr: paddr=0xff000000 memsz=0x2fdc0
elf_parse_binary: memory: 0xff000000 -> 0xff02fdc0
elf_load_binary: phdr 0 at 0x0x7f2f51979000 -> 0x0x7f2f519a5760
xen_emu_setup: ----- memory info -----
xen_emu_setup: ----- emu pgd setup -----
xen_guest_setup: ----- memory setup -----
xc_dom_mem_init: mem 2040 MB, pages 0x7f800 pages, 4k each
xc_dom_mem_init: 0x7f800 pages
xc_dom_malloc : 4080 kB
xen_guest_setup: ----- create start-of-day -----
xc_dom_build_image: called
xc_dom_alloc_segment: kernel : 0xc1000000 -> 0xc1493000 (pfn 0x1000 + 0x493 pages)
xc_dom_pfn_to_ptr: anonymous memory: pfn 0x1000+0x493 at 0x7f2f50b31000
elf_load_binary: phdr 0 at 0x0x7f2f50b31000 -> 0x0x7f2f50dd1000
elf_load_binary: phdr 1 at 0x0x7f2f50dd1000 -> 0x0x7f2f50e61000
xc_dom_alloc_segment: phys2mach : 0xc1493000 -> 0xc1691000 (pfn 0x1493 + 0x1fe pages)
xc_dom_pfn_to_ptr: anonymous memory: pfn 0x1493+0x1fe at 0x7f2f50933000
xc_dom_alloc_page : start info : 0xc1691000 (pfn 0x1691)
xc_dom_alloc_page : xenstore : 0xc1692000 (pfn 0x1692)
xc_dom_alloc_page : console : 0xc1693000 (pfn 0x1693)
nr_page_tables: 0x00000000ffffffff/32: 0x0000000000000000 -> 0x00000000ffffffff, 1 table(s)
nr_page_tables: 0x000000003fffffff/30: 0x00000000c0000000 -> 0x00000000ffffffff, 1 table(s)
nr_page_tables: 0x00000000001fffff/21: 0x00000000c0000000 -> 0x00000000c17fffff, 12 table(s)
xc_dom_alloc_segment: page tables : 0xc1694000 -> 0xc16a2000 (pfn 0x1694 + 0xe pages)
xc_dom_pfn_to_ptr: anonymous memory: pfn 0x1694+0xe at 0x7f2f50925000
xc_dom_alloc_page : boot stack : 0xc16a2000 (pfn 0x16a2)
xc_dom_build_image : virt_alloc_end : 0xc16a3000
xc_dom_build_image : virt_pgtab_end : 0xc1800000
xc_dom_update_guest_p2m: dst 32bit, pages 0x7f800
xc_dom_pfn_to_ptr: anonymous memory: pfn 0x1693+0x1 at 0x7f2f50924000
xc_dom_pfn_to_ptr: anonymous memory: pfn 0x1692+0x1 at 0x7f2f50923000
xc_dom_pfn_to_ptr: anonymous memory: pfn 0x1691+0x1 at 0x7f2f50922000
start_info_x86_32: called
xen_guest_setup: ----- setup xen hypercall page -----
xen_guest_setup: ----- setup vcpu context -----
vcpu_x86_32: called
vcpu_x86_32: cr3: pfn 0x1694 mfn 0x1e94
domain_builder: ----- kvm: state setup -----
xc_dom_release: called
domain_builder: ----- all done -----
[xenner,1] xenstore_device_net: vnic 0: mac="54:52:07:2d:e1:81" if="vnet2" br=""
calibrate tsc ... LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin /usr/bin/xenner -S -M pc -m 2048 -smp 4 -name Ubuntu-domU-x86-1 -uuid 4027c80e-b5d5-a986-18ed-5887d623d0bb -domid 9 -nographic -monitor unix:/var/run/libvirt/qemu/Ubuntu-domU-x86-1.monitor,server,nowait -boot c -kernel /home/greno/xen/domU/x86/ubuntu-9.10-karmic/kernel/boot/vmlinuz-2.6.31.6 -append xencons=xvc console=tty1 console=xvc0 -drive file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0 -net nic,macaddr=54:52:07:2d:e1:81,vlan=0 -net tap,fd=16,vlan=0 -serial pty -parallel none -usb
[xenner,1] qemu_monitor_config: unix:/var/run/libvirt/qemu/Ubuntu-domU-x86-1.monitor,server,nowait
[xenner,1] qemu_serial_config: pty
[xenner,1] qemu_disk_config_blkbackd: file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0
[xenner,1] qemu_net_config_netbackd: nic,macaddr=54:52:07:2d:e1:81,vlan=0
[xenner,1] qemu_net_config_netbackd: 0: mac="54:52:07:2d:e1:81"
[xenner,1] qemu_net_config_netbackd: tap,fd=16,vlan=0
[xenner,1] qemu_net_config_netbackd: 0: if="vnet3"
started as: "/usr/bin/xenner" "-S" "-M" "pc" "-m" "2048" "-smp" "4" "-name" "Ubuntu-domU-x86-1" "-uuid" "4027c80e-b5d5-a986-18ed-5887d623d0bb" "-domid" "9" "-nographic" "-monitor" "unix:/var/run/libvirt/qemu/Ubuntu-domU-x86-1.monitor,server,nowait" "-boot" "c" "-kernel" "/home/greno/xen/domU/x86/ubuntu-9.10-karmic/kernel/boot/vmlinuz-2.6.31.6" "-append" "xencons=xvc console=tty1 console=xvc0" "-drive" "file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0" "-net" "nic,macaddr=54:52:07:2d:e1:81,vlan=0" "-net" "tap,fd=16,vlan=0" "-serial" "pty" "-parallel" "none" "-usb"
kvm capability clocksource: ok
kvm capability nop-iodelay: ok
kvm capability mmu-op: not supported
==================== setup ====================
[xenner,0] xenstore_init_early: can't connect to /var/run/xenstored/socket (xenstored not running?)
xenner_cleanup: ----- cleaning up -----
####################################################################


And if I start it from the command line xenstored segfaults but the domain has a  process still.


Expected results:


Additional info:

attaching pygrub.cfg and domain xml files
Comment 1 Gerry Reno 2009-12-16 12:39:54 EST
Created attachment 378800 [details]
original pygrub.cfg
Comment 2 Gerry Reno 2009-12-16 12:41:18 EST
Created attachment 378802 [details]
libvirt domain xml
Comment 3 Justin M. Forbes 2009-12-22 11:19:53 EST

*** This bug has been marked as a duplicate of bug 548131 ***
Comment 4 Gerry Reno 2009-12-22 12:30:08 EST
Bug 548126 (this bug) and bug 548131 are not duplicates.  The symptoms are entirely different and happened on different platforms.

Bug 548126 involves the segfaulting of xenstored whenever the user tries to start xenner.

Bug 548131 involves the fact that xenner as a libvirt emulator does not support all the emulator command line options being generated by libvirt.

Please reopen this bug so that these two issues can be tracked separately.
Comment 5 Justin M. Forbes 2009-12-22 16:34:00 EST
You are right, it should not have been closed as a duplicate, it should have been closed as wontfix since xenner 0.41 is not included in any supported release of Fedora. Fedora 11 is on xenner 0.46 and Fedora 12 is on xenner 0.47