Bug 548131 - xenner 0.46: unable to start domU guest
xenner 0.46: unable to start domU guest
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xenner (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Gerd Hoffmann
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F13VirtPonies
  Show dependency treegraph
 
Reported: 2009-12-16 12:56 EST by Gerry Reno
Modified: 2010-02-17 04:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 04:09:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original pygrub.cfg (158 bytes, text/plain)
2009-12-16 12:57 EST, Gerry Reno
no flags Details
libvirt domain xml (1.15 KB, text/plain)
2009-12-16 12:58 EST, Gerry Reno
no flags Details

  None (edit)
Description Gerry Reno 2009-12-16 12:56:50 EST
Description of problem:
I downloaded a domU guest and kernel (Ubuntu 9.10 32-bit) from
http://www.stacklet.com/
Created a libvirt xml file, defined the domain and tried to start it.
Using libvirt domain does not start because xenner does not recognize all the command line arguments.

Version-Release number of selected component (if applicable):
xenner 0.46

How reproducible:


Steps to Reproduce:
# su -
# yum install xen xenner
# /etc/init.d/xenner start
$ ### download a domU guest image and kernel (Ubuntu 9.10 32-bit) from
http://www.stacklet.com/
# cd /var/lib/libvirt/images
# vi ubuntu-domU.xml  #create libvirt config
# virsh define ubuntu-domU.xml
# virsh start ubuntu-domU

  
Actual results:


libvirt generates a bad xenner command line.  Here is the F11 domain log:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/xenner -S -M pc -m 2048 -smp 4 -name Ubuntu-domU-x86-1 -uuid 5ab6d1df-14fc-2eee-1fa4-b72fb7ba9321 -domid 4 -nographic -monitor pty -pidfile /var/run/libvirt/qemu//Ubuntu-domU-x86-1.pid -boot c -kernel /home/greno/xen/domU/x86/ubuntu-9.10-karmic/kernel/boot/vmlinuz-2.6.31.6 -append xencons=xvc console=tty1 console=xvc0 -drive file=/var/lib/libvirt/images/ubuntu.9-10.x86.img,if=xen,index=0 -net nic,macaddr=54:52:07:2d:e1:81,vlan=0 -net tap,fd=23,vlan=0 -serial pty -parallel none -usb
[xenner,1] qemu_monitor_config: pty
char device redirected to /dev/pts/6
unknown option (or missing arg): -pidfile
QEMU PC emulator version 0.9.1
/*
* No, it isn't.  This just makes libvirt qemu version detection happy,
* so you can manage xenner guests using libvirts qemu driver.
*/

xenner v0.46 -- run xen kernels in kvm

usage: xenner [options]
options (qemu compatible):
  -help                    print this text
  -S                       start with vcpus stopped
  -kernel     <kernel>     xenified kernel image
  -initrd     <ramdisk>    ramdisk
  -append     <append>     kernel command line
  -name       <string>     set domain name
  -monitor    pty          monitor on pseudo tty
  -m          <memory>     vm memory in megabytes
  -smp        <cpus>       set number of vcpus
  -hd[abcd]   <file>       disk image
  -cdrom      <file>       cdrom image
  -drive      <config>     qemu style disk setup
  -net        <config>     qemu style network setup
  -serial     <config>     qemu style serial line (aka console) setup
  -vnc        <display>    vnc display (needs qemu-dm from xen-tools)
  -k          <kbd>        vnc clients keyboard map

options (xenner only):
  -domid      <id>         set domain id
  -uuid       <uuid>       set domain uuid
  -network    <mac>,<br>   xenner style network setup
  -debug      <nr>         set debug level
  -logfile    <file>       set logfile
  -bootloader <app>        set bootloader
  -cap-on     <name>       enable kvm features
  -cap-off    <name>       disable kvm features
  -nostderr                send messages to logfile only
  -dumpcore                don't catch fatal signals (sigsegv, sigbus)
  -libvirt-caps            print libvirt capability xml snippet

pick device model:
  -qemu-path  <file>       path to qemu binary
  -qemu-dm                 qemu is xensource qemu-dm
  -qemu-upstream           qemu is upstream+patches
              => http://kraxel.fedorapeople.org/patches/

Some more qemu-ish options are accepted but ignored,
so we don't error out when started by libvirt.

When started without kernel specified xenner tries to
get one using the bootloader (pygrub by default).

-- 
(c) 2007,08 Gerd Hoffmann <kraxel@redhat.com>



Expected results:


Additional info:
Comment 1 Gerry Reno 2009-12-16 12:57:47 EST
Created attachment 378805 [details]
original pygrub.cfg
Comment 2 Gerry Reno 2009-12-16 12:58:42 EST
Created attachment 378806 [details]
libvirt domain xml
Comment 3 Justin M. Forbes 2009-12-22 11:19:53 EST
*** Bug 548126 has been marked as a duplicate of this bug. ***
Comment 4 Gerd Hoffmann 2010-02-17 04:09:28 EST
fixed in xenner-0.48-1

Note You need to log in before you can comment on or make changes to this bug.