Bug 553115

Summary: Error getting repository data for installed, repository not found
Product: [Fedora] Fedora Reporter: Alejandro Quesada <quesadam>
Component: PackageKitAssignee: Richard Hughes <richard>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: beland, c.musselman, ffesti, james.antill, lunkwill, maxamillion, oldanstrange, pmatilai, rhughes, richard, smparrish, tla
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-08 21:23:58 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
screenshot none

Description Alejandro Quesada 2010-01-07 01:24:44 EST
Created attachment 382159 [details]
screenshot

Description of problem:
An internal system error has occurred

A problem that we were not expecting has occurred. 
Please report this bug in your distribution bugtracker with error description.

More details

Error Type: <class 'yum.Errors.RepoError'>
Error Value: Error getting repository data for installed, repository not found
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3125, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3122, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 710, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 657, in dispatch_command
    self.update_packages(only_trusted, package_ids)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1948, in update_packages
    signed = self._is_package_repo_signed(pkg)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1437, in _is_package_repo_signed
    repo = self.yumbase.repos.getRepo(pkg.repoid)
  File : /usr/lib/python2.6/site-packages/yum/repos.py, line 121, in getRepo
    'Error getting repository data for $s, repository not found' $ (repoid)
Version-Release number of selected component (if applicable):


How reproducible:
Probably isolated to my particular machine. Happens when I try to update the system.

Steps to Reproduce:
1. Run Software update
2. Resolves dependencies and finds a group of new packages to install
3. prompts for permission to install additional packages, OK, resumes installation and bug reappears
  
Actual results:
System update fails

Expected results:
System updated

Additional info:

System: Fedora Release 12 (Constantine) 
        Kernel Linux 2.6.31.5-127.fc12.i686
        GNOME 2.28.0
        Memory: 466.4 MiB
        Processor 0: Mobile Intel(R) Pentium (R) 4 CPU 2.80Ghz
        Processor 0: Mobile Intel(R) Pentium (R) 4 CPU 2.80Ghz
        Available disk space: 25.7 GiB
Comment 1 Charley Musselman 2010-01-08 02:22:19 EST
(In reply to comment #0)
> Created an attachment (id=382159) [details]
> screenshot
> 
> Description of problem:
> An internal system error has occurred
> 
> A problem that we were not expecting has occurred. 
> Please report this bug in your distribution bugtracker with error description.
> 
> More details
> 
> Error Type: <class 'yum.Errors.RepoError'>
> Error Value: Error getting repository data for installed, repository not found
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3125, in
> <module>
>     main()
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3122, in main
>     backend.dispatcher(sys.argv[1:])
>   File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 710, in
> dispatcher
>     self.dispatch_command(args[0], args[1:])
>   File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 657, in
> dispatch_command
>     self.update_packages(only_trusted, package_ids)
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1948, in
> update_packages
>     signed = self._is_package_repo_signed(pkg)
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1437, in
> _is_package_repo_signed
>     repo = self.yumbase.repos.getRepo(pkg.repoid)
>   File : /usr/lib/python2.6/site-packages/yum/repos.py, line 121, in getRepo
>     'Error getting repository data for $s, repository not found' $ (repoid)
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> Probably isolated to my particular machine. Happens when I try to update the
> system.
> 
> Steps to Reproduce:
> 1. Run Software update
> 2. Resolves dependencies and finds a group of new packages to install
> 3. prompts for permission to install additional packages, OK, resumes
> installation and bug reappears
> 
> Actual results:
> System update fails
> 
> Expected results:
> System updated
> 
> Additional info:
> 
> System: Fedora Release 12 (Constantine) 
>         Kernel Linux 2.6.31.5-127.fc12.i686
>         GNOME 2.28.0
>         Memory: 466.4 MiB
>         Processor 0: Mobile Intel(R) Pentium (R) 4 CPU 2.80Ghz
>         Processor 0: Mobile Intel(R) Pentium (R) 4 CPU 2.80Ghz
>         Available disk space: 25.7 GiB  

My experiance is identical. Software Update fails on:

"Error Value: Error getting repository data for installed, repository not found
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3125, in <module>
    main() ...
... etc. "

Mine is a PC Chips A13G+ motherboard with AMD 64 X2 processor and 2GB RAM.

c.musselman@rcn.com
Comment 2 Oldan Strange 2010-01-10 10:27:18 EST
Same error.  Anyone have a workaround.

Linux 2.6.31.6-166.fc12.i686.PAE i686
Fedora release 12 (Constantine)
4.3.3 (KDE 4.3.3)
PNY nForce 630i GeForce 7150 Socket 775 MOBO
Intel(R) Pentium(R) Dual CPU E2200 @ 2.20GHz  500 GB HDD  2.0 GB RAM

Error Type: 
Error Value: Error getting repository data for installed, repository not found
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3125, in 
main()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3122, in main
backend.dispatcher(sys.argv[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 699, in dispatcher
self.dispatch_command(args[0], args[1:])
File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 657, in dispatch_command
self.update_packages(only_trusted, package_ids)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1948, in update_packages
signed = self._is_package_repo_signed(pkg)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1437, in _is_package_repo_signed
repo = self.yumbase.repos.getRepo(pkg.repoid)
File : /usr/lib/python2.6/site-packages/yum/repos.py, line 121, in getRepo
'Error getting repository data for $s, repository not found' $ (repoid)
Comment 3 Richard Hughes 2010-01-11 07:37:11 EST
just do "yum update PackageKit" as root, and then reboot.
Comment 4 Christopher Beland 2010-03-08 21:23:58 EST

*** This bug has been marked as a duplicate of bug 541645 ***