Bug 541645 - System Update fails with PackageKit GUI ("Error getting repository data for installed, repository not found")
System Update fails with PackageKit GUI ("Error getting repository data for ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
12
i686 Linux
low Severity low
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: Reopened, Triaged
: 541811 542025 542158 542180 543322 aeromechengr 550199 553115 562974 565219 567015 567480 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-26 10:38 EST by Rich Mattes
Modified: 2015-01-27 02:20 EST (History)
40 users (show)

See Also:
Fixed In Version: 2.28.3-0.1.20091211git.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 05:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gpk-update-viewer --verbose 2>&1 | tee output (88.25 KB, text/plain)
2009-11-30 13:33 EST, Petr Mensik
no flags Details
'gpk-update-viewer --verbose' output (90.51 KB, text/plain)
2009-12-02 04:27 EST, Jerry O'Donovan
no flags Details
test patch (2.25 KB, patch)
2009-12-02 05:14 EST, Richard Hughes
no flags Details | Diff
patch for gvfs (1.19 KB, patch)
2010-03-03 18:44 EST, Colin Walters
no flags Details | Diff

  None (edit)
Description Rich Mattes 2009-11-26 10:38:12 EST
Description of problem:

Updating system using PackageKit's "Software Update" window fails


Version-Release number of selected component (if applicable):
$ rpm -qa |grep -i packagekit
PackageKit-glib-0.5.4-0.4.20091029git.fc12.i686
PackageKit-yum-plugin-0.5.4-0.4.20091029git.fc12.i686
PackageKit-yum-0.5.4-0.4.20091029git.fc12.i686
gnome-packagekit-2.28.2-0.2.20091116git.fc12.i686
PackageKit-browser-plugin-0.5.4-0.4.20091029git.fc12.i686
PackageKit-gtk-module-0.5.4-0.4.20091029git.fc12.i686
PackageKit-0.5.4-0.4.20091029git.fc12.i686
PackageKit-gstreamer-plugin-0.5.4-0.4.20091029git.fc12.i686
PackageKit-device-rebind-0.5.4-0.4.20091029git.fc12.i686
PackageKit-command-not-found-0.5.4-0.4.20091029git.fc12.i686



How reproducible:
When updates are available, click on the PackageKit tray icon

Steps to Reproduce:
1. Wait for updates to be available
2. Click on Updates tray icon
3. Select "Install Updates"
  
Actual results:
Fails with the following message in a dialogue box:

Error Type: <class 'yum.Errors.RepoError'>
Error Value: Error getting repository data for installed, repository not found
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3125, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3122, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 710, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 657, in dispatch_command
    self.update_packages(only_trusted, package_ids)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1948, in update_packages
    signed = self._is_package_repo_signed(pkg)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1437, in _is_package_repo_signed
    repo = self.yumbase.repos.getRepo(pkg.repoid)
  File : /usr/lib/python2.6/site-packages/yum/repos.py, line 121, in getRepo
    'Error getting repository data for $s, repository not found' $ (repoid)

Expected results:
System update completed successfully.

Additional info:
Just upgraded from F11 to F12 via Preupgrade.  I'm able to update the system using yum, but the pk gui does not work.
Comment 1 Richard Hughes 2009-11-26 10:46:08 EST
I've already fixed this in git master a few days ago, I'll prep a release and push it to updates in a little over a week now. Thanks.
Comment 2 Ville-Pekka Vainio 2009-11-28 06:56:10 EST
*** Bug 541811 has been marked as a duplicate of this bug. ***
Comment 3 Ville-Pekka Vainio 2009-11-28 06:59:42 EST
Richard: Does this bug affect all Fedora 12 users? If so, then those who don't use yum directly or the terminal in general (pkcon or similar tools), won't be getting any updates installed anymore.
Comment 4 James Antill 2009-11-28 10:35:48 EST
*** Bug 542025 has been marked as a duplicate of this bug. ***
Comment 5 James Antill 2009-11-29 18:27:04 EST
*** Bug 542180 has been marked as a duplicate of this bug. ***
Comment 6 Richard Hughes 2009-11-30 03:30:44 EST
(In reply to comment #3)
> Richard: Does this bug affect all Fedora 12 users? If so, then those who don't
> use yum directly or the terminal in general (pkcon or similar tools), won't be
> getting any updates installed anymore.  

No, it only appears to affect a few machines, which is why my testing didn't get the bug. I'm still trying to work out the get/not-get conditions for the bug.

If you can get the bug, the output of gpk-update-viewer --verbose would be very appreciated. Thanks.
Comment 7 Petr Mensik 2009-11-30 13:32:37 EST
I get this report on my fedora 12 system, upated from 12 beta. yum update start well, gui notification fails with message like above.
Comment 8 Petr Mensik 2009-11-30 13:33:42 EST
Created attachment 374841 [details]
gpk-update-viewer --verbose 2>&1 | tee output
Comment 9 drago01 2009-12-01 11:56:38 EST
*** Bug 542158 has been marked as a duplicate of this bug. ***
Comment 10 Jerry O'Donovan 2009-12-02 04:27:24 EST
Created attachment 375374 [details]
'gpk-update-viewer --verbose' output

Another run from a gpk-update-viewer --verbose attached in case it's useful. This machine was a successful upgrade from 11.
Comment 11 Tim Waugh 2009-12-02 04:50:09 EST
It's happening for me right now, and it's caused by the gvfs update.  I currently have:

gvfs-1.4.1-3.fc12.x86_64
gnome-mount-0.8-7.fc12.x86_64

The new gvfs package is available:

gvfs
1.4.2-1.fc12
x86_64
updates

which gives a txmbr of:

[<TransactionMember : gvfs.x86_64 0-1.4.2-1.fc12 - u (0x4353cb0)>, <TransactionMember : gnome-mount.x86_64 0-0.8-7.fc12 - None (0x4353e18)>, <TransactionMember : gvfs.x86_64 0-1.4.2-1.fc12 - u (0x4353ab8)>]

(the new package adds an obsoletes tag for gnome-mount)

The middle element of that list has .po.repoid=='installed'

So, perhaps the condition for seeing the bug is that an update is available with a new obsoletes tag for a package you also have installed?
Comment 12 Richard Hughes 2009-12-02 05:14:10 EST
Created attachment 375388 [details]
test patch

Thanks Tim, appreciated. Can someone please try the attached patch applied to /usr/share/PackageKit/helpers/yum/yumBackend.py and tell me if that fixes the problem. Thanks.
Comment 13 Tim Waugh 2009-12-02 05:57:32 EST
Yes, fixes it here.  Yay!

(Applied hunk #3 by hand due to context differences, i.e. the try...except around _is_package_repo_signed.)
Comment 14 Daniel Berrange 2009-12-02 07:20:44 EST
Confirmed, that patch resolved the problem for me too.
Comment 15 Richard Hughes 2009-12-02 07:28:29 EST
Thanks for the super-quick testing guys:

commit 5e2d1ffb9876589989b620f0cacacfaacf7c7301
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Dec 2 12:24:34 2009 +0000

    yum: Only check certain transaction elements, not all of them. Fixes rh#541645

They'll be an upstream release on 7th December which will include this fix, or I can push something out using updates if you think I need to. Advice welcome. Thanks.
Comment 16 Bill Gianopoulos 2009-12-02 08:25:38 EST
For those having this issue who are not comfortable applying the patch, but want to keep their system updated,  I have this issue and it seems to effect the GUI software update.  YOu can still keep your system patched bu doing this:

sudo yum update

In a terminal window.
Comment 17 James Antill 2009-12-02 08:27:34 EST
*** Bug 543322 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2009-12-07 11:30:26 EST
PackageKit-0.5.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/PackageKit-0.5.5-1.fc12
Comment 19 Fedora Update System 2009-12-09 23:30:28 EST
PackageKit-0.5.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13033
Comment 20 seth vidal 2009-12-10 11:31:05 EST
*** Bug 546316 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2009-12-18 08:30:34 EST
gnome-packagekit-2.28.3-0.1.20091211git.fc12,kpackagekit-0.5.2-1.fc12,PackageKit-0.5.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnome-packagekit-2.28.3-0.1.20091211git.fc12,kpackagekit-0.5.2-1.fc12,PackageKit-0.5.5-1.fc12
Comment 22 Fedora Update System 2009-12-21 23:40:44 EST
gnome-packagekit-2.28.3-0.1.20091211git.fc12, kpackagekit-0.5.2-1.fc12, PackageKit-0.5.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-packagekit kpackagekit PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13421
Comment 23 Tony 2009-12-27 06:31:52 EST
thanks, had the same problem, uncheck update of gvfs did not work,
installed new packagekit from test first
su -c 'yum --enablerepo=updates-testing update gnome-packagekit kpackagekit PackageKit'
and then update all worked fine

tony nys
Comment 24 Rex Dieter 2009-12-27 12:38:06 EST
*** Bug 550199 has been marked as a duplicate of this bug. ***
Comment 25 Fedora Update System 2009-12-27 15:28:06 EST
gnome-packagekit-2.28.3-0.1.20091211git.fc12, kpackagekit-0.5.2-1.fc12, PackageKit-0.5.5-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 seth vidal 2010-02-08 17:02:09 EST
*** Bug 562974 has been marked as a duplicate of this bug. ***
Comment 27 Fulop Istvan 2010-02-25 14:19:08 EST
Hello,
I've installed Fedora Core 12 Live on my desktop and when I try to update it I got the following error in Software Update :

Error Type: <class 'yum.Errors.RepoError'>
Error Value: Error getting repository data for installed, repository not found
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3125, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3122, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 710, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 657, in dispatch_command
    self.update_packages(only_trusted, package_ids)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1948, in update_packages
    signed = self._is_package_repo_signed(pkg)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1437, in _is_package_repo_signed
    repo = self.yumbase.repos.getRepo(pkg.repoid)
  File : /usr/lib/python2.6/site-packages/yum/repos.py, line 121, in getRepo
    'Error getting repository data for $s, repository not found' $ (repoid)


I tried the patch and upgrade but without luck. 
Also I removed and reinstalled gnome-packagekit but no difference.

Any suggestions ?
Comment 28 Adel Gadllah 2010-02-25 14:25:27 EST
(In reply to comment #27)
> Hello,
> I've installed Fedora Core 12 Live on my desktop and when I try to update it I
> got the following error in Software Update :
> 
> Error Type: <class 'yum.Errors.RepoError'>
> Error Value: Error getting repository data for installed, repository not found
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3125, in
> <module>
>     main()
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3122, in main
>     backend.dispatcher(sys.argv[1:])
>   File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 710, in
> dispatcher
>     self.dispatch_command(args[0], args[1:])
>   File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 657, in
> dispatch_command
>     self.update_packages(only_trusted, package_ids)
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1948, in
> update_packages
>     signed = self._is_package_repo_signed(pkg)
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1437, in
> _is_package_repo_signed
>     repo = self.yumbase.repos.getRepo(pkg.repoid)
>   File : /usr/lib/python2.6/site-packages/yum/repos.py, line 121, in getRepo
>     'Error getting repository data for $s, repository not found' $ (repoid)
> 
> 
> I tried the patch and upgrade but without luck. 
> Also I removed and reinstalled gnome-packagekit but no difference.
> 
> Any suggestions ?    

Open a terminal and type:

su
yum update
Comment 29 Colin Walters 2010-03-02 10:07:29 EST
So if I understand this issue correctly, a fresh F12 install still won't be able to update, because it won't be able to download the new yum and PackageKit?  

What if we reverted the gvfs update for a period of time?
Comment 30 the man behind tent405 2010-03-02 15:29:33 EST
>>28
Yes, 
[code]su -;yum update [/code]
Is the [i]workaround[/i] to this problem, but not the solution.
I don't think this bug should be considered closed.
 
A 3000+ lines python script has to have bugs in it somewhere. This yumbackend obviously does. And this thread should be about fixing it.

Unfortunately, I won't help. I just got here, and so far, Fedora isn't very convincing. A fresh install shouldn't error on its first update.
Comment 31 Bill Gianopoulos 2010-03-02 21:01:26 EST
We\\(In reply to comment #29)
> So if I understand this issue correctly, a fresh F12 install still won't be
> able to update, because it won't be able to download the new yum and
> PackageKit?  

This is not necessarily true.  I have Fedora 12 installed on 3 different computers, and only ran into this issue on one of them.

If you do run into the issue, it only impacts installing updates using the gnome gui.  If you do run into this situation, it is impossible to install the fix using the gui as it is now impossible to patch anything using the gui interface.

So, it is necessary to run yum update from a terminal window once by doing:

sudo yum update

This will install the update patch fro this bug as well as any other pending uninstalled updates and from that point forward the System Updates gui will once again be functional.
Comment 32 Colin Walters 2010-03-03 09:07:20 EST
I am reopening this issue to investigate the possibility of reverting any changes that break a desktop live install (namely gvfs, but will see if there are others).
Comment 33 Colin Walters 2010-03-03 10:10:06 EST
Ok so this issue will only affect systems which are updated from Fedora 11 desktop (i.e. have gnome-mount installed).  New F12 installs won't have it.

I believe the only affected (and supported) chain of events is F11 desktop -> preupgrade-> F12.  However because preupgrade actually uses F-12 updates, anyone using preupgrade today will get the newer PK and not be affected by this bug.

However, this still leaves us with a set of users who used preupgrade in the timeframe between the gvfs update and the PK fix who will not be receiving updates.

I suggest we still evaluate the possibility of a gvfs update workaround for these users.
Comment 34 Colin Walters 2010-03-03 10:44:20 EST
I'm testing a F11 VM, preupgrade, and a patch to gvfs.spec myself now.
Comment 35 Colin Walters 2010-03-03 18:43:11 EST
Ok, I'm having trouble reproducing this.  I installed F11 and preupgraded to F12, then tried to downgrade PackageKit and gvfs, but packagekit still successfully updates!  Grr.

Anyways, will attach my proposed patch for gvfs.
Comment 36 Colin Walters 2010-03-03 18:44:06 EST
Created attachment 397685 [details]
patch for gvfs
Comment 37 Henry Bellamy 2010-03-08 18:54:05 EST
I had this problem with 2 new F12 installations, both onto 32 bit Dell boxes.  The problem is not limited to upgrades.   In both cases running "yum update" from a terminal window fixed things so that the gui could be used for later updates.
I'm surprised that something this fundamental was not caught in the testing of F12.
Comment 38 Christopher Beland 2010-03-08 21:23:25 EST
*** Bug 567480 has been marked as a duplicate of this bug. ***
Comment 39 Christopher Beland 2010-03-08 21:23:58 EST
*** Bug 553115 has been marked as a duplicate of this bug. ***
Comment 40 Christopher Beland 2010-03-08 21:31:46 EST
*** Bug 567015 has been marked as a duplicate of this bug. ***
Comment 41 Christopher Beland 2010-03-09 15:53:45 EST
*** Bug 565219 has been marked as a duplicate of this bug. ***
Comment 42 Ken Gibbs 2010-03-09 18:44:48 EST
For me the bug fix that was sent down to me worked perfectly. I had to
become root then run a command in the terminal. It worked !

Subsequently I used Fedora 12 for several days and then suddenly the XFCE spin I was using very successfully reverted to KDE and that was the end of it. In this new state all downloads wouldn't function and so I have stopped using it.

I will report this as a separate bug.

Thanks - Ken

PS - Thanks also to Richard Hughes for his assistance offline from 
this bug-forum.

*  *  *
Comment 43 iggynelix 2010-03-11 19:25:34 EST
Just got the original error at top from a Live CD downloaded today 20010-Mar-11 from fedoraproject.org choosing to update from earlier version (F10).
The Yum update appears to be running now. 
However, be aware that a default install does not put newly created users into su doers file; thus "sudo <foo>" will give an err "not in sudoers file". One must /bin/su and know the root password.
Comment 44 Christopher Beland 2010-03-12 11:04:48 EST
That sudoers request has been previously filed as Bug 462161.
Comment 45 Dennis 2010-03-14 18:27:24 EDT
I encountered this error as well.

This update error happened on a fresh Fedora 12 installation.
( Also, I had to fight anaconda bug #473482 for several days too )

This issue seems to have been added to the "Common Fedora 12 Bugs" website:
http://fedoraproject.org/wiki/Common_F12_bugs
Comment 46 Anthony Penniston 2010-04-17 00:07:35 EDT
Also received this error, worked around by launching "sudo yum update" from a terminal.
Comment 47 Bob Clayton 2010-05-16 22:29:24 EDT
I had the same problem. I just did the update for the newer version and updater worked fine now. Cant thank you enough. It was driving me nuts.

-------------------------

[bob@sasha ~]$ su -c 'yum --enablerepo=updates-testing update PackageKit'
Password: 
Loaded plugins: presto, refresh-packagekit
updates-testing/metalink                                 |  10 kB     00:00     
updates-testing                                          | 4.5 kB     00:00     
updates-testing/primary_db                               | 855 kB     00:02     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: PackageKit = 0.5.4-0.1.20091029git.fc12 for package: PackageKit-yum-0.5.4-0.1.20091029git.fc12.i686
--> Processing Dependency: PackageKit = 0.5.4-0.1.20091029git.fc12 for package: PackageKit-glib-0.5.4-0.1.20091029git.fc12.i686
---> Package PackageKit.i686 0:0.5.7-2.fc12 set to be updated
--> Processing Dependency: PackageKit-gtk-module = 0.5.7-2.fc12 for package: PackageKit-0.5.7-2.fc12.i686
--> Processing Dependency: PackageKit-yum-plugin = 0.5.7-2.fc12 for package: PackageKit-0.5.7-2.fc12.i686
--> Running transaction check
--> Processing Dependency: PackageKit-glib = 0.5.4-0.1.20091029git.fc12 for package: PackageKit-gstreamer-plugin-0.5.4-0.1.20091029git.fc12.i686
--> Processing Dependency: PackageKit-glib = 0.5.4-0.1.20091029git.fc12 for package: PackageKit-device-rebind-0.5.4-0.1.20091029git.fc12.i686
---> Package PackageKit-glib.i686 0:0.5.7-2.fc12 set to be updated
---> Package PackageKit-gtk-module.i686 0:0.5.7-2.fc12 set to be updated
---> Package PackageKit-yum.i686 0:0.5.7-2.fc12 set to be updated
---> Package PackageKit-yum-plugin.i686 0:0.5.7-2.fc12 set to be updated
--> Running transaction check
---> Package PackageKit-device-rebind.i686 0:0.5.7-2.fc12 set to be updated
---> Package PackageKit-gstreamer-plugin.i686 0:0.5.7-2.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                         Arch     Version             Repository   Size
================================================================================
Updating:
 PackageKit                      i686     0.5.7-2.fc12        updates     518 k
Updating for dependencies:
 PackageKit-device-rebind        i686     0.5.7-2.fc12        updates      91 k
 PackageKit-glib                 i686     0.5.7-2.fc12        updates     211 k
 PackageKit-gstreamer-plugin     i686     0.5.7-2.fc12        updates      91 k
 PackageKit-gtk-module           i686     0.5.7-2.fc12        updates      90 k
 PackageKit-yum                  i686     0.5.7-2.fc12        updates     150 k
 PackageKit-yum-plugin           i686     0.5.7-2.fc12        updates      88 k

Transaction Summary
================================================================================
Install       0 Package(s)
Upgrade       7 Package(s)

Total download size: 1.2 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 1.2 M
(1/7): PackageKit-0.5.7-2.fc12.i686.rpm                  | 518 kB     00:00     
(2/7): PackageKit-device-rebind-0.5.7-2.fc12.i686.rpm    |  91 kB     00:00     
(3/7): PackageKit-glib-0.5.7-2.fc12.i686.rpm             | 211 kB     00:00     
(4/7): PackageKit-gstreamer-plugin-0.5.7-2.fc12.i686.rpm |  91 kB     00:00     
(5/7): PackageKit-gtk-module-0.5.7-2.fc12.i686.rpm       |  90 kB     00:00     
(6/7): PackageKit-yum-0.5.7-2.fc12.i686.rpm              | 150 kB     00:00     
(7/7): PackageKit-yum-plugin-0.5.7-2.fc12.i686.rpm       |  88 kB     00:00     
--------------------------------------------------------------------------------
Total                                           142 kB/s | 1.2 MB     00:08     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : PackageKit-glib-0.5.7-2.fc12.i686                       1/14 
  Updating       : PackageKit-gtk-module-0.5.7-2.fc12.i686                 2/14 
  Updating       : PackageKit-device-rebind-0.5.7-2.fc12.i686              3/14 
  Updating       : PackageKit-gstreamer-plugin-0.5.7-2.fc12.i686           4/14 
  Updating       : PackageKit-yum-plugin-0.5.7-2.fc12.i686                 5/14 
  Updating       : PackageKit-0.5.7-2.fc12.i686                            6/14 
  Updating       : PackageKit-yum-0.5.7-2.fc12.i686                        7/14 
  Cleanup        : PackageKit-glib-0.5.4-0.1.20091029git.fc12.i686         8/14 
  Cleanup        : PackageKit-yum-plugin-0.5.4-0.1.20091029git.fc12.i68    9/14 
  Cleanup        : PackageKit-device-rebind-0.5.4-0.1.20091029git.fc12.   10/14 
  Cleanup        : PackageKit-gtk-module-0.5.4-0.1.20091029git.fc12.i68   11/14 
  Cleanup        : PackageKit-0.5.4-0.1.20091029git.fc12.i686             12/14 
  Cleanup        : PackageKit-yum-0.5.4-0.1.20091029git.fc12.i686         13/14 
  Cleanup        : PackageKit-gstreamer-plugin-0.5.4-0.1.20091029git.fc   14/14 

Updated:
  PackageKit.i686 0:0.5.7-2.fc12                                                

Dependency Updated:
  PackageKit-device-rebind.i686 0:0.5.7-2.fc12                                  
  PackageKit-glib.i686 0:0.5.7-2.fc12                                           
  PackageKit-gstreamer-plugin.i686 0:0.5.7-2.fc12                               
  PackageKit-gtk-module.i686 0:0.5.7-2.fc12                                     
  PackageKit-yum.i686 0:0.5.7-2.fc12                                            
  PackageKit-yum-plugin.i686 0:0.5.7-2.fc12                                     

Complete!
Comment 48 Leonard Evens 2010-06-16 23:18:19 EDT
I just upgraded (by instllation) to Fedora 12 from Fedora 11.

I encountered this bug when I tried to update using the GUI interface.  I did manage to update using yum update at the command line, and PackageKit was updated to version 0.5.7-2.fc12.i686

I haven't had a chance to test this since I don't yet need additional updates.

But something else happens that may be related.

When I do System>Add/Remove Software>Package Collections, I get the error message

"No groups could be found. A cache refresh should fix this."

I haven't been able to figure out how to refresh the cache.  I tried
rpm --rebuild, which ran without comment, but the problem persisites.

But I also found that the directory structure of /var/cache/yum differs significantly between Fedora 11 and Fedora 12.   Under the latter there are a bunch of directories including fedora and updates.  But under Fedora 12, there is a subdirectory  i386, which in turn has a subdirectory 12, and this then has the directoreis Fedora, updates, etc.

Can someone enlighten me about what is going on?  And does it havi e anything to do with the above problem?
Comment 49 Richard Hughes 2010-07-08 05:14:33 EDT
(In reply to comment #48)
> ...does it havi e anything to do with the above problem?    

No, sorry.

Note You need to log in before you can comment on or make changes to this bug.