Bug 553440

Summary: pdftops man page lists wrong location for xpdfrc config file
Product: Red Hat Enterprise Linux 5 Reporter: Lee Revell <rlrevell>
Component: man-pages-overridesAssignee: Peter Schiffer <pschiffe>
Status: CLOSED ERRATA QA Contact: Iveta Wiedermann <isenfeld>
Severity: medium Docs Contact:
Priority: low    
Version: 5.4CC: isenfeld, mclasen, ovasik, pschiffe
Target Milestone: rcKeywords: ManPageChange, Patch
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Various manual pages from poppler package contained incorrect path to the configuration file and references to the non-existent manual pages. Consequence: Incorrect documentation. Fix: Fixed invalid path to the configuration file and removed invalid references in the poppler manual pages. Result: Correct documentation.
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-09-30 20:38:07 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 965689    

Description Lee Revell 2010-01-07 16:33:08 EST
Description of problem:

The pdftops man page says:

CONFIGURATION FILE
Pdftops reads a configuration file at startup.  It first tries to find the user’s private config file, ~/.xpdfrc.  If that doesn’t exist, it looks for a system-wide  config  file, /etc/xpdf/xpdfrc.  See the xpdfrc(5) man page for details.

BUT, pdftops looks for the file at /etc/xpdfrc:

open("/root/.xpdfrc", O_RDONLY)         = -1 ENOENT (No such file or directory)
open("/etc/xpdfrc", O_RDONLY)           = 3

Version-Release number of selected component (if applicable):

0.5.4-4.el5

How reproducible:

100%

Steps to Reproduce:
1. man pdftops
2. create config file at the location listed
3. test, it will be ignored
  
Actual results:

Man page lists incorrect config file location

Expected results:

Man page lists incorrect config file location


Additional info:
Comment 4 RHEL Product and Program Management 2010-08-09 15:09:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2013-05-21 11:22:35 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 15 errata-xmlrpc 2013-09-30 20:38:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1357.html