Bug 556284

Summary: PPPoE in NetworkManager doesn't work when connected via wifi wireless connection
Product: [Fedora] Fedora Reporter: Valent Turkovic <valent.turkovic>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: dcbw
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-03 18:23:54 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Valent Turkovic 2010-01-17 11:46:51 EST
Description of problem:
Hi there,

the network at my university requires me to first connect to the WLAN
and then use PPPoE to actually use the intertubes. Connecting to the
WLAN itself works flawlessly (*hem*), the PPPoE though is a bit
troublesome.

I first tried setting this up via the DSL tab in Gnome's NetworkManager,
but that didn't work. The connection is listed (not very surprisingly)
under the wired networks, not under the wireless ones. I tried to be
sneaky and entered my wlan-adapter's MAC address in the "wired" tab,
but that only made the entry disappear from the network listing
entirely (in the menu that you see when you left-click the
notification icon).

I did manage to set up the connection by running pppoe-setup as root.
And although I did configure it to start at system boot, this doesn't
happen. So now I have to run ifup as root every time I want to connect
to the internet. To make things more annoying the WLAN connection
disconnects somewhat frequently (lousy administration), prompting me do
do ifdown and ifup each time that happens.

Any way to have this PPPoE connection up automatically, preferably via
NetworkManager? Any help is much appreciated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dan Williams 2010-02-03 18:23:54 EST
This enhancement is definitely planned.

*** This bug has been marked as a duplicate of bug 446338 ***