Bug 556284 - PPPoE in NetworkManager doesn't work when connected via wifi wireless connection
Summary: PPPoE in NetworkManager doesn't work when connected via wifi wireless connection
Status: CLOSED DUPLICATE of bug 446338
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-17 16:46 UTC by Valent Turkovic
Modified: 2010-02-03 23:23 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-02-03 23:23:54 UTC


Attachments (Terms of Use)

Description Valent Turkovic 2010-01-17 16:46:51 UTC
Description of problem:
Hi there,

the network at my university requires me to first connect to the WLAN
and then use PPPoE to actually use the intertubes. Connecting to the
WLAN itself works flawlessly (*hem*), the PPPoE though is a bit
troublesome.

I first tried setting this up via the DSL tab in Gnome's NetworkManager,
but that didn't work. The connection is listed (not very surprisingly)
under the wired networks, not under the wireless ones. I tried to be
sneaky and entered my wlan-adapter's MAC address in the "wired" tab,
but that only made the entry disappear from the network listing
entirely (in the menu that you see when you left-click the
notification icon).

I did manage to set up the connection by running pppoe-setup as root.
And although I did configure it to start at system boot, this doesn't
happen. So now I have to run ifup as root every time I want to connect
to the internet. To make things more annoying the WLAN connection
disconnects somewhat frequently (lousy administration), prompting me do
do ifdown and ifup each time that happens.

Any way to have this PPPoE connection up automatically, preferably via
NetworkManager? Any help is much appreciated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dan Williams 2010-02-03 23:23:54 UTC
This enhancement is definitely planned.

*** This bug has been marked as a duplicate of bug 446338 ***


Note You need to log in before you can comment on or make changes to this bug.