Bug 5579

Summary: XFree86-SunMono appears broken on Sparc elc (bwtwo).
Product: [Retired] Red Hat Linux Reporter: edward.younger
Component: XFree86Assignee: Preston Brown <pbrown>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: sparc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-29 19:21:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description edward.younger 1999-10-05 13:44:58 UTC
Configuration: SparcStation elc, 16mb ram, 64mb swap.
RH 6.0 plus all updates (XFree86-SunMono-3.3.5-1.6.0);
Kernel 2.2.5 or 2.2.10 give the same result.

startx, xinit or simply /usr/X11R6/bin/X results in screen
simply turning black - no cursor or any other output. ps
shows all the expected X processes running (X server, gnome
and friends, etc). I can switch consoles with
ctrl-alt-F[1-6], however switching back to the X console
with ctrl-F7 leaves the old text on the screen (the text
cursor disappears). ctrl-alt-backspace exits with the usual
"waiting for X-server to shut down" messages.

I've tried this with the default xinit setup and also with a
minimal $HOME/.xinitrc containing just an xterm, with the
same results. gpm is turned off.

Xconfigurator exits with messages to the effect that there
is an error in my X configuration - this also happened at
install time. Sbus bwtwo frame-buffer is recognised at boot
time.

Comment 1 Preston Brown 2000-02-29 19:21:59 UTC
elc's with bwtwo framebuffers are fully supported in our forthcoming 6.2
release.