Bug 558281

Summary: F13: KSM init script error [/sys/kernel/mm/ksm/max_kernel_pages: No such file or directory]
Product: [Fedora] Fedora Reporter: Gianluca Varisco <gvarisco>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: alexander.hunt2005, amit.shah, berrange, carl.gaudreault, charles.butterfield, chkr, dan, dwmw2, ehabkost, gcosta, itamar, james, jaswinder, jforbes, markmc, mick, nobody, quintela, rc040203, robatino, robert, rob+redhat, rs, virt-maint, xoxxyy
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: qemu-0.13.0-1.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 561907 (view as bug list) Environment:
Last Closed: 2011-03-19 06:28:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 514891, 561907    
Attachments:
Description Flags
This is patch for suppress error message none

Description Gianluca Varisco 2010-01-24 12:14:04 EST
Description of problem:

Starting ksm: /etc/rc5.d/S84ksm: line 44: /sys/kernel/mm/ksm/max_kernel_pages: No such file or directory
                                                           [  OK  ]

Version-Release number of selected component (if applicable):

qemu-common-0.12.1.2-3.fc13.x86_64
kernel-2.6.33-0.20.rc5.git0.fc13.x86_64

How reproducible:

The message is displayed when the system boots up [ /var/log/boot.log ].

# ls /sys/kernel/mm/ksm/
full_scans  pages_shared  pages_sharing  pages_to_scan  pages_unshared  pages_volatile  run  sleep_millisecs
Comment 1 Justin M. Forbes 2010-02-04 11:39:58 EST
Now that the pages are swappable in 2.6.33 kernels, max_kernel_pages is no longer necessary. The ksm init script has been modified to only change /sys/kernel/mm/ksm/max_kernel_pages if it already exists.  This should work with both F12 and future rawhide kernels.
Comment 2 Ralf Corsepius 2010-08-25 06:28:03 EDT
Bug is still present in FC13.

From my /var/log/boot.log:
...
Starting ksm: /etc/rc5.d/S84ksm: line 44: /sys/kernel/mm/ksm/max_kernel_pages: No such file or directory
...

> The ksm init script has been modified to only change
> /sys/kernel/mm/ksm/max_kernel_pages if it already exists. 

This apparently has not happened:
- From /etc/init.d/ksm on FC13:
...
start() {
    echo -n $"Starting $prog: "
    KSM_MAX_KERNEL_PAGES=${KSM_MAX_KERNEL_PAGES:-`default_max_kernel_pages`}
    echo $KSM_MAX_KERNEL_PAGES > /sys/kernel/mm/ksm/max_kernel_pages
    echo 1 > /sys/kernel/mm/ksm/run
    RETVAL=$?
    [ $RETVAL = 0 ] && success $"$prog startup" || failure $"$prog startup"
    echo
}
...

- Same in Fedora's git. Even master (f15) still carries the broken init script
Comment 3 Robert Story 2010-08-25 16:28:17 EDT
yep, I'm seeing it on my f13 box too...
Comment 4 Mick Smothers 2010-08-29 03:19:44 EDT
I just updated from f12 to f13 (x86_64) and also see the message.
Comment 5 Charles Butterfield 2010-08-30 01:35:32 EDT
Me too, F13, package qemu-common.x86_64 version 2:0.12.5-1.fc13
Comment 6 Justin M. Forbes 2010-09-02 12:24:04 EDT
I apologize for that, it seems the update got applied to F-12 and did not get applied upstream.  This change has now been committed upstream, and will be present in the next qemu builds for all releases.
Comment 7 Justin M. Forbes 2010-09-02 12:40:03 EDT
*** Bug 627425 has been marked as a duplicate of this bug. ***
Comment 8 Hajime Taira 2010-09-10 00:34:13 EDT
Created attachment 446426 [details]
This is patch for suppress error message
Comment 9 Fedora Update System 2010-09-21 18:22:42 EDT
spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.7.rc1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.7.rc1.fc14
Comment 10 Fedora Update System 2010-09-22 14:42:42 EDT
spice-0.6.0-1.fc14, spice-protocol-0.6.0-1.fc14, qemu-0.13.0-0.7.rc1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spice spice-protocol qemu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/spice-0.6.0-1.fc14,spice-protocol-0.6.0-1.fc14,qemu-0.13.0-0.7.rc1.fc14
Comment 11 Fedora Update System 2010-09-30 02:10:22 EDT
spice-0.6.0-1.fc14, spice-protocol-0.6.0-1.fc14, qemu-0.13.0-0.7.rc1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Julian Sikorski 2010-09-30 02:16:45 EDT
Can we get an update for F-13 too, please?
Comment 13 Rob Riggs 2010-10-01 20:22:08 EDT
Please reopen.  This bug still exists in Fedora 13.
Comment 14 Carl G. 2010-10-02 11:39:37 EDT
---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Alexander Hunt 2010-10-09 04:33:31 EDT
Hi, What Rob Riggs said. 
Info:
I Installed some fuse (filesystem in userspace) options yesterday which installed qemu-common-2:0.12.5.1.fc13.x86_64 as a dependency. My machine is now having this issue also (although other than the message being in the boot log, it doesn't seem to be causing any problems for me so far). I don't have any spice or spice-protocol files installed.

Fedora 2.6.34.7-56.fc13.x86_64
Gnome 2.30.0
MacBook 2.1

br,
alex
Comment 16 Fedora Update System 2011-03-03 18:37:13 EST
Package qemu-0.13.0-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-0.13.0-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/qemu-0.13.0-1.fc13
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2011-03-04 04:59:10 EST
qemu-0.13.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qemu-0.13.0-1.fc13
Comment 18 Fedora Update System 2011-03-19 06:27:58 EDT
qemu-0.13.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.