Bug 562952

Summary: PDF fill-in form checkboxes are not checkable in evince
Product: [Fedora] Fedora Reporter: Joel Uckelman <uckelman>
Component: fontconfigAssignee: Akira TAGOH <tagoh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 15CC: behdad, cbm, fonts-bugs, leifer, mishu, mkasik
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 566758 (view as bug list) Environment:
Last Closed: 2012-04-05 10:14:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 566758    

Description Joel Uckelman 2010-02-08 20:10:36 UTC
Description of problem:

It is not possible to toggle the state of checkboxes in PDF forms.

Version-Release number of selected component (if applicable):

evince-2.28.2-1.fc12.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Open a form with a checkbox.
2. Click on the checkbox.
  
Actual results:

Nothing happens.

Expected results:

The box should change state.

Additional info:

I observed this problem specifically with US Federal Tax forms. For example, try the 2009 Form 1040: http://www.irs.gov/pub/irs-pdf/f1040.pdf?portlet=3

Comment 1 Marek Kašík 2010-02-16 15:31:12 UTC
Hi,

this is an issue with fontconfig. The PDF uses "ZapfDingbats" font, but there is "Zapf Dingbats" font only.
This can be bypassed by setting of ~/.fonts.conf (or /etc/font/local.conf) according to http://bugs.freedesktop.org/show_bug.cgi?id=21395#c6.

=> reassigning to fontconfig

Regards

Marek


(for more info see http://freedesktop.org/wiki/Software/poppler)
(it seems that this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=497648)

Comment 2 Colin Macdonald 2010-03-20 15:28:36 UTC
I just filed bug #575406.  I don't think its a dupe b/c my file doesn't use ZapfDingbats, but its probably related.

Comment 3 Colin Macdonald 2010-03-20 15:50:50 UTC
*** Bug 575406 has been marked as a duplicate of this bug. ***

Comment 4 Joel Uckelman 2010-09-02 09:43:24 UTC
This still happens with evince-2.30.3-1.fc13.x86_64.

Comment 5 Joel Uckelman 2011-04-11 09:46:06 UTC
This still happens with evince-2.32.0-3.fc14.x86_64.

Comment 6 Joel Uckelman 2011-05-31 17:33:43 UTC
This still happens with evince-3.0.0-1.fc15.x86_64 in Fedora 15.

Comment 7 Fedora Admin XMLRPC Client 2012-01-10 15:42:11 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 8 Fedora Admin XMLRPC Client 2012-03-22 01:38:20 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 9 Joel Uckelman 2012-03-26 19:32:01 UTC
This appears to be fixed in evince-3.2.1-2.fc16.x86_64 in Fedora 16.

Comment 10 Akira TAGOH 2012-04-05 10:14:08 UTC

*** This bug has been marked as a duplicate of bug 468565 ***