Bug 575406 - PDF fill-in form checkboxes are not checkable in evince (not zapf dingbats problem)
Summary: PDF fill-in form checkboxes are not checkable in evince (not zapf dingbats pr...
Keywords:
Status: CLOSED DUPLICATE of bug 562952
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-20 15:26 UTC by Colin Macdonald
Modified: 2010-03-20 15:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-20 15:50:50 UTC
Type: ---


Attachments (Terms of Use)
form-CIT0001E.pdf (318.67 KB, application/binary)
2010-03-20 15:26 UTC, Colin Macdonald
no flags Details

Description Colin Macdonald 2010-03-20 15:26:32 UTC
Created attachment 401453 [details]
form-CIT0001E.pdf

Description of problem:

It is not possible to toggle the state of checkboxes in PDF forms.  Think its not a dupe of Bug #562952, but my file doesn't have ZapfDingBats font.  See below...
	
Version-Release number of selected component (if applicable):

evince 2.28.2-1.fc12
poppler 0.12.4-2.fc12

How reproducible:

Will attach a fillable form.

Additional info:
At first I thought this was a dupe of #562952.  But here's the pdffont output for the file, note no dingbats and wingdings is embedded!:

$ pdffonts  Downloads/form-CIT0001E.pdf 
name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
Helvetica-Bold                       Type 1            no  no  no    1233  0
Helvetica                            Type 1            no  no  no    1232  0
AFNFDA+Wingdings                     CID TrueType      yes yes no    1231  0
Times-Roman                          Type 1            no  no  no    1240  0
Helvetica                            Type 1            no  no  no    1170  0
Helvetica-Bold                       Type 1            no  no  no    1229  0
Helvetica                            Type 1            no  no  no      23  0
Helvetica-Bold                       Type 1            no  no  no     134  0
Helvetica                            Type 1            no  no  no     580  0
Helvetica-Bold                       Type 1            no  no  no     739  0
Helvetica                            Type 1            no  no  no     877  0
Helvetica-Bold                       Type 1            no  no  no     836  0
Helvetica-Bold                       Type 1            no  no  no     954  0
Helvetica                            Type 1            no  no  no     934  0
Helvetica-BoldOblique                Type 1            no  no  no     933  0
Helvetica-Oblique                    Type 1            no  no  no     901  0

Comment 1 Colin Macdonald 2010-03-20 15:50:50 UTC
Ooops, just tried the ZapfDingbats ~/.font.conf workaround and it seems it fixes this problem too (maybe wingdings is just an alias to zapfdingbats).

So I guess its a dupe of Bug #562952 afterall.

Why isn't the workaround in fedora?

*** This bug has been marked as a duplicate of bug 562952 ***


Note You need to log in before you can comment on or make changes to this bug.