Bug 564490

Summary: Luci will randomly timeout communicating with ricci clients
Product: Red Hat Enterprise Linux 5 Reporter: Shane Bradley <sbradley>
Component: congaAssignee: Chris Feist <cfeist>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 5.4CC: adrew, amark, bbrock, bturner, cfeist, cluster-maint, jpokorny, jruemker, jwest, plyons, pmdyermms, tao
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: All   
OS: Linux   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=732483
https://bugzilla.redhat.com/show_bug.cgi?id=736795
https://bugzilla.redhat.com/show_bug.cgi?id=736814
https://bugzilla.redhat.com/show_bug.cgi?id=736818
Whiteboard:
Fixed In Version: conga-0.12.2-14.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 580575 (view as bug list) Environment:
Last Closed: 2011-01-13 17:27:31 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 578952, 578954    
Attachments:
Description Flags
Patch to fix bz none

Description Shane Bradley 2010-02-12 16:14:42 EST
Description of problem:

The luci interface will throw timeout errors at random times when
talking with ricci clients. From what we can tell these errors only
started occurring with RHEL 5.4+ release.

The errors are thrown in popup box and "messages" log if debuggin is
enabled. This is the most common error we are seeing and is the most
generic error:
"Feb 10 16:07:17 rh5node1 luci[31064]: Error reading from cs-rh5-1.gsslab.rdu.redhat.com:11111: timeout"

There has also been reports of getting the error, but not as common as
the above. These two errors may or may not be related:
"Error reading from cs-rh5-1.gsslab.rdu.redhat.com:11111: SSL error: SSL_ERROR_ZERO_RETURN

Version-Release number of selected component (if applicable):
luci-0.12.2-6.el5_4.1
ricci-0.12.2-6.el5_4.1

How reproducible:
Randomly occurs and do not have reproducer steps.

Steps to Reproduce:
1. Setup Luci/Ricci as you normally would
2. Then login and manage a cluster
3. Randomly click on links till error occurs
  
Actual results:
A random timeout error will occur.

Expected results:
Timeout error should not occur.

Additional info:
Comment 1 Ben Turner 2010-02-15 09:47:27 EST
*** Bug 563923 has been marked as a duplicate of this bug. ***
Comment 2 John Ruemker 2010-02-19 10:38:50 EST
I can confirm these are happening a *lot*, and I only started seeing them in 5.4.  

-John
Comment 25 Chris Feist 2010-04-01 17:17:32 EDT
Created attachment 404098 [details]
Patch to fix bz
Comment 31 Chris Feist 2010-05-20 15:18:33 EDT
This bug is on target to be include for 5.6, if you're looking for the 5.5.z-stream version of this bug, it's 578954.  However, the status is still the same, QE has the package and when it has passed their tests it will be pushed out.

Thanks!
Chris
Comment 38 errata-xmlrpc 2011-01-13 17:27:31 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0033.html