Bug 564630

Summary: FTBFS gnujump-1.0.6-3.fc12: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: gnujumpAssignee: Vivek Shah <boni.vivek>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 13CC: boni.vivek, bruno, jan.klepek
Target Milestone: ---Keywords: Triaged
Target Release: ---Flags: boni.vivek: needinfo+
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: gnujump-1.0.6-4.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-18 01:45:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 564245, 583274    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log
none
Patch for Makefile.in
none
Patch for Makefile.am none

Description FTBFS 2010-02-13 11:25:41 EST
gnujump-1.0.6-3.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:25:44 EST
Created attachment 390828 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:25:45 EST
Created attachment 390829 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:25:46 EST
Created attachment 390830 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:25:47 EST
Created attachment 390831 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:25:49 EST
Created attachment 390832 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:25:50 EST
Created attachment 390833 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:34:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-03-27 16:41:17 EDT
Created attachment 403037 [details]
Patch for Makefile.in

SDL_rotozoom requires the math library but it isn't explicitly added as a link option. This breaks builds in F13+.
This patch will allow the package to be rebuilt in F13 and later.
Comment 9 Bruno Wolff III 2010-03-27 16:42:56 EDT
Created attachment 403038 [details]
Patch for Makefile.am

While Makefile.am isn't used directly for Fedora builds, it is used by upstream to create Makefile.in, so this patch should get sent upstream.
Comment 10 Vivek Shah 2010-09-02 04:32:02 EDT
*** Bug 599835 has been marked as a duplicate of this bug. ***
Comment 11 Jan Klepek 2010-09-27 12:03:53 EDT
any progress on fixing this bug for fedora?
Comment 12 Vivek Shah 2010-09-28 16:58:20 EDT
I have been extremely lazy with this. I need to look into the patch added by Bruno and then test/fix accordingly. I will get it done Friday. I am extremely loaded over the next couple of days.
Comment 13 Fedora Update System 2010-10-08 11:48:34 EDT
gnujump-1.0.6-4.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/gnujump-1.0.6-4.fc12
Comment 14 Fedora Update System 2010-10-08 11:52:02 EDT
gnujump-1.0.6-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnujump-1.0.6-4.fc13
Comment 15 Fedora Update System 2010-10-08 11:57:37 EDT
gnujump-1.0.6-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnujump-1.0.6-4.fc14
Comment 16 Fedora Update System 2010-10-08 16:29:51 EDT
gnujump-1.0.6-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnujump'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnujump-1.0.6-4.fc13
Comment 17 Fedora Update System 2010-10-18 01:45:46 EDT
gnujump-1.0.6-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-10-19 03:11:37 EDT
gnujump-1.0.6-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2010-10-19 03:17:58 EDT
gnujump-1.0.6-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.