Bug 565840

Summary: liveinst fails - OSError: [Errno 2] No such file or directory: '/tmp/updates'
Product: [Fedora] Fedora Reporter: James Laska <jlaska>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: anaconda-maint-list, awilliam, bugzilla, fedora, jonathan, jturner, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-13.27-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-26 02:19:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 538273    

Description James Laska 2010-02-16 14:06:36 UTC
Description of problem:

Live installs fail to start due to a missing /tmp/updates directory.  I can easily work around this, by creating the directory.  My question ...

* Should anaconda not fail if the directory is missing? 
* Should livecd tools be creating this directory?

Version-Release number of selected component (if applicable):

 * anaconda-13.26

How reproducible:

 * everytime

Steps to Reproduce:
1. Boot a fedora live image that has anaconda-13.26 installed
2. At a command-prompt, type 'liveinst'
  
Actual results:

[liveuser@localhost ~]$ liveinst 
umount: /media/*: not found
  0 logical volume(s) in volume group "linux" now active
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 775, in <module>
    setupPythonUpdates()
  File "/usr/sbin/anaconda", line 118, in setupPythonUpdates
    for pkg in os.listdir("/tmp/updates"):
OSError: [Errno 2] No such file or directory: '/tmp/updates'

Expected results:

No failures

Additional info:

Comment 1 Chris Lumens 2010-02-16 18:19:49 UTC
*** Bug 565936 has been marked as a duplicate of this bug. ***

Comment 2 Adam Williamson 2010-02-26 02:19:51 UTC
Myself, oxf13 and a few others on IRC don't see this in an anaconda 13.31 build, closing.