Bug 568844

Summary: Akonadi server crashes on startup
Product: [Fedora] Fedora Reporter: Michael McLagan <mmclagan>
Component: akonadiAssignee: Kevin Kofler <kevin>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 12CC: jreznik, kevin, ltinkl, mathstuf, rdieter, smparrish, than
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-27 14:41:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael McLagan 2010-02-26 18:05:34 UTC
Description of problem:

Akonadi server crash prevents use of kmail

Version-Release number of selected component (if applicable):

1.3.1-2.fc12

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Server crashes, kmail aborts

Expected results:

Kmail starts as normal

Additional info:

"[
0: akonadiserver(_Z11akBacktracev+0x36) [0x8051976]
1: akonadiserver() [0x8051e4b]
2: [0xb7853400]
3: /usr/lib/libmysqlclient_r.so.16(my_strcasecmp_8bit+0x1a) [0xb681975a]
4: /usr/lib/libmysqlclient_r.so.16(get_charset_number+0x9e) [0xb680e31e]
5: /usr/lib/libmysqlclient_r.so.16(get_charset_by_csname+0x4a) [0xb680e6ba]
6: /usr/lib/libmysqlclient_r.so.16(mysql_init_character_set+0x68) [0xb682c828]
7: /usr/lib/libmysqlclient_r.so.16(mysql_real_connect+0x524) [0xb682ceb4]
8: /usr/lib/qt4/plugins/sqldrivers/libqsqlmysql.so(+0x7ad8) [0xb783ead8]
9: /usr/lib/libQtSql.so.4(_ZN12QSqlDatabase4openEv+0x42) [0xb7313822]
10: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi9DataStore4openEv+0x1b0) [0xb77a3410]
11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi9DataStoreC1Ev+0x95) [0xb77a37f5]
12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi9DataStore4selfEv+0x5e) [0xb77a38ce]
13: /usr/lib/libakonadiprivate.so.1(_ZN13IntervalCheck3runEv+0x20) [0xb772fed0]
14: /usr/lib/libQtCore.so.4(+0x5ccdf) [0xb74cbcdf]
15: /lib/libpthread.so.0(+0x5ab5) [0xb745aab5]
16: /lib/libc.so.6(clone+0x5e) [0xb6f3cdce]
]
" 

akonadi-1.3.1-2.fc12.i686
kdepimlibs-akonadi-4.4.0-2.fc12.i686
kdepim-runtime-libs-4.4.0-4.fc12.i686
kdepim-runtime-4.4.0-4.fc12.i686
kdepim-4.4.0-5.fc12.i686
kdepim-libs-4.4.0-5.fc12.i686
kdepimlibs-4.4.0-2.fc12.i686
qt-mysql-4.6.2-1.fc12.i686
MySQL-server-5.1.44-1.glibc23.i386
MySQL-shared-compat-5.1.44-1.glibc23.i386
MySQL-client-5.1.44-1.glibc23.i386

Comment 1 Rex Dieter 2010-02-27 14:41:28 UTC
stock mysql-5.1.44 is broken.

Use fedora's patched build.

*** This bug has been marked as a duplicate of bug 566547 ***