This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 566547 - mysql-5.1.43 incompat with akonadi
mysql-5.1.43 incompat with akonadi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
: 568844 (view as bug list)
Depends On:
Blocks: F13Alpha/F13AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-02-18 14:14 EST by Rex Dieter
Modified: 2013-07-02 23:27 EDT (History)
10 users (show)

See Also:
Fixed In Version: mysql-5.1.44-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-24 15:12:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Trial patch for this problem (6.34 KB, patch)
2010-02-20 00:03 EST, Tom Lane
no flags Details | Diff
upstream patch for charset issue (6.14 KB, patch)
2010-02-26 14:15 EST, Rex Dieter
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 226960 None None None Never
Debian BTS 569549 None None None Never

  None (edit)
Description Rex Dieter 2010-02-18 14:14:53 EST
An akonadi db initialized with 5.1.43 fails to start, gives errors of the form:


[akonadiserver] Character set 'latin1' is not a compiled character set and is not specified in the '/usr/share/mysql/charsets/Index.xml' file
[akonadiserver] Database error: Cannot open database.


See also,
https://bugs.kde.org/show_bug.cgi?id=226960
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=569549
Comment 1 Rex Dieter 2010-02-18 14:23:15 EST
I and another fellow on irc downgraded to 5.1.42-7 , and it works better (no errors).
Comment 2 Tom Lane 2010-02-18 14:23:58 EST
Hmph , has anybody reported this upstream to mysql.com?
Comment 3 Rex Dieter 2010-02-18 14:31:40 EST
Not yet, still investigating for details, not even 100% sure it's all mysql's fault, honestly.

all we know at this point is
akonadi-1.3.1 + mysql-5.1.43  = bad.
Comment 4 Rex Dieter 2010-02-18 15:12:30 EST
This upstream report looks a lot like what we're seeing,
http://bugs.mysql.com/bug.php?id=15547

but that doesn't seem specific to 5.1.43
Comment 5 Tom Lane 2010-02-18 15:47:29 EST
15547 is ancient, but what is new in 5.1.43 is the patch for the linked report
http://bugs.mysql.com/bug.php?id=45058
I'll bet that broke it somehow.
Comment 6 Rex Dieter 2010-02-18 16:04:34 EST
I can do a build reversing that patch, and do some more testing.
Comment 7 Rex Dieter 2010-02-18 16:08:32 EST
Ugh, only parts of http://lists.mysql.com/commits/87152 seem to be applied in 5.1.53
Comment 8 Tom Lane 2010-02-18 18:11:52 EST
Yeah, figuring out which patch actually got applied is often no fun with mysql.  I think they intentionally make their SCM not too transparent.
Comment 9 Tom Lane 2010-02-19 20:32:28 EST
Keeping in mind that I know less than zip about akonadi --- could someone give me a step-by-step to reproduce this bug?
Comment 10 Rex Dieter 2010-02-19 20:51:20 EST
Sure.

0.  yum install akonadi

1.  make sure you have no existing ~/.local/share/akonadi dir.  (if exists, remove or rename)

2.  in terminal, 
$  akonadictl start

with the newer mysql-server, it fails to start and init the db giving errors per comment #1.

3.  (if you get akonadi to start),
$ akonadictl stop

then try repeating steps 1-3, with different mysql-server builds until success.
Comment 11 Tom Lane 2010-02-20 00:03:59 EST
Created attachment 395215 [details]
Trial patch for this problem

Reverts the relevant changes between 5.1.42 and 5.1.43
Comment 12 Tom Lane 2010-02-20 00:06:44 EST
I dug through the diff from 5.1.42 to 5.1.43 and extracted the parts that seemed to have to do with charset initialization.  This patch makes the problem go away for me, but I wonder if anyone else would like to try it?  Presumably it also brings back the issue that upstream hoped to fix in their bug 45058...
Comment 13 Rex Dieter 2010-02-20 11:24:53 EST
Thanks, I'll try to test that out today.
Comment 14 Bartosz Fabianowski 2010-02-20 11:46:43 EST
While I am not a Redhat user, I can confirm your patch addresses the issue. I was running into the same problems under FreeBSD with MySQL 5.5.1. Your patch applies cleanly to MySQL 5.5.1 as well and allows Akonadi to start normally. Thanks!
Comment 15 Tom Lane 2010-02-20 12:07:25 EST
(In reply to comment #14)

5.5.1 broke too, huh?  I thought they'd just messed up the back-port to the 5.1.x branch.  Please report that at the upstream bug 45058.
Comment 16 Bartosz Fabianowski 2010-02-20 12:55:11 EST
(In reply to comment #15)

I reported upstream that this also happens with 5.5.1 earlier today. It seems that the code change in itself is causing a problem, across all branches of MySQL it was applied to.
Comment 17 Tom Lane 2010-02-21 08:54:24 EST
I've added that patch to the just-completed build of 5.1.44; hopefully it will make things better.
Comment 18 Fedora Update System 2010-02-21 08:59:55 EST
mysql-5.1.44-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/mysql-5.1.44-1.fc12
Comment 19 Fedora Update System 2010-02-21 09:00:10 EST
mysql-5.1.44-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mysql-5.1.44-1.fc13
Comment 20 Fedora Update System 2010-02-21 09:00:19 EST
mysql-5.1.44-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mysql-5.1.44-1.fc11
Comment 21 Fedora Update System 2010-02-21 11:57:07 EST
mysql-5.1.44-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-1922
Comment 22 Rex Dieter 2010-02-21 12:18:19 EST
I can confirm that with the patched mysql-server-5.1.44-1.fc12.x86_64 build, I
can no longer reproduce the problem described here.  Thanks!
Comment 23 Fedora Update System 2010-02-21 22:43:54 EST
mysql-5.1.44-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mysql-5.1.44-2.fc13
Comment 24 Fedora Update System 2010-02-23 00:14:29 EST
mysql-5.1.44-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-2470
Comment 25 Fedora Update System 2010-02-23 00:23:51 EST
mysql-5.1.44-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2519
Comment 26 Fedora Update System 2010-02-23 00:25:46 EST
mysql-5.1.44-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-2547
Comment 27 Kevin Kofler 2010-02-23 09:15:57 EST
I'm taking this off the blocker for the F11 and F12 KDE 4.4.0 updates as the MySQL in F11/F12 updates is fine and the one in F11/F12 updates-testing is now fixed too.

However, I had to add this to the F13Alpha blocker as the current MySQL in F13 Alpha is broken and this screws up the KDE spin. :-(
Comment 28 Kevin Kofler 2010-02-23 09:17:10 EST
(mysql-5.1.44-2.fc13 has the fix, we need that build in the alpha.)
Comment 29 Adam Williamson 2010-02-23 11:54:06 EST
just to keep it on the public record, kevin tells me jesse is aware of this issue and will pull the fix into rc3.

it's a very borderline call on its actual alpha blocker-iness - per the criteria, we wouldn't necessarily consider a similar issue even in GNOME to be a blocker. but i'd certainly support including the fix if it's an obvious and relatively simple change that isn't likely to break anything else.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 30 Tom Lane 2010-02-23 12:21:37 EST
I'm prepared to push this stable if it gets another +1 karma.  But given mysql's recent track record a version update isn't necessarily a totally safe thing, so more testing would definitely make me feel better about it.
Comment 31 Jesse Keating 2010-02-24 14:04:38 EST
I've pulled mysql-5.1.44-2.fc13 into my side repo for the RC3 compose.
Comment 32 Tom Lane 2010-02-24 14:26:34 EST
[ shrug... ]  Since apparently this will be in rc3 regardless of my concerns about stability, I might as well push it stable instead of having it go in through a back door.
Comment 33 Rex Dieter 2010-02-24 14:36:16 EST
Do you have a better suggestion wrt rc3?

1.  leave in 4.1.43 and keep the breakage outlined here
2.  patch 4.1.43 instead
3.  revert to 4.1.42
4.  ??
Comment 34 Tom Lane 2010-02-24 14:50:54 EST
What I asked for was more people to test the package while it was in testing, like say more than one of the half dozen people subscribed to this bug report.  Doesn't seem that that's going to happen in any timely fashion, so I marked it stable.
Comment 35 Rex Dieter 2010-02-24 15:03:53 EST
If it makes you feel better, there were several other confirmations on irc (but I agree that getting the explicit bodhi +1's would've been nicer).
Comment 36 Adam Williamson 2010-02-24 15:12:52 EST
given the amount of confirmations mentioned by rex, and since this is blocking the alpha, let's close it. please re-open if there turn out to be problems.

if you want to confirm this you can fake up an alpha pre-rc3 KDE live build by using the KDE desktop .ks along with jesse's side repo, at http://alt.fedoraproject.org/pub/alt/stage/bleed/ . I'm doing this myself for the desktop spin to do some testing on that.
Comment 37 Fedora Update System 2010-02-25 07:49:37 EST
mysql-5.1.44-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 38 Davi Arnaut 2010-02-26 11:21:00 EST
A patch has been committed to mysql that hopefully addresses this problem. Testing is appreciated.

Tom Lane: We use distributed revision control, a patch associated with a bug report might not be the merged patch due to code differences when merging between trees. To retrieve the exact path, use bzr to branch from launchpad and extract the exact revision (*).

http://forge.mysql.com/wiki/Bazaar
Comment 39 Rex Dieter 2010-02-26 11:34:55 EST
I'll try testing that out, provide feedback upstream.
Comment 40 Rex Dieter 2010-02-26 13:47:30 EST
upstream fix appears good, on initial testing.

For posterity, I'll attach the patch I used
Comment 41 Rex Dieter 2010-02-26 14:15:58 EST
Created attachment 396644 [details]
upstream patch for charset issue

replaces existing mysql-chartset-bug.patch
Comment 42 Rex Dieter 2010-02-27 09:41:28 EST
*** Bug 568844 has been marked as a duplicate of this bug. ***
Comment 43 Fedora Update System 2010-03-08 22:18:37 EST
mysql-5.1.44-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 44 Fedora Update System 2010-03-10 01:45:17 EST
mysql-5.1.44-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.