Bug 577661

Summary: SELinux is preventing /usr/libexec/gdm-session-worker "remove_name" access on .xsession-errors.
Product: [Fedora] Fedora Reporter: Chris Miller <cjm>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: cjm, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:6033ad2b2c30fcfd1207c7989328f5a1070f71180149373f4c92c58528388773
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-29 08:35:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Miller 2010-03-28 18:09:50 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "remove_name" access on
.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .xsession-errors [ dir ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.2-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-99.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.9-70.fc12.i686.PAE #1
                              SMP Wed Mar 3 04:57:21 UTC 2010 i686 i686
Alert Count                   4
First Seen                    Thu 18 Mar 2010 10:29:27 PM PDT
Last Seen                     Thu 18 Mar 2010 10:29:27 PM PDT
Local ID                      e1484f26-932a-4990-b145-4ca5d28be761
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1268976567.914:146): avc:  denied  { remove_name } for  pid=3332 comm="gdm-session-wor" name=".xsession-errors" dev=sda2 ino=1133055 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1268976567.914:146): avc:  denied  { rename } for  pid=3332 comm="gdm-session-wor" name=".xsession-errors" dev=sda2 ino=1133055 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1268976567.914:146): avc:  denied  { add_name } for  pid=3332 comm="gdm-session-wor" name=".xsession-errors.old" dev=sda2 ino=1133047 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1268976567.914:146): avc:  denied  { unlink } for  pid=3332 comm="gdm-session-wor" name=".xsession-errors.old" dev=sda2 ino=1133047 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1268976567.914:146): arch=40000003 syscall=38 success=yes exit=0 a0=8fc1d90 a1=8fc1718 a2=8fc1718 a3=8fc1d90 items=0 ppid=3149 pid=3332 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=20 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,admin_home_t,dir,remove_name
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:dir { remove_name add_name };
allow xdm_t admin_home_t:file { rename unlink };

Comment 1 Miroslav Grepl 2010-03-29 08:28:17 UTC
*** Bug 577663 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-03-29 08:29:25 UTC
*** Bug 577662 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-03-29 08:35:16 UTC
Are you logging in as root via X?  This is not allowed by SELinux.

*** This bug has been marked as a duplicate of bug 543970 ***