Bug 577662 - SELinux is preventing /usr/sbin/ntpd "read" access on /root/.xsession-errors.
Summary: SELinux is preventing /usr/sbin/ntpd "read" access on /root/.xsession-er...
Keywords:
Status: CLOSED DUPLICATE of bug 577661
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:24c56feddb1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-28 18:13 UTC by Chris Miller
Modified: 2010-03-29 08:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-29 08:29:25 UTC


Attachments (Terms of Use)

Description Chris Miller 2010-03-28 18:13:23 UTC
Summary:

SELinux is preventing /usr/sbin/ntpd "read" access on /root/.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by ntpd. It is not expected that this access is
required by ntpd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:ntpd_t:s0
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root/.xsession-errors [ file ]
Source                        ntpd
Source Path                   /usr/sbin/ntpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ntp-4.2.4p8-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-99.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.9-70.fc12.i686.PAE #1
                              SMP Wed Mar 3 04:57:21 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Thu 18 Mar 2010 11:51:30 PM PDT
Last Seen                     Thu 18 Mar 2010 11:51:30 PM PDT
Local ID                      882769ad-1eb1-464f-a6fa-4c0b52ac390b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1268981490.514:438): avc:  denied  { read } for  pid=13914 comm="ntpd" path="/root/.xsession-errors" dev=sda2 ino=1133047 scontext=unconfined_u:system_r:ntpd_t:s0 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1268981490.514:438): arch=40000003 syscall=11 success=yes exit=0 a0=9815fd0 a1=98162d0 a2=9815298 a3=98162d0 items=0 ppid=13913 pid=13914 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=20 comm="ntpd" exe="/usr/sbin/ntpd" subj=unconfined_u:system_r:ntpd_t:s0 key=(null)



Hash String generated from  catchall,ntpd,ntpd_t,admin_home_t,file,read
audit2allow suggests:

#============= ntpd_t ==============
allow ntpd_t admin_home_t:file read;

Comment 1 Miroslav Grepl 2010-03-29 08:29:25 UTC

*** This bug has been marked as a duplicate of bug 577661 ***


Note You need to log in before you can comment on or make changes to this bug.