Bug 578021

Summary: lang-specific overrides rule doesn't work as expected
Product: [Fedora] Fedora Reporter: Akira TAGOH <tagoh>
Component: ipa-mincho-fontsAssignee: Akira TAGOH <tagoh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: fonts-bugs, i18n-bugs, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: ipa-mincho-fonts-003.02-2.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586840 (view as bug list) Environment:
Last Closed: 2010-05-10 19:49:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 578015    
Bug Blocks: 507684, 586840    

Description Akira TAGOH 2010-03-29 23:34:00 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 66-ipa-mincho.conf
Comment 1 Akira TAGOH 2010-04-16 21:30:35 EDT
Fixed in ipa-mincho-fonts-003.02-2.fc13
Comment 2 Fedora Update System 2010-04-16 21:36:21 EDT
ipa-mincho-fonts-003.02-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ipa-mincho-fonts-003.02-2.fc13
Comment 3 Fedora Update System 2010-04-20 09:33:40 EDT
ipa-mincho-fonts-003.02-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ipa-mincho-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ipa-mincho-fonts-003.02-2.fc13
Comment 4 Akira TAGOH 2010-04-26 05:44:59 EDT
Testing result:
# rpm -qa ipa-mincho-fonts
ipa-mincho-fonts-003.02-2.fc13.noarch
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ja
ipam.ttf: "IPAMincho" "Regular"
# fc-match serif:lang=ja-jp
ipam.ttf: "IPAMincho" "Regular"

That looks good though, that may be good to not use compare="contains" since fontconfig matches to another languages with it, but luckily not appearing this at the head because of the priority etc.

# for i in $(ls /usr/share/locale|grep -v -E "^(ja)$"); do fc-match serif:lang=$i|grep -E "^(IPAMincho)$"; [ $? = 0 ] && echo $i; done
#

No affects to other languages.
Comment 5 Fedora Update System 2010-05-10 19:49:40 EDT
ipa-mincho-fonts-003.02-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.