Bug 578015 - l10n-font-template.conf doesn't work as expected
l10n-font-template.conf doesn't work as expected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fontpackages (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Target 578017 578018 578019 578020 578021 578023 578025 578026 578027 578028 578029 578030 578031 578032 578034 578036 578037 578038 578039 578040 578041 578042 578043 578045 578046 578047 578048 578049 578050 578051 586797
  Show dependency treegraph
 
Reported: 2010-03-29 23:11 EDT by Akira TAGOH
Modified: 2010-06-29 03:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 03:39:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (603 bytes, patch)
2010-05-14 05:24 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2010-03-29 23:11:34 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in this template prevents to apply the rule for the specific language only properly. As a result, fonts is used for non-targetted languages and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from this template.
Comment 1 Akira TAGOH 2010-03-29 23:17:45 EDT
Packages applied this rule is following. all of them needs to be fixed otherwise any of them will be still picked up as long as either of them are installed:

baekmuk-ttf-batang-fonts
baekmuk-ttf-dotum-fonts
baekmuk-ttf-gulim-fonts
culmus-aharoni-clm-fonts
culmus-david-clm-fonts
culmus-drugulin-clm-fonts
culmus-ellinia-clm-fonts
culmus-frank-ruehl-clm-fonts
culmus-miriam-clm-fonts
culmus-miriam-mono-clm-fonts
culmus-nachlieli-clm-fonts
hanazono-fonts
ipa-gothic-fonts
ipa-mincho-fonts
ipa-pgothic-fonts
ipa-pmincho-fonts
kacst-art-fonts
kacst-book-fonts
kacst-decorative-fonts
kacst-digital-fonts
kacst-farsi-fonts
kacst-letter-fonts
kacst-naskh-fonts
kacst-office-fonts
kacst-one-fonts
kacst-pen-fonts
kacst-poster-fonts
kacst-qurn-fonts
kacst-screen-fonts
kacst-title-fonts
kacst-titlel-fonts
knm-new-fixed-fonts
lklug-fonts
lohit-assamese-fonts
lohit-bengali-fonts
lohit-devanagari-fonts
lohit-gujarati-fonts
lohit-kannada-fonts
lohit-malayalam-fonts
lohit-oriya-fonts
lohit-punjabi-fonts
lohit-tamil-fonts
lohit-telugu-fonts
madan-fonts
samyak-devanagari-fonts
samyak-gujarati-fonts
samyak-malayalam-fonts
samyak-oriya-fonts
samyak-tamil-fonts
sarai-fonts
sazanami-gothic-fonts
sazanami-mincho-fonts
smc-anjalioldlipi-fonts
smc-dyuthi-fonts
smc-kalyani-fonts
smc-meera-fonts
smc-rachana-fonts
smc-raghumalayalam-fonts
smc-suruma-fonts
thai-scalable-garuda-fonts
thai-scalable-kinnari-fonts
thai-scalable-umpush-fonts
vlgothic-fonts
vlgothic-p-fonts
woodardworks-laconic-shadow-fonts
wqy-microhei-fonts
wqy-zenhei-fonts
Comment 2 Nicolas Mailhot 2010-03-30 10:16:59 EDT
If you can get Behdad to state your analysis is right I see no problem in updating the template
Comment 3 Akira TAGOH 2010-03-30 20:44:36 EDT
This is the logs what I get from behdad so far:
<##fonts:tagoh> behdad: not sure why we use binding="same" in the patte
rn editing for lang specific thing
<##fonts:behdad> tagoh: if the goal is to alias differing names of equi
valent fonts, we want same binding
<##fonts:behdad> otherwise it doesn't really work

The main purpose of this rule isn't to get the exact alias right, because there are no fonts has certain glyph coverages for everything. and what we are expecting here would be to apply the certain fonts partially for the languages. I see same binding is still useful if one wants to replace AAA font to BBB font say.
Comment 4 Nicolas Mailhot 2010-03-31 06:18:05 EDT
Ok, if it doesn t really work, I ll change it when I m back from vacation next week
Do you want commit acces to fontpackages so you can contribute enhancements directly in the future ? I hate being the single point of failure there
Comment 5 Akira TAGOH 2010-04-01 03:53:29 EDT
(In reply to comment #4)
> Ok, if it doesn t really work, I ll change it when I m back from vacation next
> week

Thanks. to make this clearer more, as a result, this change will puts more gravity to the priority prefix to determine which fonts is better, because strong binding only overrides this list after that and we use that for the case only where AA font could replaces BB font say. and it works expectedly as long as we test the language properly.

> Do you want commit acces to fontpackages so you can contribute enhancements
> directly in the future ? I hate being the single point of failure there    

That would be really nice :) I continued the development of the fontconfig audit stuff recently and nearly ready to see if config files contains authorized rules against templates. I'm keen to contribute this audit program, but anyway.
Comment 6 Akira TAGOH 2010-05-14 05:24:25 EDT
Created attachment 413988 [details]
proposed patch

just attached here because I don't have access to commit it to fontpackages.

* Fri May 14 2010 Akira TAGOH <tagoh@redhat.com>
- 1.42-2
— Get rid of binding="same" from l10n-font-template.conf (#578015)
Comment 7 Akira TAGOH 2010-05-28 02:23:17 EDT
Thanks for approving the request to access on fontpackages.git. just pushed the change the above.
Comment 8 Akira TAGOH 2010-05-28 04:01:28 EDT
and fixed in fontpackages-1.42-2.fc14.

Note You need to log in before you can comment on or make changes to this bug.