Bug 578036

Summary: lang-specific overrides rule doesn't work as expected
Product: [Fedora] Fedora Reporter: Akira TAGOH <tagoh>
Component: lohit-malayalam-fontsAssignee: Pravin Satpute <psatpute>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: fonts-bugs, i18n-bugs, psatpute
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: lohit-malayalam-fonts-2.4.4-5.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586862 (view as bug list) Environment:
Last Closed: 2010-04-25 10:01:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 578015    
Bug Blocks: 507684, 586862    

Description Akira TAGOH 2010-03-29 23:46:25 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 67-lohit-malayalam.conf
Comment 1 Fedora Update System 2010-04-16 11:39:17 EDT
lohit-malayalam-fonts-2.4.4-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lohit-malayalam-fonts-2.4.4-5.fc13
Comment 2 Pravin Satpute 2010-04-16 11:42:30 EDT
fixed in lohit-malayalam-fonts-2.4.4-5.fc14
Comment 3 Fedora Update System 2010-04-20 09:04:22 EDT
lohit-malayalam-fonts-2.4.4-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-malayalam-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/lohit-malayalam-fonts-2.4.4-5.fc13
Comment 4 Akira TAGOH 2010-04-22 05:36:37 EDT
Please note that I've removed smc-meera-fonts for testing first since it has a priority than lohit-malayalam-fonts.

Testing result:
# rpm -q lohit-malayalam-fonts
lohit-malayalam-fonts-2.4.4-5.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml
Lohit-Malayalam.ttf: "Lohit Malayalam" "Regular"
# fc-match monospace:lang=ml-in
Lohit-Malayalam.ttf: "Lohit Malayalam" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml
Lohit-Malayalam.ttf: "Lohit Malayalam" "Regular"
# fc-match serif:lang=ml-in
Lohit-Malayalam.ttf: "Lohit Malayalam" "Regular"

Though no rules for monospace nor serif in lohit-malayalam-fonts. may be good to have one for them?

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml
Lohit-Malayalam.ttf: "Lohit Malayalam" "Regular"
# fc-match sans:lang=ml-in
Lohit-Malayalam.ttf: "Lohit Malayalam" "Regular"

That looks good.

# for i in $(ls /usr/share/locale|grep -v ml); do fc-match sans:lang=$i|grep "Lohit Malayalam"; [ $? = 0 ] && echo $i; done
#

Confirmed that the updated package works fine.
Comment 5 Fedora Update System 2010-04-25 10:01:35 EDT
lohit-malayalam-fonts-2.4.4-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.