This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 580146

Summary: sssd requires fully versioned deps, which can prevent yum upgrades
Product: [Fedora] Fedora Reporter: Matt Domsch <matt_domsch>
Component: sssdAssignee: Simo Sorce <ssorce>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: jhrozek, sbose, sgallagh, ssorce
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-07 11:14:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Matt Domsch 2010-04-07 11:11:51 EDT
Description of problem:
yum upgrade fails.  libcollection, libini_config, and libdhash went backwards in updates-testing versioning (0.4.0-2.fc13 of all are installed on my system, but only 0.4.0-1.fc13 of all are in updates-testing anymore).  sssd requires fully versioned deps, not a > {someversion}

rpm -q --requires sssd-1.1.1-1.fc13 
libcollection = 0.4.0-1.fc13
libdhash = 0.4.0-1.fc13
libini_config = 0.4.0-1.fc13




--> Package sssd.x86_64 0:1.1.1-1.fc13 set to be updated
--> Processing Dependency: libcollection = 0.4.0-1.fc13 for package: sssd-1.1.1-1.fc13.x86_64
--> Processing Dependency: libini_config = 0.4.0-1.fc13 for package: sssd-1.1.1-1.fc13.x86_64
--> Processing Dependency: libdhash = 0.4.0-1.fc13 for package: sssd-1.1.1-1.fc13.x86_64

[snip]

Transaction Check Error:
  package libcollection-0.4.0-2.fc13.x86_64 (which is newer than libcollection-0.4.0-1.fc13.i686) is already installed
  package libini_config-0.4.0-2.fc13.x86_64 (which is newer than libini_config-0.4.0-1.fc13.i686) is already installed
  package libdhash-0.4.0-2.fc13.x86_64 (which is newer than libdhash-0.4.0-1.fc13.i686) is already installed




Requires: libdhash = %{dhash_version}-%{release}
Requires: libcollection = %{collection_version}-%{release}
Requires: libini_config = %{ini_config_version}-%{release}


Version-Release number of selected component (if applicable):
sssd-1.1.1-1
Comment 1 Matt Domsch 2010-04-07 11:14:29 EDT

*** This bug has been marked as a duplicate of bug 579033 ***