Bug 583401

Summary: [abrt] crash in elisa-0.5.35-2.fc12: pb.py:40:<module>:ImportError: No module named hashlib
Product: [Fedora] Fedora Reporter: Lubos Kocman <setuid>
Component: elisaAssignee: Matthias Saou <matthias>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: matthias, mschmidt
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard: abrt_hash:654e8c53
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-19 04:48:05 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: backtrace none

Description Lubos Kocman 2010-04-18 06:58:25 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/elisa
comment: Just tried to start up elisa. Doesn't matter if ~/.elisa-0.5 exist or not.
component: elisa
executable: /usr/bin/elisa
kernel: 2.6.33.1-24.fc13.i686.PAE
package: elisa-0.5.35-2.fc12
reason: pb.py:40:<module>:ImportError: No module named hashlib
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.Have elisa-0.5.35-2.fc12.noarch installed
2. Execute Elisa from gnome-menu
3.
Comment 1 Lubos Kocman 2010-04-18 06:58:27 EDT
Created attachment 407385 [details]
File: backtrace
Comment 2 Lubos Kocman 2010-04-18 07:09:10 EDT
From the code,

elisa is trying to import twisted.python.hashlib

exactly:

from twisted.python.hashlib import md5

I'm not able to import this module. But hashlib is present on the system:

/usr/lib/python2.6/hashlib.py

so I re-installed python-twisted, and even from installer can be seen that there is some problem with python-twisted.

bash-4.1$ sudo yum -y install python-twisted
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-twisted.noarch 0:8.2.0-3.fc12 set to be updated
--> Processing Dependency: python-twisted-lore >= 8.2.0 for package: python-twisted-8.2.0-3.fc12.noarch
--> Processing Dependency: python-twisted-names >= 8.2.0 for package: python-twisted-8.2.0-3.fc12.noarch
--> Processing Dependency: python-twisted-runner >= 8.0.0 for package: python-twisted-8.2.0-3.fc12.noarch
--> Processing Dependency: python-twisted-words >= 8.2.0 for package: python-twisted-8.2.0-3.fc12.noarch
--> Processing Dependency: python-twisted-mail >= 8.2.0 for package: python-twisted-8.2.0-3.fc12.noarch
--> Processing Dependency: python-twisted-news >= 8.2.0 for package: python-twisted-8.2.0-3.fc12.noarch
--> Processing Dependency: python-twisted-conch >= 8.2.0 for package: python-twisted-8.2.0-3.fc12.noarch
--> Running transaction check
---> Package python-twisted-conch.i686 0:8.2.0-3.fc12 set to be updated
---> Package python-twisted-lore.i686 0:8.2.0-3.fc12 set to be updated
---> Package python-twisted-mail.i686 0:8.2.0-3.fc12 set to be updated
---> Package python-twisted-names.i686 0:8.2.0-3.fc12 set to be updated
---> Package python-twisted-news.i686 0:8.2.0-3.fc12 set to be updated
---> Package python-twisted-runner.i686 0:8.2.0-3.fc12 set to be updated
---> Package python-twisted-words.i686 0:8.2.0-3.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch         Version            Repository    Size
================================================================================
Installing:
 python-twisted              noarch       8.2.0-3.fc12       fedora       6.2 k
Installing for dependencies:
 python-twisted-conch        i686         8.2.0-3.fc12       fedora       415 k
 python-twisted-lore         i686         8.2.0-3.fc12       fedora       112 k
 python-twisted-mail         i686         8.2.0-3.fc12       fedora       296 k
 python-twisted-names        i686         8.2.0-3.fc12       fedora       109 k
 python-twisted-news         i686         8.2.0-3.fc12       fedora        45 k
 python-twisted-runner       i686         8.2.0-3.fc12       fedora        24 k
 python-twisted-words        i686         8.2.0-3.fc12       fedora       374 k

Transaction Summary
================================================================================
Install       8 Package(s)
Upgrade       0 Package(s)

Total download size: 1.3 M
Installed size: 7.6 M
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 1.3 M
(1/8): python-twisted-8.2.0-3.fc12.noarch.rpm            | 6.2 kB     00:00     
(2/8): python-twisted-conch-8.2.0-3.fc12.i686.rpm        | 415 kB     00:00     
(3/8): python-twisted-lore-8.2.0-3.fc12.i686.rpm         | 112 kB     00:00     
(4/8): python-twisted-mail-8.2.0-3.fc12.i686.rpm         | 296 kB     00:00     
(5/8): python-twisted-names-8.2.0-3.fc12.i686.rpm        | 109 kB     00:00     
(6/8): python-twisted-news-8.2.0-3.fc12.i686.rpm         |  45 kB     00:00     
(7/8): python-twisted-runner-8.2.0-3.fc12.i686.rpm       |  24 kB     00:00     
(8/8): python-twisted-words-8.2.0-3.fc12.i686.rpm        | 374 kB     00:00     
--------------------------------------------------------------------------------
Total                                           733 kB/s | 1.3 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : python-twisted-runner-8.2.0-3.fc12.i686                  1/8 
  Installing     : python-twisted-names-8.2.0-3.fc12.i686                   2/8 
Traceback (most recent call last):
  File "/usr/libexec/twisted-dropin-cache", line 13, in <module>
    from twisted.plugin import IPlugin, getCache
  File "/usr/lib/python2.6/site-packages/twisted/plugin.py", line 34, in <module>
    from twisted.python.modules import getModule
  File "/usr/lib/python2.6/site-packages/twisted/python/modules.py", line 67, in <module>
    from twisted.python.filepath import FilePath, UnlistableError
  File "/usr/lib/python2.6/site-packages/twisted/python/filepath.py", line 27, in <module>
    from twisted.python.hashlib import sha1
ImportError: No module named hashlib
  Installing     : python-twisted-mail-8.2.0-3.fc12.i686                    3/8 
Traceback (most recent call last):
  File "/usr/libexec/twisted-dropin-cache", line 13, in <module>
    from twisted.plugin import IPlugin, getCache
  File "/usr/lib/python2.6/site-packages/twisted/plugin.py", line 34, in <module>
    from twisted.python.modules import getModule
  File "/usr/lib/python2.6/site-packages/twisted/python/modules.py", line 67, in <module>
    from twisted.python.filepath import FilePath, UnlistableError
  File "/usr/lib/python2.6/site-packages/twisted/python/filepath.py", line 27, in <module>
    from twisted.python.hashlib import sha1
ImportError: No module named hashlib
  Installing     : python-twisted-news-8.2.0-3.fc12.i686                    4/8 
Traceback (most recent call last):
  File "/usr/libexec/twisted-dropin-cache", line 13, in <module>
    from twisted.plugin import IPlugin, getCache
  File "/usr/lib/python2.6/site-packages/twisted/plugin.py", line 34, in <module>
    from twisted.python.modules import getModule
  File "/usr/lib/python2.6/site-packages/twisted/python/modules.py", line 67, in <module>
    from twisted.python.filepath import FilePath, UnlistableError
  File "/usr/lib/python2.6/site-packages/twisted/python/filepath.py", line 27, in <module>
    from twisted.python.hashlib import sha1
ImportError: No module named hashlib
  Installing     : python-twisted-lore-8.2.0-3.fc12.i686                    5/8 
Traceback (most recent call last):
  File "/usr/libexec/twisted-dropin-cache", line 13, in <module>
    from twisted.plugin import IPlugin, getCache
  File "/usr/lib/python2.6/site-packages/twisted/plugin.py", line 34, in <module>
    from twisted.python.modules import getModule
  File "/usr/lib/python2.6/site-packages/twisted/python/modules.py", line 67, in <module>
    from twisted.python.filepath import FilePath, UnlistableError
  File "/usr/lib/python2.6/site-packages/twisted/python/filepath.py", line 27, in <module>
    from twisted.python.hashlib import sha1
ImportError: No module named hashlib
  Installing     : python-twisted-words-8.2.0-3.fc12.i686                   6/8 
Traceback (most recent call last):
  File "/usr/libexec/twisted-dropin-cache", line 13, in <module>
    from twisted.plugin import IPlugin, getCache
  File "/usr/lib/python2.6/site-packages/twisted/plugin.py", line 34, in <module>
    from twisted.python.modules import getModule
  File "/usr/lib/python2.6/site-packages/twisted/python/modules.py", line 67, in <module>
    from twisted.python.filepath import FilePath, UnlistableError
  File "/usr/lib/python2.6/site-packages/twisted/python/filepath.py", line 27, in <module>
    from twisted.python.hashlib import sha1
ImportError: No module named hashlib
  Installing     : python-twisted-conch-8.2.0-3.fc12.i686                   7/8 
Traceback (most recent call last):
  File "/usr/libexec/twisted-dropin-cache", line 13, in <module>
    from twisted.plugin import IPlugin, getCache
  File "/usr/lib/python2.6/site-packages/twisted/plugin.py", line 34, in <module>
    from twisted.python.modules import getModule
  File "/usr/lib/python2.6/site-packages/twisted/python/modules.py", line 67, in <module>
    from twisted.python.filepath import FilePath, UnlistableError
  File "/usr/lib/python2.6/site-packages/twisted/python/filepath.py", line 27, in <module>
    from twisted.python.hashlib import sha1
ImportError: No module named hashlib
  Installing     : python-twisted-8.2.0-3.fc12.noarch                       8/8 

Installed:
  python-twisted.noarch 0:8.2.0-3.fc12                                          

Dependency Installed:
  python-twisted-conch.i686 0:8.2.0-3.fc12                                      
  python-twisted-lore.i686 0:8.2.0-3.fc12                                       
  python-twisted-mail.i686 0:8.2.0-3.fc12                                       
  python-twisted-names.i686 0:8.2.0-3.fc12                                      
  python-twisted-news.i686 0:8.2.0-3.fc12                                       
  python-twisted-runner.i686 0:8.2.0-3.fc12                                     
  python-twisted-words.i686 0:8.2.0-3.fc12                                      

Complete!
bash-4.1$ elisa
Launcher core version: 0.5.35
Current core version: 0.5.35
Traceback (most recent call last):
  File "/usr/bin/elisa", line 8, in <module>
    load_entry_point('elisa==0.5.35', 'gui_scripts', 'elisa')()
  File "/usr/lib/python2.6/site-packages/elisa/core/launcher.py", line 389, in main
    Launcher().main(sys.argv)
  File "/usr/lib/python2.6/site-packages/elisa/core/launcher.py", line 83, in main
    return self.main_after_voodoo(argv)
  File "/usr/lib/python2.6/site-packages/elisa/core/launcher.py", line 230, in main_after_voodoo
    self.run_application()
  File "/usr/lib/python2.6/site-packages/elisa/core/launcher.py", line 356, in run_application
    from elisa.core.application import Application
  File "/usr/lib/python2.6/site-packages/elisa/core/application.py", line 37, in <module>
    from elisa.core import media_uri
  File "/usr/lib/python2.6/site-packages/elisa/core/media_uri.py", line 28, in <module>
    from elisa.extern.translation import Translatable
  File "/usr/lib/python2.6/site-packages/elisa/extern/translation.py", line 31, in <module>
    from twisted.spread import pb
  File "/usr/lib/python2.6/site-packages/twisted/spread/pb.py", line 40, in <module>
    from twisted.python.hashlib import md5
ImportError: No module named hashlib
bash-4.1$ rpm -q python-twisted
python-twisted-8.2.0-3.fc12.noarch


HTH

Lubos Kocman
Comment 3 Michal Schmidt 2010-04-19 04:48:05 EDT

*** This bug has been marked as a duplicate of bug 583304 ***