Bug 583304 - REGRESSION in python-twisted-core update: filepath.py:27:<module>:ImportError: No module named hashlib
REGRESSION in python-twisted-core update: filepath.py:27:<module>:ImportError...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-twisted-core (Show other bugs)
12
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Thomas Vander Stichele
Fedora Extras Quality Assurance
abrt_hash:612575ea
:
: 583246 583401 583473 583522 583618 583851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-17 15:23 EDT by Emmett Culley
Modified: 2010-04-20 09:23 EDT (History)
12 users (show)

See Also:
Fixed In Version: python-twisted-core-8.2.0-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-20 09:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (6.71 KB, text/plain)
2010-04-17 15:23 EDT, Emmett Culley
no flags Details

  None (edit)
Description Emmett Culley 2010-04-17 15:23:43 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: python -OO jabbim.py
component: jabbim
executable: /usr/share/jabbim/jabbim.py
kernel: 2.6.32.11-99.fc12.x86_64
package: jabbim-0.5-0.12.svn20091030.fc12
reason: filepath.py:27:<module>:ImportError: No module named hashlib
release: Fedora release 12 (Constantine)

comment
-----
This has been happening each time Jabbim is started.  This time jabbim didn't just through an execption.  It won't start at all.

I just updated my system to the latest.
Comment 1 Emmett Culley 2010-04-17 15:23:45 EDT
Created attachment 407297 [details]
File: backtrace
Comment 2 Michal Schmidt 2010-04-18 03:13:00 EDT
I see python-twisted-core was recently updated:
https://admin.fedoraproject.org/updates/python-twisted-core-8.2.0-4.fc12
https://admin.fedoraproject.org/updates/python-twisted-core-8.2.0-4.fc13

It seems that changeset_r25457.patch was unsufficiently tested.
Reassigning to python-twisted-core.


Thomas,
why did you push the update directly to stable?
For now I suggest you revert the change you did in -4, push it ASAP directly
to stable to fix the current regression.
Only later perhaps try to fix the deprecation warnings differently,
but make sure it goes via updates-testing.
Comment 3 Thomas Vander Stichele 2010-04-18 06:36:26 EDT
I don't understand how I didn't get that when testing the package, but I did get it updating now as well.

An important new file was missing from the patch which I had to rework by hand.  Including it now.
Comment 4 Fedora Update System 2010-04-18 07:01:53 EDT
python-twisted-core-8.2.0-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/python-twisted-core-8.2.0-5.fc13
Comment 5 Fedora Update System 2010-04-18 07:02:24 EDT
python-twisted-core-8.2.0-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-twisted-core-8.2.0-5.fc12
Comment 6 leigh scott 2010-04-18 10:23:25 EDT
(In reply to comment #3)
 
> An important new file was missing from the patch which I had to rework by hand.
>  Including it now.    


Why patch it? 10.0.0 doesn't need patching.



http://tmrc.mit.edu/mirror/twisted/Core/10.0/


http://fedoraforum.org/leigh123linux/srpm/python-twisted-core-10.0.0-1.fc13.src.rpm


your patch still misses a .py

[root@localhost F-13]# rpm -Uvh '/home/leigh/Desktop/python-twisted-core-8.2.0-5.fc13.x86_64.rpm' 
Preparing...                ########################################### [100%]
   1:python-twisted-core    ########################################### [100%]
/usr/lib64/python2.6/site-packages/twisted/persisted/sob.py:12: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import os, md5, sys
[root@localhost F-13]# 


10.0.0 installs cleanly

[root@localhost F-13]# rpm -Uvh /home/leigh/rpmbuild/RPMS/x86_64/python-twisted-core-10.0.0-1.fc13.x86_64.rpm
Preparing...                ########################################### [100%]
   1:python-twisted-core    ########################################### [100%]
[root@localhost F-13]#
Comment 7 Michal Schmidt 2010-04-19 04:25:50 EDT
*** Bug 583522 has been marked as a duplicate of this bug. ***
Comment 8 Michal Schmidt 2010-04-19 04:41:00 EDT
*** Bug 583246 has been marked as a duplicate of this bug. ***
Comment 9 Michal Schmidt 2010-04-19 04:48:05 EDT
*** Bug 583401 has been marked as a duplicate of this bug. ***
Comment 10 Michal Schmidt 2010-04-19 04:48:28 EDT
*** Bug 583473 has been marked as a duplicate of this bug. ***
Comment 11 Mads Kiilerich 2010-04-19 09:14:35 EDT
*** Bug 583618 has been marked as a duplicate of this bug. ***
Comment 12 Oliver Gould 2010-04-19 16:38:51 EDT

How to reproduce
-----
1. python -c 'import twisted.python.filepath'
2. 
3.
Comment 13 Luke Macken 2010-04-19 20:23:24 EDT
*** Bug 583851 has been marked as a duplicate of this bug. ***
Comment 14 Ian Botfield 2010-04-20 04:27:25 EDT

How to reproduce
-----
1.running betavine vodafone connection
2.
3.


Comment
-----
Installed betavine for vodafone vodem. running the application causing the above error
Comment 15 Fedora Update System 2010-04-20 05:57:41 EDT
python-twisted-core-8.2.0-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/python-twisted-core-8.2.0-6.fc13
Comment 16 Fedora Update System 2010-04-20 05:57:45 EDT
python-twisted-core-8.2.0-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-twisted-core-8.2.0-6.fc12
Comment 17 Fedora Update System 2010-04-20 09:03:46 EDT
python-twisted-core-8.2.0-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-04-20 09:23:23 EDT
python-twisted-core-8.2.0-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.