Bug 594550

Summary: Java does not work
Product: [Fedora] Fedora Reporter: Peter Gückel <pgueckel>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: cbm, gecko-bugs-nobody, mishu, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-09 18:12:13 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Peter Gückel 2010-05-20 21:43:55 EDT
Description of problem:
about:plugins does not show any java, even though java-1.6.0-openjdk-plugin-1.6.0.0-38.b18.fc13.x86_64 is installed.

Version-Release number of selected component (if applicable):
firefox-3.6.3-4.fc13.x86_64

How reproducible:
Open firefox and view about:plugins.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Gückel 2010-05-20 21:49:32 EDT
The java.com test shows that java is installed, but following the link to see whether it is working shows that it is not. The suggestions given there do not get it working, nor do they make it show up in about:plugins.

Also, running mozilla-plugin-config -i (leaving the fedora default /etc/sysconfig/nspluginwrapper intact) does not change the symptoms. No java in firefox.

Conversely, konqueror does indeed show java with this standard installation and setup.
Comment 2 Andre Robatino 2010-05-26 09:00:07 EDT
You appear to have the updates-testing version of java-1.6.0-openjdk.  The version in F13 stable is 1.6.0.0-37.b17.fc13.x86_64.  Try "yum downgrade java-1.6.0-openjdk" to downgrade to this version (which works for me on a clean F13 x86_64 install).
Comment 3 Peter Gückel 2010-06-10 21:08:21 EDT
I upgraded to java-1.6.0-openjdk-1.6.0.0-39.b18.fc13.x86_64, which is in updates (not updates-testing) and the problem persists. No java plugin in firefox.
Comment 4 Peter Gückel 2010-06-10 21:29:49 EDT
(In reply to comment #3)

After updating, I checked /usr/lib64/mozilla/plugins and I see that there is a link libjavaplugin.so that points to /etc/alternatives/libjavaplugin.so.x86_64, which is also a link that points to /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaNPPlugin.so, which does not exist. There is a IcedTeaPlugin.so (no NP) there, however.

Should the link point there?

OK, I ran:

alternatives --remove libjavaplugin.so.x86_64 /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaNPPlugin.so

and now the link was automatically shifted (alternatives reports that "status is auto") to /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so.

I now have an icedtea plugin in firefox.

The link that is provided by the java openjdk-plugin package is wrong.
Comment 5 Andre Robatino 2010-06-11 00:43:25 EDT
I now have the same problem (no Java plugin in Firefox) as you, even though I didn't before.  I seem to have the same problem (wrong links).  Not being familiar with alternatives, can you check if there is 100% CPU usage while running Java applets, as reported in bug #592553?
Comment 6 Andre Robatino 2010-06-11 01:02:13 EDT
FYI your problem has been reported as bug #602906.
Comment 7 Andre Robatino 2010-06-11 02:12:28 EDT
I fixed the alternatives link and the 100% CPU usage is still there.  Will downgrade to the original release version until a good version is released.
Comment 8 Peter Gückel 2010-06-11 12:41:53 EDT
(In reply to comment #5)
> I now have the same problem (no Java plugin in Firefox) as you, even though I
> didn't before.  I seem to have the same problem (wrong links).  Not being
> familiar with alternatives, can you check if there is 100% CPU usage while
> running Java applets, as reported in bug #592553?    

No, there is no 100% java problem. When viewing a java web page in firefox, the browser uses at most 2% of processor power and X sometimes jumps from 2% to 4%. That is all.
Comment 9 Andre Robatino 2010-06-15 12:19:55 EDT
The latest version 1.6.0.0-41.b18.fc13.x86_64 is working properly for me (link fixed, 100% CPU gone).
Comment 10 Peter Gückel 2010-07-09 18:12:13 EDT
I am now on java-1.6.0-openjdk-1.6.0.0-41.b18.fc13.x86_64 and all seems well.