Bug 602906 - Wrong alternate link for openjdk plugin
Summary: Wrong alternate link for openjdk plugin
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Martin Matejovic
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 595191 603364 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-11 00:56 UTC by Felipe Contreras
Modified: 2010-06-21 13:08 UTC (History)
13 users (show)

Fixed In Version: java-1.6.0-openjdk-1.6.0.0-39.b18.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-15 16:03:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felipe Contreras 2010-06-11 00:56:35 UTC
Description of problem:
The link to the plugin is wrong:
/etc/alternatives/libjavaplugin.so -> /usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaNPPlugin.so

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-plugin 1.6.0.0

Obviously, the link should point to:
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/IcedTeaPlugin.so

Comment 1 Andre Robatino 2010-06-11 06:24:58 UTC
The name was correct in the older version.  Since the new version suffers from 100% CPU usage as well (see bug #592553), one may as well "fix" this by downgrading to the older version and hope that the symlink problem is fixed in the next one.

[andre@compaq-pc ~]$ rpm -ql java-1.6.0-openjdk-plugin-1.6.0.0-37.b17.fc13.x86_64
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/IcedTeaNPPlugin.so
[andre@compaq-pc ~]$

Comment 2 Andre Robatino 2010-06-11 06:36:06 UTC
These bugs (wrong link and 100% CPU usage) now exist in Rawhide as well.  Should the Version of this bug be bumped to rawhide, or should it be cloned?

Comment 3 Howard Ning 2010-06-11 10:43:07 UTC
The new version is pushed to stable without any fixes.

Comment 4 Martin Matejovic 2010-06-14 12:12:39 UTC
*** Bug 603364 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2010-06-15 09:23:20 UTC
java-1.6.0-openjdk-1.6.0.0-41.b18.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-41.b18.fc13

Comment 6 Andre Robatino 2010-06-15 09:41:58 UTC
This update fixes both this bug and bug #592553 for me.

Comment 7 Mihai Harpau 2010-06-15 10:13:15 UTC
Update from comment 5 fixed the bug for me too.

Comment 8 Fedora Update System 2010-06-15 16:03:26 UTC
java-1.6.0-openjdk-1.6.0.0-41.b18.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Jason Farrell 2010-06-15 18:42:14 UTC
*** Bug 595191 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2010-06-16 12:36:32 UTC
java-1.6.0-openjdk-1.6.0.0-39.b18.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-39.b18.fc12

Comment 11 Fedora Update System 2010-06-21 13:08:14 UTC
java-1.6.0-openjdk-1.6.0.0-39.b18.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.