Bug 597648

Summary: greasemonkey add-on kills firefox
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: gecko-bugs-nobody, mcepl, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-30 21:13:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tom Horsley 2010-05-30 00:05:54 UTC
Description of problem:

Install greasemonkey from the firefox add-ons search page. Restart firefox
according to instructions to have plugin take effect. That much appears
to work fine, but then exit firefox and try to start firefox again, and
it always exits with exit status 1.

Run firefox -safe-mode, select disable all add-ons. Now you can run firefox
again, you can even go enable the add-ons, as long as you don't enable
greasemonkey.

If you do enable greasemonkey, the next time you start firefox,
it exits again with status 1.

Version-Release number of selected component (if applicable):
firefox-3.6.3-4.fc13.x86_64

How reproducible:
100% on fedora 13, on fedora 12 greasemonkey seems to work fine.

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
FF stops running

Expected results:
FF keeps working, and I can use greasemonkey scripts.

Additional info:

I initially chimed in on bug 593042 because it seemed similar, but
now I'm not so sure, so I make this separate bug.

Comment 1 Andre Robatino 2010-05-30 02:50:28 UTC
I have greasemonkey 0.8.20100408.6 and mozilla-adblockplus in firefox-3.6.3-4.fc13.x86_64, apparently without any problems (they worked okay in F12 also).  I suppose you could try uninstalling all extensions, cleaning out all extensions* files and directories from ~/.mozilla/firefox/*.default, then reinstalling them in case something there is broken.

Comment 2 Tom Horsley 2010-05-30 03:04:02 UTC
This discussion:

http://groups.google.com/group/greasemonkey-users/browse_thread/thread/f74ba159c50110ca

led to the conclusion that this is really mozilla bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=551152

My /home is indeed a symlink. When I change my user's definition to
point to the actual path rather than using the symlink /home as
part of the path, I can run firefox with greasemonkey enabled.

Comment 3 Matěj Cepl 2010-05-30 21:13:08 UTC
(In reply to comment #2)
> My /home is indeed a symlink. When I change my user's definition to
> point to the actual path rather than using the symlink /home as
> part of the path, I can run firefox with greasemonkey enabled.    

We don't support symlinked $HOME. Especially with Firefox you get into serious conflicts with SELinux which doesn't like symlinks on important directories.

Closing as NOTABUG.

Comment 4 Tom Horsley 2010-05-30 21:30:07 UTC
I don't get into selinux trouble if I have selinux turned off :-).

However, I have now switched to a bind mount of /home instead of a symlink,
and that seems to work fine, there may be other tools that like that better
than a symlink out there, so it is probably a better idea.