Bug 593042 - Firefox didn't come up after installing Flashblock extension and selecting "restart"
Firefox didn't come up after installing Flashblock extension and selecting "r...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 13:26 EDT by k.t.
Modified: 2011-04-12 08:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-12 08:49:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description k.t. 2010-05-17 13:26:01 EDT
Description of problem:
Firefox didn't reappear after installing Flashblock extension and selecting restart.
I already had Quakelive extension installed the same way and then Firefox did restart without issues.

Version-Release number of selected component (if applicable):
Fedora 13 beta

How reproducible:
don't know

Steps to Reproduce:
1. install quakelive?
2. install flashblock?
3.
  
Actual results:
does not restart, only closes

Expected results:
restart

Additional info:
Comment 1 Tom Horsley 2010-05-29 16:45:20 EDT
I'm having similar problems with completely different extensions. After I
install a few (I've tried different orderings), firefox won't start anymore,
exiting with status 1, but no messages printed to stderr.

I'm trying to install Adblock Plus, Greasemonkey, PDF Download, and
Sidebar Bookmark Selector. It seems like I can maybe install any two,
and then firefox starts exiting with status 1 after installing the 3rd.
Doesn't seem to matter which order I install them in.

I currently have the following versions of stuff installed:

firefox-3.6.3-4.fc13.x86_64
nspluginwrapper-1.3.0-11.fc13.x86_64
nspluginwrapper-1.3.0-11.fc13.i686
flash-plugin-10.0.45.2-release.i386

After it breaks, I can rm -rf ~/.mozilla and firefox will run again
until I install "too many" additional plugins.
Comment 2 Tom Horsley 2010-05-29 20:07:20 EDT
I've added bug 597648 for the above comment #1 problem, I'm no longer
sure it is the same as the original bug.
Comment 3 Chris Campbell 2011-01-11 11:11:50 EST
If you disable all extensions, plug-ins and themes, does Firefox work as intended? If it does, then this is not a Firefox issue. If you install one or more extensions/plug-ins and they break Firefox, then the issue is with the extensions or plug-ins. If the extensions in question are provided by Fedora, please open a bug report against the plug-in; otherwise perhaps the plug-in has a support channel itself.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Chris Campbell 2011-04-12 08:49:32 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.